glibc: add patch fixing the build with binutils 2.29
Fixes the following build failure, which occurs on all architectures: /tmp/cc6APNmN.s: Assembler messages: /tmp/cc6APNmN.s: Error: `loc1@GLIBC_2.17' can't be versioned to common symbol 'loc1' /tmp/cc6APNmN.s: Error: `loc2@GLIBC_2.17' can't be versioned to common symbol 'loc2' /tmp/cc6APNmN.s: Error: `locs@GLIBC_2.17' can't be versioned to common symbol 'locs' ../o-iterator.mk:9: recipe for target '/tmp/output/build/glibc-2.25/build/misc/regexp.os' failed Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
dcfdf82e53
commit
cf821efbd0
65
package/glibc/0005-fix-binutils-2-29-build.patch
Normal file
65
package/glibc/0005-fix-binutils-2-29-build.patch
Normal file
@ -0,0 +1,65 @@
|
||||
From: H.J. Lu <hjl.tools@gmail.com>
|
||||
Date: Fri, 23 Jun 2017 21:38:46 +0000 (-0700)
|
||||
Subject: Avoid .symver on common symbols [BZ #21666]
|
||||
X-Git-Tag: glibc-2.26~241
|
||||
X-Git-Url: https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commitdiff_plain;h=388b4f1a02f3a801965028bbfcd48d905638b797
|
||||
|
||||
Avoid .symver on common symbols [BZ #21666]
|
||||
|
||||
The .symver directive on common symbol just creates a new common symbol,
|
||||
not an alias and the newer assembler with the bug fix for
|
||||
|
||||
https://sourceware.org/bugzilla/show_bug.cgi?id=21661
|
||||
|
||||
will issue an error. Before the fix, we got
|
||||
|
||||
$ readelf -sW libc.so | grep "loc[12s]"
|
||||
5109: 00000000003a0608 8 OBJECT LOCAL DEFAULT 36 loc1
|
||||
5188: 00000000003a0610 8 OBJECT LOCAL DEFAULT 36 loc2
|
||||
5455: 00000000003a0618 8 OBJECT LOCAL DEFAULT 36 locs
|
||||
6575: 00000000003a05f0 8 OBJECT GLOBAL DEFAULT 36 locs@GLIBC_2.2.5
|
||||
7156: 00000000003a05f8 8 OBJECT GLOBAL DEFAULT 36 loc1@GLIBC_2.2.5
|
||||
7312: 00000000003a0600 8 OBJECT GLOBAL DEFAULT 36 loc2@GLIBC_2.2.5
|
||||
|
||||
in libc.so. The versioned loc1, loc2 and locs have the wrong addresses.
|
||||
After the fix, we got
|
||||
|
||||
$ readelf -sW libc.so | grep "loc[12s]"
|
||||
6570: 000000000039e3b8 8 OBJECT GLOBAL DEFAULT 34 locs@GLIBC_2.2.5
|
||||
7151: 000000000039e3c8 8 OBJECT GLOBAL DEFAULT 34 loc1@GLIBC_2.2.5
|
||||
7307: 000000000039e3c0 8 OBJECT GLOBAL DEFAULT 34 loc2@GLIBC_2.2.5
|
||||
|
||||
[BZ #21666]
|
||||
* misc/regexp.c (loc1): Add __attribute__ ((nocommon));
|
||||
(loc2): Likewise.
|
||||
(locs): Likewise.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
[Backported from upstream commit
|
||||
388b4f1a02f3a801965028bbfcd48d905638b797, to fix the build with
|
||||
binutils 2.29.]
|
||||
---
|
||||
diff --git a/misc/regexp.c b/misc/regexp.c
|
||||
index 19d76c0..eaea7c3 100644
|
||||
--- a/misc/regexp.c
|
||||
+++ b/misc/regexp.c
|
||||
@@ -29,14 +29,15 @@
|
||||
|
||||
#if SHLIB_COMPAT (libc, GLIBC_2_0, GLIBC_2_23)
|
||||
|
||||
-/* Define the variables used for the interface. */
|
||||
-char *loc1;
|
||||
-char *loc2;
|
||||
+/* Define the variables used for the interface. Avoid .symver on common
|
||||
+ symbol, which just creates a new common symbol, not an alias. */
|
||||
+char *loc1 __attribute__ ((nocommon));
|
||||
+char *loc2 __attribute__ ((nocommon));
|
||||
compat_symbol (libc, loc1, loc1, GLIBC_2_0);
|
||||
compat_symbol (libc, loc2, loc2, GLIBC_2_0);
|
||||
|
||||
/* Although we do not support the use we define this variable as well. */
|
||||
-char *locs;
|
||||
+char *locs __attribute__ ((nocommon));
|
||||
compat_symbol (libc, locs, locs, GLIBC_2_0);
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user