package/safeclib: bump to version 3.7.1
Drop patch (already in version) and so autoreconf https://github.com/rurban/safeclib/blob/v3.7.1/ChangeLog Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
d0e519ad3d
commit
cc27267ae4
@ -1,63 +0,0 @@
|
|||||||
From 94c612016834d7bdc2b721ff5f4f5e158bda6fdd Mon Sep 17 00:00:00 2001
|
|
||||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
||||||
Date: Sat, 8 Jan 2022 21:49:22 +0100
|
|
||||||
Subject: [PATCH] configure.ac: add --disable-hardening option
|
|
||||||
|
|
||||||
Allow the user to disable hardening which is enabled by default since
|
|
||||||
version 02092020 and
|
|
||||||
https://github.com/rurban/safeclib/commit/caa4408eb4a5c767f0474258af3b6ccf444e10aa
|
|
||||||
to avoid the following build failure when the toolchain doesn't support
|
|
||||||
stack-protector:
|
|
||||||
|
|
||||||
/home/buildroot/autobuild/instance-3/output-1/host/opt/ext-toolchain/m68k-buildroot-uclinux-uclibc/bin/ld.real: ../src/.libs/libsafec-3.6.0.a(safe_mem_constraint.o): in function `handle_mem_bos_chk_warn':
|
|
||||||
safe_mem_constraint.c:(.text+0x40): undefined reference to `__stack_chk_guard'
|
|
||||||
|
|
||||||
Fixes:
|
|
||||||
- http://autobuild.buildroot.org/results/a481ee2d26a094358b0298617cce691be3077f22
|
|
||||||
|
|
||||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
||||||
[Upstream status: https://github.com/rurban/safeclib/pull/107]
|
|
||||||
---
|
|
||||||
configure.ac | 27 +++++++++++++++++++--------
|
|
||||||
1 file changed, 19 insertions(+), 8 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 55756b06..f852ed44 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -383,6 +383,21 @@ AC_ARG_ENABLE(debug-build,
|
|
||||||
esac], [enable_debug_build=false ])
|
|
||||||
AM_CONDITIONAL(ENABLE_DEBUG_BUILD, test "x$enable_debug_build" = "xtrue")
|
|
||||||
|
|
||||||
+AC_ARG_ENABLE(hardening,
|
|
||||||
+ AS_HELP_STRING([--disable-hardening],
|
|
||||||
+ [disable hardening @<:@default=no@:>@]),
|
|
||||||
+ [case "${enableval}" in
|
|
||||||
+ yes) enable_hardening=true ;;
|
|
||||||
+ no) enable_hardening=false ;;
|
|
||||||
+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-hardening]) ;;
|
|
||||||
+ esac], [enable_hardening=true])
|
|
||||||
+
|
|
||||||
+if test "x$enable_hardening" = "xtrue" ; then
|
|
||||||
+ AX_APPEND_COMPILE_FLAGS([-fstack-protector-strong -fstack-clash-protection -fcf-protection],
|
|
||||||
+ [WARN_CFLAGS],[$ax_ccf_err])
|
|
||||||
+ AX_APPEND_LINK_FLAGS([-fstack-protector-strong -fstack-clash-protection -fcf-protection],
|
|
||||||
+ [WARN_LDFLAGS],[$ax_ccf_err])
|
|
||||||
+fi
|
|
||||||
|
|
||||||
AC_MSG_NOTICE([Check programs])
|
|
||||||
# ===============================================
|
|
||||||
@@ -543,10 +562,6 @@ case $host_os in
|
|
||||||
[],[$ax_ccf_err])
|
|
||||||
;;
|
|
||||||
esac
|
|
||||||
-AX_APPEND_COMPILE_FLAGS([-fstack-protector-strong -fstack-clash-protection -fcf-protection],
|
|
||||||
- [WARN_CFLAGS],[$ax_ccf_err])
|
|
||||||
-AX_APPEND_LINK_FLAGS([-fstack-protector-strong -fstack-clash-protection -fcf-protection],
|
|
||||||
- [WARN_LDFLAGS],[$ax_ccf_err])
|
|
||||||
|
|
||||||
if test x$ax_cv_check_cflags__Wrestrict = xyes; then
|
|
||||||
AC_DEFINE([HAVE_WARNING_RESTRICT], 1, [Have -Wrestrict])
|
|
||||||
--
|
|
||||||
2.34.1
|
|
||||||
|
|
@ -1,5 +1,5 @@
|
|||||||
# From https://github.com/rurban/safeclib/releases/tag/v02092020
|
# From https://github.com/rurban/safeclib/releases/tag/v3.7.1
|
||||||
sha256 d374bdcbfcdc4c9a76abed3707667372ca212fd87a369e7bcaaa54e716d27c0a libsafec-02092020.tar.xz
|
sha256 71d3ec970f930bd980f2a41127228eeedfc53749e4c6b203329adc4ff7df32a7 safeclib-3.7.1.tar.xz
|
||||||
|
|
||||||
# Hash for license file
|
# Hash for license file
|
||||||
sha256 c33e77efd5781e3d59a2bb648c82d2a615035ef0d24cf58880380e3af906510b COPYING
|
sha256 c33e77efd5781e3d59a2bb648c82d2a615035ef0d24cf58880380e3af906510b COPYING
|
||||||
|
@ -4,15 +4,13 @@
|
|||||||
#
|
#
|
||||||
################################################################################
|
################################################################################
|
||||||
|
|
||||||
SAFECLIB_VERSION = 02092020
|
SAFECLIB_VERSION = 3.7.1
|
||||||
SAFECLIB_SITE = \
|
SAFECLIB_SITE = \
|
||||||
https://github.com/rurban/safeclib/releases/download/v$(SAFECLIB_VERSION)
|
https://github.com/rurban/safeclib/releases/download/v$(SAFECLIB_VERSION)
|
||||||
SAFECLIB_SOURCE = libsafec-$(SAFECLIB_VERSION).tar.xz
|
SAFECLIB_SOURCE = safeclib-$(SAFECLIB_VERSION).tar.xz
|
||||||
SAFECLIB_LICENSE = MIT
|
SAFECLIB_LICENSE = MIT
|
||||||
SAFECLIB_LICENSE_FILES = COPYING
|
SAFECLIB_LICENSE_FILES = COPYING
|
||||||
SAFECLIB_INSTALL_STAGING = YES
|
SAFECLIB_INSTALL_STAGING = YES
|
||||||
# We're patching configure.ac
|
|
||||||
SAFECLIB_AUTORECONF = YES
|
|
||||||
# -fstack-protector-strong is used by default. Disable that so the
|
# -fstack-protector-strong is used by default. Disable that so the
|
||||||
# BR2_SSP_* options in the toolchain wrapper are used instead
|
# BR2_SSP_* options in the toolchain wrapper are used instead
|
||||||
SAFECLIB_CONF_OPTS = --disable-hardening
|
SAFECLIB_CONF_OPTS = --disable-hardening
|
||||||
|
Loading…
Reference in New Issue
Block a user