package/luajit: bump to version 41fb94defa8f830ce69a8122b03f6ac3216d392a
The LuaJIT project switches to a rolling release scheme. Now, the version contains the timestamp of its latest commit. The timestamp can be seen in build log: ==== Successfully installed LuaJIT 2.1.1693350652 to /usr ==== diff COPYRIGHT: -Copyright (C) 2005-2022 Mike Pall. All rights reserved. +Copyright (C) 2005-2023 Mike Pall. All rights reserved. Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
ab4f3fafaa
commit
c9dcd9e459
@ -6,7 +6,7 @@ Index: b/Makefile
|
|||||||
===================================================================
|
===================================================================
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -45,8 +45,7 @@
|
@@ -50,8 +50,7 @@
|
||||||
INSTALL_MAN= $(INSTALL_SHARE)/man/man1
|
INSTALL_MAN= $(INSTALL_SHARE)/man/man1
|
||||||
INSTALL_PKGCONFIG= $(INSTALL_LIB)/pkgconfig
|
INSTALL_PKGCONFIG= $(INSTALL_LIB)/pkgconfig
|
||||||
|
|
||||||
@ -16,7 +16,7 @@ Index: b/Makefile
|
|||||||
INSTALL_ANAME= libluajit-$(ABIVER).a
|
INSTALL_ANAME= libluajit-$(ABIVER).a
|
||||||
INSTALL_SOSHORT1= libluajit-$(ABIVER).so
|
INSTALL_SOSHORT1= libluajit-$(ABIVER).so
|
||||||
INSTALL_SOSHORT2= libluajit-$(ABIVER).so.$(MAJVER)
|
INSTALL_SOSHORT2= libluajit-$(ABIVER).so.$(MAJVER)
|
||||||
@@ -61,7 +60,6 @@
|
@@ -66,7 +65,6 @@
|
||||||
INSTALL_SHORT1= $(INSTALL_LIB)/$(INSTALL_SOSHORT1)
|
INSTALL_SHORT1= $(INSTALL_LIB)/$(INSTALL_SOSHORT1)
|
||||||
INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT2)
|
INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT2)
|
||||||
INSTALL_T= $(INSTALL_BIN)/$(INSTALL_TNAME)
|
INSTALL_T= $(INSTALL_BIN)/$(INSTALL_TNAME)
|
||||||
|
@ -6,12 +6,12 @@ Index: b/Makefile
|
|||||||
===================================================================
|
===================================================================
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -33,7 +33,7 @@
|
@@ -38,7 +38,7 @@
|
||||||
INSTALL_BIN= $(DPREFIX)/bin
|
INSTALL_BIN= $(DPREFIX)/bin
|
||||||
INSTALL_LIB= $(DPREFIX)/$(MULTILIB)
|
INSTALL_LIB= $(DPREFIX)/$(MULTILIB)
|
||||||
INSTALL_SHARE= $(DPREFIX)/share
|
INSTALL_SHARE= $(DPREFIX)/share
|
||||||
-INSTALL_DEFINC= $(DPREFIX)/include/luajit-$(MAJVER).$(MINVER)
|
-INSTALL_DEFINC= $(DPREFIX)/include/luajit-$(MMVERSION)
|
||||||
+INSTALL_DEFINC= $(DPREFIX)/include
|
+INSTALL_DEFINC= $(DPREFIX)/include
|
||||||
INSTALL_INC= $(INSTALL_DEFINC)
|
INSTALL_INC= $(INSTALL_DEFINC)
|
||||||
|
|
||||||
INSTALL_LJLIBD= $(INSTALL_SHARE)/luajit-$(VERSION)
|
INSTALL_LJLIBD= $(INSTALL_SHARE)/luajit-$(MMVERSION)
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
# Locally calculated
|
# Locally calculated
|
||||||
sha256 835035b244c3dc3d3d19bdd5ac623af90b84207e6330fb78f9fa51d6e200d760 luajit-8635cbabf3094c4d8bd00578c7d812bea87bb2d3.tar.gz
|
sha256 b518721280390e4cec1af30f6819d86756ce4234d82410a55a4e121855f64e08 luajit-41fb94defa8f830ce69a8122b03f6ac3216d392a.tar.gz
|
||||||
|
|
||||||
# Locally calculated
|
# Locally calculated
|
||||||
sha256 52fc5b15ac968ed81aabb4c1e23ab3bce50f57a5764e9cdca86b463a11072921 COPYRIGHT
|
sha256 1130331ac861a4b4520e9c8ad0814efdc6f1e79ea55ea9c460c73733d13ccb5f COPYRIGHT
|
||||||
|
@ -4,7 +4,7 @@
|
|||||||
#
|
#
|
||||||
################################################################################
|
################################################################################
|
||||||
|
|
||||||
LUAJIT_VERSION = 8635cbabf3094c4d8bd00578c7d812bea87bb2d3
|
LUAJIT_VERSION = 41fb94defa8f830ce69a8122b03f6ac3216d392a
|
||||||
LUAJIT_SITE = $(call github,LuaJIT,LuaJIT,$(LUAJIT_VERSION))
|
LUAJIT_SITE = $(call github,LuaJIT,LuaJIT,$(LUAJIT_VERSION))
|
||||||
LUAJIT_LICENSE = MIT
|
LUAJIT_LICENSE = MIT
|
||||||
LUAJIT_LICENSE_FILES = COPYRIGHT
|
LUAJIT_LICENSE_FILES = COPYRIGHT
|
||||||
@ -33,6 +33,15 @@ LUAJIT_HOST_CC = $(HOSTCC) -m32
|
|||||||
LUAJIT_XCFLAGS += -DLUAJIT_DISABLE_GC64
|
LUAJIT_XCFLAGS += -DLUAJIT_DISABLE_GC64
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
# emulation of git archive with .gitattributes & export-subst
|
||||||
|
# Timestamp of the $(LUAJIT_VERSION) commit, obtained in the LuaJit
|
||||||
|
# repo, with: git show -s --format=%ct $(LUAJIT_VERSION)
|
||||||
|
define LUAJIT_GEN_RELVER_FILE
|
||||||
|
echo 1693350652 >$(@D)/.relver
|
||||||
|
endef
|
||||||
|
LUAJIT_POST_EXTRACT_HOOKS = LUAJIT_GEN_RELVER_FILE
|
||||||
|
HOST_LUAJIT_POST_EXTRACT_HOOKS = LUAJIT_GEN_RELVER_FILE
|
||||||
|
|
||||||
# We unfortunately can't use TARGET_CONFIGURE_OPTS, because the luajit
|
# We unfortunately can't use TARGET_CONFIGURE_OPTS, because the luajit
|
||||||
# build system uses non conventional variable names.
|
# build system uses non conventional variable names.
|
||||||
define LUAJIT_BUILD_CMDS
|
define LUAJIT_BUILD_CMDS
|
||||||
|
Loading…
Reference in New Issue
Block a user