package/libbpf: bump to version 1.1.0

Drop patch which is now upstream.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
James Hilliard 2023-01-09 15:03:29 -07:00 committed by Thomas Petazzoni
parent dce238f045
commit c9d6f0e1c8
3 changed files with 2 additions and 40 deletions

View File

@ -1,38 +0,0 @@
From 68e6f83f223ebf3fbf0d94c0f4592e5e6773f0c1 Mon Sep 17 00:00:00 2001
From: Tobias Waldekranz <tobias@waldekranz.com>
Date: Fri, 14 Oct 2022 21:14:14 +0200
Subject: [PATCH] Makefile: Fix cross-compilation for 32-bit targets
Determining the correct library installation path (lib vs. lib64)
using uname(1) breaks in cross compilation scenarios where word widths
differ between the host and target system.
Instead, source the information from the compilers '-dumpmachine'
option (supported by both GCC and Clang).
We call this the "host" architecture, using the same nomenclature as
Autotools (--host configure option).
Upstream: https://github.com/libbpf/libbpf/commit/68e6f83f223ebf3fbf0d94c0f4592e5e6773f0c1
Signed-off-by: Tobias Waldekranz <tobias@waldekranz.com>
---
src/Makefile | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/src/Makefile b/src/Makefile
index 3cd0854..d535f81 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -77,7 +77,8 @@ INSTALL = install
DESTDIR ?=
-ifeq ($(filter-out %64 %64be %64eb %64le %64el s390x, $(shell uname -m)),)
+HOSTARCH = $(firstword $(subst -, ,$(shell $(CC) -dumpmachine)))
+ifeq ($(filter-out %64 %64be %64eb %64le %64el s390x, $(HOSTARCH)),)
LIBSUBDIR := lib64
else
LIBSUBDIR := lib
--
2.34.1

View File

@ -1,5 +1,5 @@
# Locally calculated
sha256 3d6afde67682c909e341bf194678a8969f17628705af25f900d5f68bd299cb03 libbpf-1.0.1.tar.gz
sha256 5da826c968fdb8a2f714701cfef7a4b7078be030cf58b56143b245816301cbb8 libbpf-1.1.0.tar.gz
sha256 847f4addbd56e2d5be20c4ea0845e972672fc07b755fadaae5f7abd35d71e349 LICENSE
sha256 e1638b9a0c68ca90fad3df1d6b4e430804d2fbdc15e58d02cffddfae38953bbf LICENSE.BSD-2-Clause
sha256 0b9a4febcdee6de55872501d5c1a8f5d8b0d1650cd4d5351995ceb22e889f8ca LICENSE.LGPL-2.1

View File

@ -4,7 +4,7 @@
#
################################################################################
LIBBPF_VERSION = 1.0.1
LIBBPF_VERSION = 1.1.0
LIBBPF_SITE = $(call github,libbpf,libbpf,v$(LIBBPF_VERSION))
LIBBPF_LICENSE = GPL-2.0, LGPL-2.1, BSD-2-Clause
LIBBPF_LICENSE_FILES = LICENSE LICENSE.BSD-2-Clause LICENSE.LGPL-2.1