Merge branch '2010-05-15-fixes' of git://git.busybox.net/~tpetazzoni/git/buildroot
This commit is contained in:
commit
c89b725978
@ -1,7 +1,7 @@
|
||||
config BR2_PACKAGE_AVAHI
|
||||
bool "avahi"
|
||||
select BR2_PACKAGE_GETTEXT if BR2_ENABLE_LOCALE
|
||||
select BR2_PACKAGE_LIBINTL if BR2_ENABLE_LOCALE
|
||||
select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
|
||||
select BR2_PACKAGE_LIBINTL if BR2_NEEDS_GETTEXT
|
||||
help
|
||||
Avahi is a system which facilitates service
|
||||
discovery on a local network.
|
||||
|
@ -82,7 +82,7 @@ AVAHI_CONF_OPT = --localstatedir=/var \
|
||||
--with-autoipd-user=default \
|
||||
--with-autoipd-group=default
|
||||
|
||||
AVAHI_DEPENDENCIES = $(if $(BR2_PACKAGE_GETTEXT),gettext) host-intltool
|
||||
AVAHI_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT),gettext libintl) host-intltool
|
||||
|
||||
ifneq ($(BR2_PACKAGE_AVAHI_DAEMON)$(BR2_PACKAGE_AVAHI_AUTOIPD),)
|
||||
AVAHI_DEPENDENCIES += libdaemon
|
||||
|
@ -79,8 +79,6 @@ else
|
||||
CAIRO_CONF_OPT += --disable-svg
|
||||
endif
|
||||
|
||||
HOST_CAIRO_DEPENDENCIES = host-pkg-config host-pixman host-fontconfig
|
||||
|
||||
HOST_CAIRO_CONF_OPT = \
|
||||
--enable-ps \
|
||||
--enable-pdf \
|
||||
@ -90,4 +88,3 @@ HOST_CAIRO_CONF_OPT = \
|
||||
--disable-svg
|
||||
|
||||
$(eval $(call AUTOTARGETS,package,cairo))
|
||||
$(eval $(call AUTOTARGETS,package,cairo,host))
|
||||
|
@ -1,5 +1,6 @@
|
||||
config BR2_PACKAGE_GETTEXT
|
||||
bool "gettext"
|
||||
depends on BR2_NEEDS_GETTEXT
|
||||
help
|
||||
The GNU `gettext' utilities are a set of tools that provide a
|
||||
framework to help other GNU packages produce multi-lingual
|
||||
@ -21,6 +22,7 @@ config BR2_PACKAGE_GETTEXT_STATIC
|
||||
|
||||
config BR2_PACKAGE_LIBINTL
|
||||
bool "libintl"
|
||||
depends on BR2_NEEDS_GETTEXT
|
||||
help
|
||||
Selecting this package installs all of gettext in the staging
|
||||
directory and the shared library for it's use in the target.
|
||||
|
@ -2,8 +2,8 @@ config BR2_PACKAGE_GMPC
|
||||
bool "gmpc"
|
||||
depends on BR2_PACKAGE_LIBGTK2
|
||||
select BR2_PACKAGE_LIBGLIB2
|
||||
select BR2_PACKAGE_GETTEXT
|
||||
select BR2_PACKAGE_LIBINTL
|
||||
select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
|
||||
select BR2_PACKAGE_LIBINTL if BR2_NEEDS_GETTEXT
|
||||
select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
|
||||
select BR2_PACKAGE_LIBMPD
|
||||
select BR2_PACKAGE_LIBCURL
|
||||
|
@ -11,7 +11,8 @@ GMPC_CONF_ENV = ac_cv_lib_curl_curl_global_init=yes \
|
||||
ac_cv_path_GOB2=$(GOB2_HOST_BINARY)
|
||||
GMPC_CONF_OPT = --disable-mmkeys
|
||||
|
||||
GMPC_DEPENDENCIES = libglib2 libgtk2 libglade libcurl libmpd host-gob2 host-intltool
|
||||
GMPC_DEPENDENCIES = libglib2 libgtk2 libglade libcurl libmpd host-gob2 host-intltool \
|
||||
$(if $(BR2_NEEDS_GETTEXT),gettext libintl)
|
||||
|
||||
ifeq ($(BR2_PACKAGE_XLIB_LIBSM),y)
|
||||
GMPC_DEPENENCIES += xlib_libSM
|
||||
|
@ -1,7 +1,7 @@
|
||||
config BR2_PACKAGE_GREP
|
||||
bool "grep"
|
||||
select BR2_PACKAGE_GETTEXT if BR2_ENABLE_LOCALE
|
||||
select BR2_PACKAGE_LIBINTL if BR2_ENABLE_LOCALE
|
||||
select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
|
||||
select BR2_PACKAGE_LIBINTL if BR2_NEEDS_GETTEXT
|
||||
help
|
||||
The GNU regular expression matcher.
|
||||
|
||||
|
@ -8,6 +8,6 @@ GREP_SOURCE:=grep-$(GREP_VERSION).tar.bz2
|
||||
GREP_SITE:=$(BR2_GNU_MIRROR)/grep
|
||||
GREP_CONF_OPT = --disable-perl-regexp --without-included-regex
|
||||
|
||||
GREP_DEPENDENCIES = $(if $(BR2_ENABLE_LOCALE),gettext libintl)
|
||||
GREP_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT),gettext libintl)
|
||||
|
||||
$(eval $(call AUTOTARGETS,package,grep))
|
||||
|
@ -2,8 +2,8 @@ config BR2_PACKAGE_HAL
|
||||
bool "hal"
|
||||
select BR2_PACKAGE_EXPAT
|
||||
select BR2_PACKAGE_LIBGLIB2
|
||||
select BR2_PACKAGE_GETTEXT
|
||||
select BR2_PACKAGE_LIBINTL
|
||||
select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
|
||||
select BR2_PACKAGE_LIBINTL if BR2_NEEDS_GETTEXT
|
||||
select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
|
||||
select BR2_PACKAGE_DBUS
|
||||
select BR2_PACKAGE_DBUS_EXPAT
|
||||
|
@ -79,7 +79,7 @@ $(TARGET_DIR)/$(HAL_TARGET_BINARY): $(HAL_DIR)/hald/hald
|
||||
rm -f $(TARGET_DIR)/usr/libexec/$$file; \
|
||||
done
|
||||
|
||||
hal: host-pkg-config host-libxml-parser-perl dbus-glib hwdata udev $(TARGET_DIR)/$(HAL_TARGET_BINARY)
|
||||
hal: host-pkg-config host-libxml-parser-perl dbus-glib hwdata udev $(if $(BR2_NEEDS_GETTEXT),gettext libintl) $(TARGET_DIR)/$(HAL_TARGET_BINARY)
|
||||
|
||||
hal-clean:
|
||||
rm -f $(TARGET_DIR)/etc/dbus-1/system.d/hal.conf
|
||||
|
@ -8,7 +8,7 @@ define LIBCAP_BUILD_CMDS
|
||||
endef
|
||||
|
||||
define LIBCAP_INSTALL_STAGING_CMDS
|
||||
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) LIBATTR=no DESTDIR=$(STAGING_DIR) install
|
||||
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) LIBATTR=no DESTDIR=$(STAGING_DIR) prefix=/usr lib=lib install
|
||||
endef
|
||||
|
||||
define LIBCAP_INSTALL_TARGET_CMDS
|
||||
@ -20,7 +20,7 @@ define HOST_LIBCAP_BUILD_CMDS
|
||||
endef
|
||||
|
||||
define HOST_LIBCAP_INSTALL_CMDS
|
||||
$(HOST_MAKE_ENV) $(MAKE) -C $(@D) LIBATTR=no DESTDIR=$(HOST_DIR) install
|
||||
$(HOST_MAKE_ENV) $(MAKE) -C $(@D) LIBATTR=no DESTDIR=$(HOST_DIR) prefix=/usr lib=lib install
|
||||
endef
|
||||
|
||||
$(eval $(call GENTARGETS,package,libcap))
|
||||
|
@ -7,6 +7,8 @@ LIBCGICC_VERSION=3.2.9
|
||||
LIBCGICC_SITE=$(BR2_GNU_MIRROR)/cgicc
|
||||
LIBCGICC_SOURCE=cgicc-$(LIBCGICC_VERSION).tar.gz
|
||||
LIBCGICC_INSTALL_STAGING=YES
|
||||
LIBCGICC_LIBTOOL_PATCH=NO
|
||||
LIBCGICC_AUTORECONF=YES
|
||||
|
||||
LIBCGICC_CONF_OPT = \
|
||||
--disable-demos \
|
||||
|
@ -1,7 +1,7 @@
|
||||
config BR2_PACKAGE_LIBGLIB2
|
||||
bool "libglib2"
|
||||
select BR2_PACKAGE_GETTEXT
|
||||
select BR2_PACKAGE_LIBINTL
|
||||
select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
|
||||
select BR2_PACKAGE_LIBINTL if BR2_NEEDS_GETTEXT
|
||||
select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
|
||||
help
|
||||
Low-level core library that forms the basis of GTK+ and GNOME.
|
||||
|
@ -55,7 +55,7 @@ HOST_LIBGLIB2_CONF_OPT = \
|
||||
--disable-gtk-doc \
|
||||
--enable-debug=no \
|
||||
|
||||
LIBGLIB2_DEPENDENCIES = gettext libintl host-pkg-config host-libglib2
|
||||
LIBGLIB2_DEPENDENCIES = host-pkg-config host-libglib2 $(if $(BR2_NEEDS_GETTEXT),gettext libintl)
|
||||
|
||||
HOST_LIBGLIB2_DEPENDENCIES = host-pkg-config
|
||||
|
||||
|
@ -1,5 +1,6 @@
|
||||
config BR2_PACKAGE_LIBICONV
|
||||
bool "libiconv"
|
||||
depends on !BR2_ENABLE_LOCALE
|
||||
help
|
||||
unicode conversion library
|
||||
|
||||
|
@ -10,7 +10,7 @@ LIBIDN_INSTALL_STAGING = YES
|
||||
LIBIDN_INSTALL_TARGET = YES
|
||||
LIBIDN_CONF_OPT = --enable-shared --disable-java --enable-csharp=no
|
||||
LIBIDN_LIBTOOL_PATCH = NO
|
||||
LIBIDN_DEPENDENCIES = host-pkg-config gettext $(if $(BR2_PACKAGE_LIBICONV),libiconv)
|
||||
LIBIDN_DEPENDENCIES = host-pkg-config $(if $(BR2_NEEDS_GETTEXT),gettext) $(if $(BR2_PACKAGE_LIBICONV),libiconv)
|
||||
|
||||
$(eval $(call AUTOTARGETS,package,libidn))
|
||||
|
||||
|
@ -26,6 +26,6 @@ LIBSOUP_CONF_OPT = \
|
||||
--without-gnome \
|
||||
--disable-gtk-doc
|
||||
|
||||
LIBSOUP_DEPENDENCIES = gettext libintl host-pkg-config host-libglib2 libglib2 libxml2
|
||||
LIBSOUP_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT),gettext libintl) host-pkg-config host-libglib2 libglib2 libxml2
|
||||
|
||||
$(eval $(call AUTOTARGETS,package,libsoup))
|
||||
|
@ -1,7 +1,12 @@
|
||||
config BR2_PACKAGE_LMBENCH
|
||||
bool "lmbench"
|
||||
# Uses pmap_set, pmap__unset, pmap_getport, etc.
|
||||
depends on BR2_INET_RPC
|
||||
help
|
||||
LMbench is a suite of simple, portable,
|
||||
ANSI/C microbenchmarks for UNIX/POSIX.
|
||||
|
||||
http://sourceforge.net/projects/lmbench/
|
||||
|
||||
comment "lmbench requires a toolchain with RPC support"
|
||||
depends on !BR2_INET_RPC
|
||||
|
@ -54,8 +54,7 @@ $(LTRACE_DIR)/.configured: $(LTRACE_DIR)/.patched
|
||||
touch $@
|
||||
|
||||
$(LTRACE_DIR)/$(LTRACE_BINARY): $(LTRACE_DIR)/.configured
|
||||
$(MAKE) CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld ARCH=$(LTRACE_ARCH) \
|
||||
-C $(LTRACE_DIR)
|
||||
$(MAKE) ARCH=$(LTRACE_ARCH) -C $(LTRACE_DIR)
|
||||
|
||||
$(TARGET_DIR)/$(LTRACE_TARGET_BINARY): $(LTRACE_DIR)/$(LTRACE_BINARY)
|
||||
#$(MAKE) DESTDIR=$(TARGET_DIR) ARCH=$(LTRACE_ARCH) -C $(LTRACE_DIR) install
|
||||
|
@ -74,7 +74,7 @@ $(LVM2_DIR)/.configured: $(LVM2_DIR)/.unpacked
|
||||
|
||||
|
||||
$(LVM2_DIR)/.built: $(LVM2_DIR)/.configured
|
||||
$(MAKE1) CC=$(TARGET_CC) RANLIB=$(TARGET_RANLIB) AR=$(TARGET_AR) -C $(LVM2_DIR) DESTDIR=$(STAGING_DIR)
|
||||
$(MAKE1) -C $(LVM2_DIR) DESTDIR=$(STAGING_DIR)
|
||||
$(MAKE1) -C $(LVM2_DIR) DESTDIR=$(STAGING_DIR) install
|
||||
# Fixup write permissions so that the files can be overwritten
|
||||
# several times in the $(TARGET_DIR)
|
||||
|
@ -1,7 +1,7 @@
|
||||
config BR2_PACKAGE_MAKE
|
||||
bool "make"
|
||||
select BR2_PACKAGE_GETTEXT if BR2_ENABLE_LOCALE
|
||||
select BR2_PACKAGE_LIBINTL if BR2_ENABLE_LOCALE
|
||||
select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
|
||||
select BR2_PACKAGE_LIBINTL if BR2_NEEDS_GETTEXT
|
||||
help
|
||||
A tool which controls the generation of executables and other
|
||||
non-source files of a program from the program's source files.
|
||||
|
@ -56,7 +56,7 @@ $(TARGET_DIR)/$(GNUMAKE_TARGET_BINARY): $(GNUMAKE_DIR)/$(GNUMAKE_BINARY)
|
||||
rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
|
||||
$(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
|
||||
|
||||
make: $(if $(BR2_PACKAGE_GETTEXT),gettext) $(TARGET_DIR)/$(GNUMAKE_TARGET_BINARY)
|
||||
make: $(if $(BR2_NEEDS_GETTEXT),gettext) $(TARGET_DIR)/$(GNUMAKE_TARGET_BINARY)
|
||||
|
||||
make-clean:
|
||||
$(MAKE) DESTDIR=$(TARGET_DIR) -C $(GNUMAKE_DIR) uninstall
|
||||
|
@ -1,8 +1,6 @@
|
||||
config BR2_PACKAGE_LIBMPD
|
||||
bool "libmpd"
|
||||
select BR2_PACKAGE_LIBGLIB2
|
||||
select BR2_PACKAGE_GETTEXT
|
||||
select BR2_PACKAGE_LIBINTL
|
||||
select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
|
||||
help
|
||||
High-level client library for accessing Music Player Daemon.
|
||||
|
@ -1,32 +0,0 @@
|
||||
--- mutt-1.5.16.oorig/Makefile.in 2007-09-02 22:16:23.000000000 +0200
|
||||
+++ mutt-1.5.16/Makefile.in 2007-09-02 22:19:49.000000000 +0200
|
||||
@@ -164,12 +164,6 @@
|
||||
DBX = @DBX@
|
||||
DEBUGGER = @DEBUGGER@
|
||||
|
||||
-# $(makedoc_OBJECTS): $(makedoc_SOURCES)
|
||||
-# $(HOST_CC) $(DEFS) $(AM_CPPFLAGS) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) -c $<
|
||||
-
|
||||
-# makedoc: $(makedoc_OBJECTS) $(makedoc_DEPENDENCIES)
|
||||
-# @rm -rf makedoc
|
||||
-# $(HOST_CC) $(AM_CFLAGS) $(LDFLAGS) $(makedoc_LDFLAGS) $(makedoc_OBJECTS) $(makedoc_LDADD) -o makedoc
|
||||
DEFS = -DPKGDATADIR=\"$(pkgdatadir)\" -DSYSCONFDIR=\"$(sysconfdir)\" \
|
||||
-DBINDIR=\"$(bindir)\" -DMUTTLOCALEDIR=\"$(datadir)/locale\" \
|
||||
-DHAVE_CONFIG_H=1
|
||||
@@ -447,9 +441,15 @@
|
||||
|
||||
clean-binPROGRAMS:
|
||||
-test -z "$(bin_PROGRAMS)" || rm -f $(bin_PROGRAMS)
|
||||
+
|
||||
+$(makedoc_OBJECTS): $(makedoc_SOURCES)
|
||||
+ $(CC_FOR_BUILD) -DHAVE_UNISTD_H -DHAVE_GETOPT_H -DHAVE_STRERROR -c $< ;#$(DEFS) $(AM_CPPFLAGS) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) -c $<
|
||||
+#makedoc: $(makedoc_OBJECTS) $(makedoc_DEPENDENCIES)
|
||||
+# @rm -rf makedoc
|
||||
+# $(CC_FOR_BUILD) $(AM_CFLAGS) $(LDFLAGS) $(makedoc_LDFLAGS) $(makedoc_OBJECTS) $(makedoc_LDADD) -o makedoc
|
||||
makedoc$(EXEEXT): $(makedoc_OBJECTS) $(makedoc_DEPENDENCIES)
|
||||
@rm -f makedoc$(EXEEXT)
|
||||
- $(LINK) $(makedoc_LDFLAGS) $(makedoc_OBJECTS) $(makedoc_LDADD) $(LIBS)
|
||||
+ $(CC_FOR_BUILD) $(makedoc_LDFLAGS) $(makedoc_OBJECTS) $(makedoc_LDADD) $(LIBS) -o $@
|
||||
mutt$(EXEEXT): $(mutt_OBJECTS) $(mutt_DEPENDENCIES)
|
||||
@rm -f mutt$(EXEEXT)
|
||||
$(LINK) $(mutt_LDFLAGS) $(mutt_OBJECTS) $(mutt_LDADD) $(LIBS)
|
21
package/mutt/mutt-1.5.17+20080114-nodoc.patch
Normal file
21
package/mutt/mutt-1.5.17+20080114-nodoc.patch
Normal file
@ -0,0 +1,21 @@
|
||||
Disable the documentation build
|
||||
|
||||
The documentation tool is compiled for the target, but executed on the
|
||||
host. We don't bother fixing this, as we don't care of the
|
||||
documentation in Buildroot.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
|
||||
Index: mutt-1.5.17+20080114/Makefile.am
|
||||
===================================================================
|
||||
--- mutt-1.5.17+20080114.orig/Makefile.am 2010-05-15 18:15:08.000000000 +0200
|
||||
+++ mutt-1.5.17+20080114/Makefile.am 2010-05-15 18:15:17.000000000 +0200
|
||||
@@ -9,7 +9,7 @@
|
||||
IMAP_INCLUDES = -I$(top_srcdir)/imap
|
||||
endif
|
||||
|
||||
-SUBDIRS = m4 po intl doc contrib $(IMAP_SUBDIR)
|
||||
+SUBDIRS = m4 po intl contrib $(IMAP_SUBDIR)
|
||||
|
||||
bin_SCRIPTS = muttbug flea @SMIMEAUX_TARGET@
|
||||
|
@ -7,70 +7,19 @@ MUTT_VERSION:=1.5.17+20080114
|
||||
MUTT_SOURCE:=mutt_$(MUTT_VERSION).orig.tar.gz
|
||||
MUTT_PATCH:=mutt_$(MUTT_VERSION)-1.diff.gz
|
||||
MUTT_SITE:=$(BR2_DEBIAN_MIRROR)/debian/pool/main/m/mutt/
|
||||
MUTT_DIR:=$(BUILD_DIR)/mutt-$(MUTT_VERSION)
|
||||
MUTT_CAT:=$(ZCAT)
|
||||
MUTT_BINARY:=mutt
|
||||
MUTT_TARGET_BINARY:=usr/bin/mutt
|
||||
|
||||
$(DL_DIR)/$(MUTT_SOURCE):
|
||||
$(call DOWNLOAD,$(MUTT_SITE),$(MUTT_SOURCE))
|
||||
|
||||
$(DL_DIR)/$(MUTT_PATCH):
|
||||
$(call DOWNLOAD,$(MUTT_SITE),$(MUTT_PATCH))
|
||||
|
||||
$(MUTT_DIR)/.unpacked: $(DL_DIR)/$(MUTT_SOURCE) $(DL_DIR)/$(MUTT_PATCH)
|
||||
$(MUTT_CAT) $(DL_DIR)/$(MUTT_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
|
||||
toolchain/patch-kernel.sh $(MUTT_DIR) package/mutt/ mutt-$(MUTT_VERSION)\*.patch
|
||||
ifneq ($(MUTT_PATCH),)
|
||||
(cd $(MUTT_DIR) && $(MUTT_CAT) $(DL_DIR)/$(MUTT_PATCH) | patch -p1)
|
||||
if [ -d $(MUTT_DIR)/debian/patches ]; then \
|
||||
toolchain/patch-kernel.sh $(MUTT_DIR) $(MUTT_DIR)/debian/patches \*.patch; \
|
||||
fi
|
||||
endif
|
||||
touch $@
|
||||
|
||||
$(MUTT_DIR)/.configured: $(MUTT_DIR)/.unpacked
|
||||
(cd $(MUTT_DIR); rm -rf config.cache; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
$(TARGET_CONFIGURE_ARGS) \
|
||||
./configure $(QUIET) \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--prefix=/usr \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_IPV6) \
|
||||
$(DISABLE_NLS) \
|
||||
MUTT_DEPENDENCIES=ncurses
|
||||
MUTT_CONF_OPT = \
|
||||
--disable-smtp \
|
||||
--disable-iconv \
|
||||
--without-wc-funcs \
|
||||
)
|
||||
touch $@
|
||||
--without-wc-funcs
|
||||
MUTT_AUTORECONF=YES
|
||||
|
||||
$(MUTT_DIR)/$(MUTT_BINARY): $(MUTT_DIR)/.configured
|
||||
$(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(MUTT_DIR)
|
||||
define MUTT_APPLY_DEBIAN_PATCHES
|
||||
if [ -d $(@D)/debian/patches ]; then \
|
||||
toolchain/patch-kernel.sh $(@D) $(@D)/debian/patches \*.patch; \
|
||||
fi
|
||||
endef
|
||||
|
||||
$(TARGET_DIR)/$(MUTT_TARGET_BINARY): $(MUTT_DIR)/$(MUTT_BINARY)
|
||||
cp -dpf $(MUTT_DIR)/$(MUTT_BINARY) $@
|
||||
$(STRIPCMD) $(STRIP_STRIP_ALL) $@
|
||||
MUTT_POST_PATCH_HOOKS += MUTT_APPLY_DEBIAN_PATCHES
|
||||
|
||||
mutt-source: $(DL_DIR)/$(MUTT_SOURCE) $(DL_DIR)/$(MUTT_PATCH)
|
||||
|
||||
mutt-unpacked: $(MUTT_DIR)/.unpacked
|
||||
|
||||
mutt: ncurses $(TARGET_DIR)/$(MUTT_TARGET_BINARY)
|
||||
|
||||
mutt-clean:
|
||||
-$(MAKE) -C $(MUTT_DIR) clean
|
||||
rm -f $(TARGET_DIR)/$(MUTT_TARGET_BINARY)
|
||||
|
||||
mutt-dirclean:
|
||||
rm -rf $(MUTT_DIR)
|
||||
#############################################################
|
||||
#
|
||||
# Toplevel Makefile options
|
||||
#
|
||||
#############################################################
|
||||
ifeq ($(BR2_PACKAGE_MUTT),y)
|
||||
TARGETS+=mutt
|
||||
endif
|
||||
$(eval $(call AUTOTARGETS,package,mutt))
|
@ -1,7 +1,13 @@
|
||||
config BR2_PACKAGE_NETSNMP
|
||||
bool "netsnmp"
|
||||
# Build with external toolchains is broken, libtool strips
|
||||
# --sysroot at link time
|
||||
depends on !BR2_TOOLCHAIN_EXTERNAL
|
||||
help
|
||||
Suite of applications used to implement SNMP v1, SNMP v2c, and
|
||||
SNMP v3 using both IPv4 and IPv6.
|
||||
|
||||
http://net-snmp.sourceforge.net/
|
||||
|
||||
comment "lmbench is broken with external toolchains"
|
||||
depends on BR2_TOOLCHAIN_EXTERNAL
|
||||
|
36
package/ntp/ntp-4.2.4_p5-nano.patch
Normal file
36
package/ntp/ntp-4.2.4_p5-nano.patch
Normal file
@ -0,0 +1,36 @@
|
||||
Fixes the MOD_NANO build failure
|
||||
|
||||
ntp_loopfilter.c: In function 'local_clock':
|
||||
ntp_loopfilter.c:571: error: 'MOD_NANO' undeclared (first use in this function)
|
||||
ntp_loopfilter.c:571: error: (Each undeclared identifier is reported only once
|
||||
ntp_loopfilter.c:571: error: for each function it appears in.)
|
||||
ntp_loopfilter.c: In function 'loop_config':
|
||||
ntp_loopfilter.c:896: error: 'MOD_NANO' undeclared (first use in this function)
|
||||
|
||||
Taken from
|
||||
http://cvs.fedoraproject.org/viewvc/devel/ntp/ntp-4.2.4p7-nano.patch?revision=1.1&content-type=text/plain&view=co
|
||||
|
||||
See the discussion at
|
||||
https://bugs.launchpad.net/ubuntu/+source/ntp/+bug/412242 for more
|
||||
details and links. The below fix is not a correct fix, but only a
|
||||
workaround. The real fix required changes to kernel/libc headers.
|
||||
|
||||
Index: ntp-4.2.4p5/include/ntp_syscall.h
|
||||
===================================================================
|
||||
--- ntp-4.2.4p5.orig/include/ntp_syscall.h 2010-05-14 17:34:48.000000000 +0200
|
||||
+++ ntp-4.2.4p5/include/ntp_syscall.h 2010-05-14 17:35:13.000000000 +0200
|
||||
@@ -14,6 +14,14 @@
|
||||
# include <sys/timex.h>
|
||||
#endif
|
||||
|
||||
+#if defined(ADJ_NANO) && !defined(MOD_NANO)
|
||||
+#define MOD_NANO ADJ_NANO
|
||||
+#endif
|
||||
+
|
||||
+#if defined(ADJ_TAI) && !defined(MOD_TAI)
|
||||
+#define MOD_TAI ADJ_TAI
|
||||
+#endif
|
||||
+
|
||||
#ifndef NTP_SYSCALLS_LIBC
|
||||
#ifdef NTP_SYSCALLS_STD
|
||||
# define ntp_adjtime(t) syscall(SYS_ntp_adjtime, (t))
|
20
package/pango/S25pango
Normal file
20
package/pango/S25pango
Normal file
@ -0,0 +1,20 @@
|
||||
#!/bin/sh
|
||||
#
|
||||
# run pango-querymodules if needed
|
||||
|
||||
FILE=/etc/pango/pango.modules
|
||||
|
||||
case "$1" in
|
||||
start|"")
|
||||
if [ ! -f $FILE ] ; then
|
||||
mkdir -p /etc/pango
|
||||
/usr/bin/pango-querymodules > "$FILE"
|
||||
fi
|
||||
;;
|
||||
stop)
|
||||
;;
|
||||
*)
|
||||
echo "Usage: $0 {start|stop}" >&2
|
||||
exit 1
|
||||
;;
|
||||
esac
|
@ -40,16 +40,7 @@ PANGO_CONF_ENV = ac_cv_func_posix_getpwuid_r=yes glib_cv_stack_grows=no \
|
||||
PANGO_CONF_OPT = --enable-shared --enable-static \
|
||||
--enable-explicit-deps=no --disable-debug
|
||||
|
||||
HOST_PANGO_CONF_OPT = \
|
||||
--disable-static \
|
||||
$(if $(BR2_PACKAGE_XORG7),--with-x,--without-x) \
|
||||
--disable-debug \
|
||||
|
||||
PANGO_DEPENDENCIES = gettext libintl host-pkg-config host-pango libglib2 cairo
|
||||
|
||||
HOST_PANGO_DEPENDENCIES = host-pkg-config host-cairo host-libglib2 host-autoconf host-automake
|
||||
|
||||
HOST_PANGO_AUTORECONF = YES
|
||||
PANGO_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT),gettext libintl) host-pkg-config libglib2 cairo
|
||||
|
||||
ifeq ($(BR2_PACKAGE_XORG7),y)
|
||||
PANGO_CONF_OPT += --with-x \
|
||||
@ -61,12 +52,7 @@ else
|
||||
endif
|
||||
|
||||
$(eval $(call AUTOTARGETS,package,pango))
|
||||
$(eval $(call AUTOTARGETS,package,pango,host))
|
||||
|
||||
$(PANGO_HOOK_POST_INSTALL):
|
||||
mkdir -p $(TARGET_DIR)/etc/pango
|
||||
$(PANGO_HOST_BINARY) > $(TARGET_DIR)/etc/pango/pango.modules
|
||||
$(SED) 's~$(HOST_DIR)~~g' $(TARGET_DIR)/etc/pango/pango.modules
|
||||
$(INSTALL) -m 755 package/pango/S25pango $(TARGET_DIR)/etc/init.d/
|
||||
touch $@
|
||||
|
||||
PANGO_HOST_BINARY:=$(HOST_DIR)/usr/bin/pango-querymodules
|
||||
|
@ -67,7 +67,7 @@ config BR2_PACKAGE_PHP_EXT_FTP
|
||||
|
||||
config BR2_PACKAGE_PHP_EXT_GETTEXT
|
||||
bool "gettext"
|
||||
select BR2_PACKAGE_GETTEXT
|
||||
select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
|
||||
help
|
||||
gettext support
|
||||
|
||||
|
@ -84,7 +84,7 @@ endif
|
||||
|
||||
ifeq ($(BR2_PACKAGE_PHP_EXT_GETTEXT),y)
|
||||
PHP_CONF_OPT += --with-gettext=$(STAGING_DIR)/usr
|
||||
PHP_DEPENDENCIES += gettext
|
||||
PHP_DEPENDENCIES += $(if $(BR2_NEEDS_GETTEXT),gettext)
|
||||
endif
|
||||
|
||||
ifeq ($(BR2_PACKAGE_PHP_EXT_GMP),y)
|
||||
|
@ -1,8 +1,8 @@
|
||||
config BR2_PACKAGE_PSMISC
|
||||
bool "psmisc"
|
||||
select BR2_PACKAGE_NCURSES
|
||||
select BR2_PACKAGE_GETTEXT if BR2_ENABLE_LOCALE
|
||||
select BR2_PACKAGE_LIBINTL if BR2_ENABLE_LOCALE
|
||||
select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
|
||||
select BR2_PACKAGE_LIBINTL if BR2_NEEDS_GETTEXT
|
||||
help
|
||||
Helpful /proc related utilities such as pstree, fuser, and killall
|
||||
|
||||
|
@ -7,12 +7,6 @@ PSMISC_VERSION:=22.8
|
||||
PSMISC_SOURCE:=psmisc-$(PSMISC_VERSION).tar.gz
|
||||
PSMISC_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/psmisc
|
||||
PSMISC_AUTORECONF:=NO
|
||||
PSMISC_DEPENDENCIES:=ncurses
|
||||
|
||||
ifeq ($(BR2_ENABLE_LOCALE),y)
|
||||
# psmisc gets confused and forgets to link with libintl
|
||||
PSMISC_MAKE_OPT:=LIBS=-lintl
|
||||
PSMISC_DEPENDENCIES+= gettext libintl
|
||||
endif
|
||||
PSMISC_DEPENDENCIES:=ncurses $(if $(BR2_NEEDS_GETTEXT),gettext libintl)
|
||||
|
||||
$(eval $(call AUTOTARGETS,package,psmisc))
|
||||
|
@ -59,8 +59,12 @@ config BR2_PACKAGE_QUAGGA_NETLINK
|
||||
|
||||
config BR2_PACKAGE_QUAGGA_SNMP
|
||||
bool "SNMP support"
|
||||
depends on !BR2_TOOLCHAIN_EXTERNAL
|
||||
select BR2_PACKAGE_NETSNMP
|
||||
|
||||
comment "quagga snmp support broken with external toolchains"
|
||||
depends on BR2_TOOLCHAIN_EXTERNAL
|
||||
|
||||
config BR2_PACKAGE_QUAGGA_TCP_ZEBRA
|
||||
bool "TCP/IP socket connection between zebra and proto daemon"
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
config BR2_PACKAGE_SAMBA
|
||||
bool "samba"
|
||||
select BR2_PACKAGE_LIBICONV
|
||||
select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
|
||||
help
|
||||
Provides print services to all manner of SMB/CIFS clients,
|
||||
including the numerous versions of Microsoft Windows
|
||||
|
@ -16,7 +16,7 @@ SAMBA_INSTALL_TARGET = YES
|
||||
|
||||
|
||||
SAMBA_DEPENDENCIES = \
|
||||
libiconv \
|
||||
$(if $(BR2_ENABLE_LOCALE),,libiconv) \
|
||||
$(if $(BR2_PACKAGE_SAMBA_RPCCLIENT),readline) \
|
||||
$(if $(BR2_PACKAGE_SAMBA_SMBCLIENT),readline) \
|
||||
$(if $(BR2_PACKAGE_SAMBA_AVAHI),avahi) \
|
||||
|
@ -2,8 +2,8 @@ config BR2_PACKAGE_SSHFS
|
||||
bool "sshfs (FUSE)"
|
||||
select BR2_PACKAGE_LIBFUSE
|
||||
select BR2_PACKAGE_LIBGLIB2
|
||||
select BR2_PACKAGE_GETTEXT
|
||||
select BR2_PACKAGE_LIBINTL
|
||||
select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
|
||||
select BR2_PACKAGE_LIBINTL if BR2_NEEDS_GETTEXT
|
||||
select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
|
||||
depends on BR2_PACKAGE_OPENSSH
|
||||
help
|
||||
|
@ -11,6 +11,6 @@ SSHFS_AUTORECONF:=NO
|
||||
SSHFS_INSTALL_STAGING:=NO
|
||||
SSHFS_INSTALL_TARGET:=YES
|
||||
|
||||
SSHFS_DEPENDENCIES = libglib2 libfuse
|
||||
SSHFS_DEPENDENCIES = libglib2 libfuse $(if $(BR2_NEEDS_GETTEXT),gettext libintl)
|
||||
|
||||
$(eval $(call AUTOTARGETS,package,sshfs))
|
||||
|
@ -1,5 +1,7 @@
|
||||
config BR2_PACKAGE_STARTUP_NOTIFICATION
|
||||
bool "startup-notification"
|
||||
select BR2_PACKAGE_XLIB_LIBX11
|
||||
depends on BR2_PACKAGE_XORG7
|
||||
help
|
||||
Startup-notification is a library used to monitor application startup.
|
||||
|
||||
|
@ -9,6 +9,7 @@ STARTUP_NOTIFICATION_SITE = http://freedesktop.org/software/startup-notification
|
||||
STARTUP_NOTIFICATION_AUTORECONF = NO
|
||||
STARTUP_NOTIFICATION_INSTALL_STAGING = YES
|
||||
STARTUP_NOTIFICATION_INSTALL_TARGET = YES
|
||||
STARTUP_NOTIFICATION = xlib_libX11
|
||||
|
||||
STARTUP_NOTIFICATION_CONF_ENV = lf_cv_sane_realloc=yes
|
||||
|
||||
|
@ -23,7 +23,7 @@ $(UEMACS_DIR)/.unpacked: $(DL_DIR)/$(UEMACS_SOURCE)
|
||||
|
||||
$(UEMACS_DIR)/$(UEMACS_BINARY): $(UEMACS_DIR)/.unpacked
|
||||
$(MAKE) -C $(UEMACS_DIR) \
|
||||
CC="$(TARGET_CC)" DEFINES="-DAUTOCONF -DPOSIX -DUSG" CFLAGS+="$(TARGET_CFLAGS) " LIBS=-lncurses
|
||||
CC="$(TARGET_CC)" DEFINES="-DAUTOCONF -DPOSIX -DUSG" CFLAGS+="$(TARGET_CFLAGS) " LIBS="$(TARGET_CFLAGS) -lncurses"
|
||||
$(STRIPCMD) $(UEMACS_DIR)/$(UEMACS_BINARY)
|
||||
|
||||
$(TARGET_DIR)/$(UEMACS_TARGET_BINARY): $(UEMACS_DIR)/$(UEMACS_BINARY)
|
||||
|
@ -1,7 +1,7 @@
|
||||
config BR2_PACKAGE_UTIL-LINUX
|
||||
bool "util-linux"
|
||||
select BR2_PACKAGE_GETTEXT if BR2_ENABLE_LOCALE
|
||||
select BR2_PACKAGE_LIBINTL if BR2_ENABLE_LOCALE
|
||||
select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
|
||||
select BR2_PACKAGE_LIBINTL if BR2_NEEDS_GETTEXT
|
||||
depends on BR2_INET_RPC
|
||||
help
|
||||
Various useful/essential Linux utilities.
|
||||
|
@ -18,8 +18,8 @@ else
|
||||
UTIL-LINUX_SCHED_UTILS:=--disable-schedutils
|
||||
endif
|
||||
|
||||
ifeq ($(BR2_PACKAGE_LIBINTL),y)
|
||||
UTIL-LINUX_DEPENDENCIES += libintl
|
||||
ifeq ($(BR2_NEEDS_GETTEXT),y)
|
||||
UTIL-LINUX_DEPENDENCIES += gettext libintl
|
||||
UTIL-LINUX_MAKE_OPT = LIBS=-lintl
|
||||
endif
|
||||
|
||||
|
@ -26,7 +26,7 @@ $(VPNC_BINARY): $(VPNC_DIR)/.unpacked
|
||||
rm -f $@
|
||||
$(MAKE) $(TARGET_CONFIGURE_OPTS) INCLUDE=$(STAGING_DIR)/usr/include \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
LDFLAGS+=-lgcrypt LDFLAGS+=-lgpg-error \
|
||||
LDFLAGS+=-lgcrypt LDFLAGS+=-lgpg-error LDFLAGS+="$(TARGET_CFLAGS)" \
|
||||
CC="$(TARGET_CC)" -C $(VPNC_DIR)
|
||||
|
||||
$(VPNC_TARGET_BINARY): $(VPNC_BINARY)
|
||||
@ -38,7 +38,7 @@ $(VPNC_TARGET_BINARY): $(VPNC_BINARY)
|
||||
MANDIR=/usr/share/man \
|
||||
VERSION=$(VPNC_VERSION) \
|
||||
INCLUDE=$(STAGING_DIR)/usr/include \
|
||||
LDFLAGS="-lgcrypt -lgpg-error" \
|
||||
LDFLAGS="-lgcrypt -lgpg-error $(TARGET_CFLAGS)" \
|
||||
-C $(VPNC_DIR) install
|
||||
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(VPNC_TARGET_BINARY)
|
||||
|
||||
|
@ -56,6 +56,14 @@ config BR2_ENABLE_LOCALE_WHITELIST
|
||||
will be available on the target - That purely depends on the
|
||||
support for that locale in the selected packages.
|
||||
|
||||
# uClibc toolchains require a separatly-compiled gettext/libintl when
|
||||
# locale support is enabled. This isn't necessary with glibc
|
||||
# toolchains as glibc includes gettext/libintl.
|
||||
config BR2_NEEDS_GETTEXT
|
||||
bool
|
||||
default y if (BR2_TOOLCHAIN_BUILDROOT && BR2_ENABLE_LOCALE)
|
||||
default y if (BR2_TOOLCHAIN_EXTERNAL_UCLIBC && BR2_ENABLE_LOCALE)
|
||||
|
||||
config BR2_USE_WCHAR
|
||||
bool "Enable WCHAR support"
|
||||
help
|
||||
|
@ -231,6 +231,15 @@ check_arm_abi = \
|
||||
exit 1 ; \
|
||||
fi ; \
|
||||
|
||||
#
|
||||
# Check that the external toolchain supports C++
|
||||
#
|
||||
check_cplusplus = \
|
||||
if ! test -x $(TARGET_CXX) ; then \
|
||||
echo "BR2_INSTALL_LIBSTDCPP is selected but C++ support not available in external toolchain" ; \
|
||||
exit 1 ; \
|
||||
fi ; \
|
||||
|
||||
#
|
||||
# Check that the cross-compiler given in the configuration exists
|
||||
#
|
||||
@ -288,6 +297,9 @@ endif
|
||||
ifeq ($(BR2_arm),y)
|
||||
$(Q)$(call check_arm_abi)
|
||||
endif
|
||||
ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
|
||||
$(Q)$(call check_cplusplus)
|
||||
endif
|
||||
ifeq ($(BR2_TOOLCHAIN_EXTERNAL_UCLIBC),y)
|
||||
$(Q)$(call check_uclibc,$(SYSROOT_DIR))
|
||||
else
|
||||
|
Loading…
Reference in New Issue
Block a user