package/at: convert local patches to git format
Convert local patches to git format. Note that some of them change name because of use of 'git format-patch'. Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
0a73b9b962
commit
c77d8494a1
@ -1,25 +1,26 @@
|
||||
From 195d30e2e01fe2f91ed3bdaeec3982aa66b309dd Mon Sep 17 00:00:00 2001
|
||||
From d2bdcff4748f4c1961118b9467bab302b403ef9f Mon Sep 17 00:00:00 2001
|
||||
From: Marc Kleine-Budde <mkl@pengutronix.de>
|
||||
Date: Tue, 1 Dec 2009 20:57:45 +0100
|
||||
Subject: [PATCH 5/5] Makefile.in: replace IROOT by DESTDIR
|
||||
Subject: [PATCH] Makefile.in: replace IROOT by DESTDIR
|
||||
|
||||
This patch replaces IROOT by DESTDIR, which is the autotools standard
|
||||
variable. For backwards compatibilty IROOT overwrites the DESTDIR.
|
||||
|
||||
[Vincent: tweak the patch for the new version]
|
||||
|
||||
Signed-off-by: Marc Kleine-Budde <mkl@pengutronix.de>
|
||||
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
||||
[Vincent: tweak the patch for the new version]
|
||||
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
|
||||
[Giulio: convert patch to git format]
|
||||
---
|
||||
Makefile.in | 68 ++++++++++++++++++++++++++++++++-----------------------------
|
||||
Makefile.in | 68 ++++++++++++++++++++++++++++-------------------------
|
||||
1 file changed, 36 insertions(+), 32 deletions(-)
|
||||
|
||||
diff --git a/Makefile.in b/Makefile.in
|
||||
index 06544f9..1f699d9 100644
|
||||
index 4c11913..61e7b1d 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -17,6 +17,10 @@ atdocdir = $(docdir)/at
|
||||
etcdir = @ETCDIR@
|
||||
@@ -18,6 +18,10 @@ etcdir = @ETCDIR@
|
||||
atjobdir = @ATJBD@
|
||||
systemdsystemunitdir = @systemdsystemunitdir@
|
||||
|
||||
+ifdef IROOT
|
||||
@ -29,7 +30,7 @@ index 06544f9..1f699d9 100644
|
||||
DAEMON_USERNAME = @DAEMON_USERNAME@
|
||||
DAEMON_GROUPNAME= @DAEMON_GROUPNAME@
|
||||
LOADAVG_MX = @LOADAVG_MX@
|
||||
@@ -91,41 +95,41 @@ atrun: atrun.in
|
||||
@@ -93,41 +97,41 @@ atrun: atrun.in
|
||||
$(CC) -c $(CFLAGS) $(DEFS) $*.c
|
||||
|
||||
install: all
|
||||
@ -104,5 +105,5 @@ index 06544f9..1f699d9 100644
|
||||
|
||||
dist: checkin $(DIST) $(LIST) Filelist.asc
|
||||
--
|
||||
2.4.10
|
||||
2.25.1
|
||||
|
||||
|
@ -1,21 +1,25 @@
|
||||
[PATCH]: Makefile.in: fix make install for non-root, don't strip
|
||||
From 2dd7c3c5b590a3115568175acc888f8e36919d71 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Korsgaard <jacmet@sunsite.dk>
|
||||
Date: Fri, 23 Jul 2021 16:47:56 +0200
|
||||
Subject: [PATCH] Makefile.in: fix make install for non-root, don't strip
|
||||
|
||||
Buildroot will ensure all files are owned by root and stripped anyway
|
||||
(if needed) before the rootfs is created.
|
||||
|
||||
[Vincent: tweak the patch for the new version]
|
||||
|
||||
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
|
||||
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
||||
[Vincent: tweak the patch for the new version]
|
||||
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
|
||||
[Giulio: convert patch to git format]
|
||||
---
|
||||
Makefile.in | 43 +++++++++++++++++++++----------------------
|
||||
1 file changed, 21 insertions(+), 22 deletions(-)
|
||||
|
||||
diff --git a/Makefile.in b/Makefile.in
|
||||
index 1f699d9..f313f9b 100644
|
||||
index 61e7b1d..9f89b1f 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -95,41 +95,40 @@ atrun: atrun.in
|
||||
@@ -97,41 +97,40 @@ atrun: atrun.in
|
||||
$(CC) -c $(CFLAGS) $(DEFS) $*.c
|
||||
|
||||
install: all
|
||||
@ -79,5 +83,5 @@ index 1f699d9..f313f9b 100644
|
||||
|
||||
dist: checkin $(DIST) $(LIST) Filelist.asc
|
||||
--
|
||||
2.4.10
|
||||
2.25.1
|
||||
|
@ -1,17 +1,23 @@
|
||||
[PATCH]: fix getloadavg.c compilation, revert to 3.1.10 version
|
||||
From 4eda31cea9fb3c77fe2748a65960f24ffb42f9ff Mon Sep 17 00:00:00 2001
|
||||
From: Peter Korsgaard <jacmet@sunsite.dk>
|
||||
Date: Fri, 23 Jul 2021 16:51:17 +0200
|
||||
Subject: [PATCH] getloadavg: fix getloadavg.c compilation, revert to 3.1.10
|
||||
version
|
||||
|
||||
getloadavg.c shipped with 3.1.13 doesn't compile because it references
|
||||
headers not shipped. Fix it by simply reverting to the 3.1.10 version.
|
||||
|
||||
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
|
||||
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
|
||||
[Giulio: convert patch to git format]
|
||||
---
|
||||
getloadavg.c | 7 ++++---
|
||||
getloadavg.c | 7 ++++---
|
||||
1 file changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
Index: at-3.1.13/getloadavg.c
|
||||
===================================================================
|
||||
--- at-3.1.13.orig/getloadavg.c
|
||||
+++ at-3.1.13/getloadavg.c
|
||||
diff --git a/getloadavg.c b/getloadavg.c
|
||||
index cf5869f..23d18eb 100644
|
||||
--- a/getloadavg.c
|
||||
+++ b/getloadavg.c
|
||||
@@ -66,11 +66,12 @@ Boston, MA 02110-1301 USA */
|
||||
|
||||
/* This should always be first. */
|
||||
@ -28,3 +34,6 @@ Index: at-3.1.13/getloadavg.c
|
||||
|
||||
#ifndef HAVE_GETLOADAVG
|
||||
|
||||
--
|
||||
2.25.1
|
||||
|
Loading…
Reference in New Issue
Block a user