package/libdnet: bump to version 1.16.4

Drop second patch (already in version)

https://github.com/ofalk/libdnet/releases/tag/libdnet-1.16.2
https://github.com/ofalk/libdnet/releases/tag/libdnet-1.16.3
https://github.com/ofalk/libdnet/releases/tag/libdnet-1.16.4

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Fabrice Fontaine 2023-09-24 23:02:24 +02:00 committed by Peter Korsgaard
parent 285f136a15
commit c76f5f24c7
4 changed files with 2 additions and 29 deletions

View File

@ -653,7 +653,6 @@ package/libcorrect/0002-CMakeLists.txt-conditionally-use-fsanitize-address.patch
package/libcuefile/0001-fix-static-link.patch Upstream
package/libdaemon/0001-testd-use-unistd-h-instead-of-sys-unistd-h.patch Upstream
package/libdnet/0001-python-makefile.patch Upstream
package/libdnet/0002-Correct-path-to-string-h-from-bsd.patch Upstream
package/libdrm/0001-tests-meson.build-disable-nouveau-tests-for-static-b.patch Upstream
package/libdvbcsa/0001-altivec-powerpc64.patch Upstream
package/libeXosip2/0001-src-eXtl_dtls.c-fix-build-with-libressl-3.4.1.patch Upstream

View File

@ -1,26 +0,0 @@
From 347c23da1ec6f19b0b0143d53edcc209e522bbf2 Mon Sep 17 00:00:00 2001
From: Oliver Falk <oliver@linux-kernel.at>
Date: Wed, 29 Jun 2022 13:27:45 +0200
Subject: [PATCH] Correct path to string.h (from bsd); Fixes #74
[Retrieved (and backported) from:
https://github.com/ofalk/libdnet/commit/347c23da1ec6f19b0b0143d53edcc209e522bbf2]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
python/dnet.c | 64 +++++++++++++++++++++++--------------------------
python/dnet.pyx | 2 +-
2 files changed, 31 insertions(+), 35 deletions(-)
diff --git a/python/dnet.pyx b/python/dnet.pyx
index d9cbc90..af65a11 100644
--- a/python/dnet.pyx
+++ b/python/dnet.pyx
@@ -40,7 +40,7 @@ cdef extern from *:
unsigned long htonl(unsigned long n)
unsigned long ntohl(unsigned long n)
-cdef extern from "string.h":
+cdef extern from "bsd/string.h":
int strlcpy(char *dst, char *src, int size)
cdef __memcpy(char *dst, object src, int n):

View File

@ -1,3 +1,3 @@
# Locally computed:
sha256 b151c4913758ef80daf4558361b4f2680a37b01d59272625bb78c77183062c63 libdnet-1.16.1.tar.gz
sha256 7df1f0a3db9cf03b48cf50ab273fd6a20c1be99eb9344b9663fe3fd9ed9dab65 libdnet-1.16.4.tar.gz
sha256 6b46ec86e290066c47b6607d322135b3c473566e7225ac23d35a7c0588a82da6 LICENSE

View File

@ -4,7 +4,7 @@
#
################################################################################
LIBDNET_VERSION = 1.16.1
LIBDNET_VERSION = 1.16.4
LIBDNET_SITE = $(call github,ofalk,libdnet,libdnet-$(LIBDNET_VERSION))
LIBDNET_LICENSE = BSD-3-Clause
LIBDNET_LICENSE_FILES = LICENSE