package/log4cxx: bump to version 1.1.0
- Drop patch (already in version) - Drop LOG4CXX_IGNORE_CVES as CVE-2023-31038 has been fixed in 1.1.0 - Add unixodbc optional dependency https://logging.apache.org/log4cxx/latest_stable/changelog.html#1.1.0 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Arnout Vandecappelle <arnout@mind.be>
This commit is contained in:
parent
9ff9d5f886
commit
c4878d530e
@ -1,73 +0,0 @@
|
||||
From 4900c27cc284ba2f671ae92e6ffb4ab391f9507a Mon Sep 17 00:00:00 2001
|
||||
From: Robert Middleton <rm5248@users.noreply.github.com>
|
||||
Date: Mon, 6 Feb 2023 20:39:02 -0500
|
||||
Subject: [PATCH] Make ODBC and SMTP opt-in (#191)
|
||||
|
||||
See #189
|
||||
|
||||
Upstream: afeaab6d0f0107c77dfadcbe3708f170c48d5ed9
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||
---
|
||||
src/main/include/CMakeLists.txt | 40 ++++++++++++++++++++++++---------
|
||||
1 file changed, 30 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/src/main/include/CMakeLists.txt b/src/main/include/CMakeLists.txt
|
||||
index e31443fb..d6835293 100644
|
||||
--- a/src/main/include/CMakeLists.txt
|
||||
+++ b/src/main/include/CMakeLists.txt
|
||||
@@ -85,22 +85,42 @@ include(CheckIncludeFiles)
|
||||
include(CheckIncludeFileCXX)
|
||||
include(CheckLibraryExists)
|
||||
|
||||
-if(WIN32)
|
||||
- CHECK_INCLUDE_FILES(sqlext.h HAS_ODBC)
|
||||
+option(LOG4CXX_ENABLE_ODBC "Support logging via ODBC" OFF)
|
||||
+if(LOG4CXX_ENABLE_ODBC)
|
||||
+ if(WIN32)
|
||||
+ CHECK_INCLUDE_FILES(sqlext.h HAS_ODBC)
|
||||
+ else()
|
||||
+ include(FindPkgConfig)
|
||||
+
|
||||
+ pkg_check_modules( odbc odbc )
|
||||
+ if(${odbc_FOUND})
|
||||
+ set(HAS_ODBC 1)
|
||||
+ else()
|
||||
+ set(HAS_ODBC 0)
|
||||
+ endif(${odbc_FOUND})
|
||||
+ endif(WIN32)
|
||||
+
|
||||
+ if(NOT ${HAS_ODBC})
|
||||
+ message(SEND_ERROR "ODBC not found but requested")
|
||||
+ endif()
|
||||
else()
|
||||
- include(FindPkgConfig)
|
||||
-
|
||||
- pkg_check_modules( odbc QUIET odbc )
|
||||
- if(${odbc_FOUND})
|
||||
- set(HAS_ODBC 1)
|
||||
- endif(${odbc_FOUND})
|
||||
-endif(WIN32)
|
||||
+ set(HAS_ODBC 0)
|
||||
+endif(LOG4CXX_ENABLE_ODBC)
|
||||
+
|
||||
+option(LOG4CXX_ENABLE_ESMTP "Support logging via libesmtp" OFF)
|
||||
+if(LOG4CXX_ENABLE_ESMTP)
|
||||
+ CHECK_LIBRARY_EXISTS(esmtp smtp_create_session "" HAS_LIBESMTP)
|
||||
+ if(NOT HAS_LIBESMTP)
|
||||
+ message(SEND_ERROR "SMTP support with libesmtp not found but requested")
|
||||
+ endif()
|
||||
+else()
|
||||
+ set(HAS_LIBESMTP 0)
|
||||
+endif(LOG4CXX_ENABLE_ESMTP)
|
||||
|
||||
CHECK_INCLUDE_FILE_CXX(locale HAS_STD_LOCALE)
|
||||
CHECK_FUNCTION_EXISTS(mbsrtowcs HAS_MBSRTOWCS)
|
||||
CHECK_FUNCTION_EXISTS(wcstombs HAS_WCSTOMBS)
|
||||
CHECK_FUNCTION_EXISTS(fwide HAS_FWIDE)
|
||||
-CHECK_LIBRARY_EXISTS(esmtp smtp_create_session "" HAS_LIBESMTP)
|
||||
CHECK_FUNCTION_EXISTS(syslog HAS_SYSLOG)
|
||||
if(UNIX)
|
||||
set(CMAKE_REQUIRED_LIBRARIES "pthread")
|
||||
--
|
||||
2.41.0
|
||||
|
@ -1,4 +1,4 @@
|
||||
# From https://www.apache.org/dist/logging/log4cxx/0.13.0/apache-log4cxx-0.13.0.tar.gz.sha512
|
||||
sha512 2a5f4fecc0415d942658c588774f0666082c497b6fd49bf64ab3328a997775206788c9b10a8c89208896c57da52fcc12c18d5d11ca1d3bf699e4633b8fcea6e5 apache-log4cxx-0.13.0.tar.gz
|
||||
# From https://www.apache.org/dist/logging/log4cxx/1.1.0/apache-log4cxx-1.1.0.tar.gz.sha512
|
||||
sha512 66a66eab933a6afd0779e3f73f65afa4fb82481208b591fd7c7c86ded805f50abcd9cdf954bdb49e1e7f5198e6c1c4fff8a7e180ff5fff9491f1946e9ba6fe2b apache-log4cxx-1.1.0.tar.gz
|
||||
# Locally computed
|
||||
sha256 cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30 LICENSE
|
||||
|
@ -4,21 +4,17 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LOG4CXX_VERSION = 0.13.0
|
||||
LOG4CXX_VERSION = 1.1.0
|
||||
LOG4CXX_SITE = https://archive.apache.org/dist/logging/log4cxx/$(LOG4CXX_VERSION)
|
||||
LOG4CXX_SOURCE = apache-log4cxx-$(LOG4CXX_VERSION).tar.gz
|
||||
LOG4CXX_INSTALL_STAGING = YES
|
||||
LOG4CXX_LICENSE = Apache-2.0
|
||||
LOG4CXX_LICENSE_FILES = LICENSE
|
||||
LOG4CXX_CPE_ID_VENDOR = apache
|
||||
# We do not support ODBC functionality
|
||||
LOG4CXX_IGNORE_CVES = CVE-2023-31038
|
||||
|
||||
# Note: if you want to support odbc, make sure CVE-2023-31038 is fixed
|
||||
LOG4CXX_CONF_OPTS = \
|
||||
-DAPR_CONFIG_EXECUTABLE=$(STAGING_DIR)/usr/bin/apr-1-config \
|
||||
-DAPR_UTIL_CONFIG_EXECUTABLE=$(STAGING_DIR)/usr/bin/apu-1-config \
|
||||
-DLOG4CXX_ENABLE_ODBC=OFF
|
||||
-DAPR_UTIL_CONFIG_EXECUTABLE=$(STAGING_DIR)/usr/bin/apu-1-config
|
||||
|
||||
LOG4CXX_DEPENDENCIES = apr apr-util
|
||||
|
||||
@ -33,6 +29,13 @@ else
|
||||
LOG4CXX_CONF_OPTS += -DLOG4CXX_ENABLE_LIBESMTP=OFF
|
||||
endif
|
||||
|
||||
ifeq ($(BR2_PACKAGE_UNIXODBC),y)
|
||||
LOG4CXX_CONF_OPTS += -DLOG4CXX_ENABLE_ODBC=ON
|
||||
LOG4CXX_DEPENDENCIES += unixodbc
|
||||
else
|
||||
LOG4CXX_CONF_OPTS += -DLOG4CXX_ENABLE_ODBC=OFF
|
||||
endif
|
||||
|
||||
ifeq ($(BR2_USE_WCHAR),y)
|
||||
LOG4CXX_CONF_OPTS += -DLOG4CXX_WCHAR_T=ON
|
||||
else
|
||||
|
Loading…
Reference in New Issue
Block a user