xcursor-transparent-theme: new package

Based on work originally done by Aleksandar Zivkovic at
http://patchwork.ozlabs.org/patch/171109/.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Thomas Petazzoni 2013-03-24 08:19:30 +00:00 committed by Peter Korsgaard
parent 6ebb930b69
commit c415c33959
5 changed files with 65 additions and 0 deletions

View File

@ -268,6 +268,7 @@ if BR2_PACKAGE_XORG7
menu "X11R7 Other data"
source package/x11r7/xdata_xbitmaps/Config.in
source package/x11r7/xdata_xcursor-themes/Config.in
source package/x11r7/xcursor-transparent-theme/Config.in
source package/x11r7/xkeyboard-config/Config.in
endmenu
endif

View File

@ -0,0 +1,7 @@
config BR2_PACKAGE_XCURSOR_TRANSPARENT_THEME
bool "xcursor-transparent-theme"
select BR2_PACKAGE_XLIB_LIBXCURSOR
help
Completely transparent theme for hiding the X11 cursor.
No upstream site.

View File

@ -0,0 +1,2 @@
[Icon Theme]
Inherits=xcursor-transparent

View File

@ -0,0 +1,37 @@
Do not symlink to a host directory
The installation of xcursor-transparent-theme creates many symbolic
links to the 'transp' cursor file, but it does so using an absolute
directory, that happens to point to the installation location, which
is incorrect when cross-compiling.
Also add the -f option so that the package can be reinstalled even if
it has already been installed.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/cursors/Makefile.am
===================================================================
--- a/cursors/Makefile.am
+++ b/cursors/Makefile.am
@@ -91,6 +91,6 @@
$(INSTALL_DATA) $(CURSOR_REAL) $(DESTDIR)$(CURSOR_DIR)/
for CURSOR in $(CURSOR_NAMES); do \
echo '-- Installing cursor '$$CURSOR; \
- ln -s $(DESTDIR)$(CURSOR_DIR)/transp $(DESTDIR)$(CURSOR_DIR)/$$CURSOR; \
+ ln -sf transp $(DESTDIR)$(CURSOR_DIR)/$$CURSOR; \
done
Index: b/cursors/Makefile.in
===================================================================
--- a/cursors/Makefile.in
+++ b/cursors/Makefile.in
@@ -177,7 +177,7 @@
$(INSTALL_DATA) $(CURSOR_REAL) $(DESTDIR)$(CURSOR_DIR)/
for CURSOR in $(CURSOR_NAMES); do \
echo '-- Installing cursor '$$CURSOR; \
- ln -s $(DESTDIR)$(CURSOR_DIR)/transp $(DESTDIR)$(CURSOR_DIR)/$$CURSOR; \
+ ln -sf transp $(DESTDIR)$(CURSOR_DIR)/$$CURSOR; \
done
# Tell versions [3.59,3.63) of GNU make to not export all variables.

View File

@ -0,0 +1,18 @@
#############################################################
#
# xcursor-transparent-theme - No description available
#
#############################################################
XCURSOR_TRANSPARENT_THEME_VERSION = 0.1.1
XCURSOR_TRANSPARENT_THEME_SITE = http://downloads.yoctoproject.org/releases/matchbox/utils/
XCURSOR_TRANSPARENT_THEME_DEPENDENCIES = xlib_libXcursor host-xapp_xcursorgen
define ICONS_DEFAULT_CONFIG_INSTALL
$(INSTALL) -m 0755 -D package/x11r7/xcursor-transparent-theme/index.theme \
$(TARGET_DIR)/usr/share/icons/default/index.theme
endef
XCURSOR_TRANSPARENT_THEME_POST_INSTALL_TARGET_HOOKS += ICONS_DEFAULT_CONFIG_INSTALL
$(eval $(autotools-package))