package/usbredir: bump to version 0.11.0

- Switch to meson-package
- Add patch to allow tests to be disabled
- Update indentation in hash file (two spaces)

usbredirserver was the only executable that was installed before.
Disable tools to keep the same behavior.

https://gitlab.freedesktop.org/spice/usbredir/-/blob/usbredir-0.11.0/ChangeLog.md

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
Fabrice Fontaine 2021-09-19 16:21:48 +02:00 committed by Arnout Vandecappelle (Essensium/Mind)
parent 013eee1452
commit c3a907a770
3 changed files with 59 additions and 7 deletions

View File

@ -0,0 +1,46 @@
From 8490a7ac101d4ee0a78c44b252d3b7a6c2508c74 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sat, 21 Aug 2021 11:55:48 +0200
Subject: [PATCH] meson: add tests option
Add tests option to allow the user to disable them
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Retrieved from:
https://gitlab.freedesktop.org/spice/usbredir/-/commit/8490a7ac101d4ee0a78c44b252d3b7a6c2508c74]
---
meson.build | 4 +++-
meson_options.txt | 5 +++++
2 files changed, 8 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 6e773a7..a6d21b8 100644
--- a/meson.build
+++ b/meson.build
@@ -106,7 +106,9 @@ if host_machine.system() != 'windows'
subdir('fuzzing')
endif
endif
-subdir('tests')
+if get_option('tests').enabled()
+ subdir('tests')
+endif
subdir('data')
summary(summary_info, bool_yn: true)
diff --git a/meson_options.txt b/meson_options.txt
index b35732b..63e8c85 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -21,3 +21,8 @@ option('tools',
type : 'feature',
value : 'enabled',
description : 'Build usbredir\'s tools such as usbredirect')
+
+option('tests',
+ type : 'feature',
+ value : 'enabled',
+ description : 'Build usbredir\'s tests such as filter')
--
GitLab

View File

@ -1,4 +1,6 @@
# locally computed hash
sha256 87bc9c5a81c982517a1bec70dc8d22e15ae197847643d58f20c0ced3c38c5e00 usbredir-0.8.0.tar.bz2
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
sha256 592987e8510228d546540b84a22444bde98e48d03078d3b2eefcd889bec5ce8c COPYING.LIB
# https://spice-space.org/download/usbredir/usbredir-0.11.0.tar.xz.sha256sum
sha256 72dd5f3aa90dfbc0510b5149bb5b1654c8f21fdc405dfce7b5dc163dcff19cba usbredir-0.11.0.tar.xz
# Hash for license files
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
sha256 592987e8510228d546540b84a22444bde98e48d03078d3b2eefcd889bec5ce8c COPYING.LIB

View File

@ -4,13 +4,17 @@
#
################################################################################
USBREDIR_VERSION = 0.8.0
USBREDIR_SOURCE = usbredir-$(USBREDIR_VERSION).tar.bz2
USBREDIR_VERSION = 0.11.0
USBREDIR_SOURCE = usbredir-$(USBREDIR_VERSION).tar.xz
USBREDIR_SITE = http://spice-space.org/download/usbredir
USBREDIR_LICENSE = LGPL-2.1+ (libraries)
USBREDIR_LICENSE_FILES = COPYING.LIB
USBREDIR_INSTALL_STAGING = YES
USBREDIR_DEPENDENCIES = host-pkgconf libusb
USBREDIR_CONF_OPTS = \
-Dgit_werror=disabled \
-Dtests=disabled \
-Dtools=disabled
ifeq ($(BR2_PACKAGE_USBREDIR_SERVER),y)
@ -26,4 +30,4 @@ USBREDIR_POST_INSTALL_TARGET_HOOKS += USBREDIR_POST_INSTALL_TARGET_RM_SERVER
endif # BR2_PACKAGE_USBREDIR_SERVER
$(eval $(autotools-package))
$(eval $(meson-package))