package/libmbim: bump to version 1.26.2
Drop patches (already in version) https://gitlab.freedesktop.org/mobile-broadband/libmbim/-/blob/1.26.2/NEWS Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
6acdbb81c8
commit
c1b6b12d98
@ -1,34 +0,0 @@
|
||||
From ff1f9d7c9bc163de3117383b7cea9cd99585462a Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Sat, 31 Jul 2021 23:42:35 +0200
|
||||
Subject: [PATCH] src/libmbim-glib/meson.build: fix static build
|
||||
|
||||
Replace shared_library by library to fix static build failure with
|
||||
toolchains that don't support dynamic library
|
||||
|
||||
Fixes:
|
||||
- http://autobuild.buildroot.org/results/8553211d87a2c41d8b47b51bbb193736fce49714
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Upstream status:
|
||||
https://gitlab.freedesktop.org/mobile-broadband/libmbim/-/merge_requests/83]
|
||||
---
|
||||
src/libmbim-glib/meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/libmbim-glib/meson.build b/src/libmbim-glib/meson.build
|
||||
index e3337db..5de3564 100644
|
||||
--- a/src/libmbim-glib/meson.build
|
||||
+++ b/src/libmbim-glib/meson.build
|
||||
@@ -76,7 +76,7 @@ version_header = configure_file(
|
||||
|
||||
symbol_map = join_paths(meson.current_source_dir(), 'symbol.map')
|
||||
|
||||
-libmbim_glib = shared_library(
|
||||
+libmbim_glib = library(
|
||||
libname,
|
||||
version: mbim_glib_version,
|
||||
sources: version_header,
|
||||
--
|
||||
2.30.2
|
||||
|
@ -1,60 +0,0 @@
|
||||
From 792af73ea90e9689703ab526dd444fdb1c2f8e40 Mon Sep 17 00:00:00 2001
|
||||
From: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
|
||||
Date: Thu, 14 Oct 2021 12:25:46 +0200
|
||||
Subject: [PATCH] meson.build: add an option to not build man pages.
|
||||
|
||||
When cross-compiling, the compiled binaries cannot be run on the build
|
||||
machine, unless one defines a helper (e.g. qemu) in the meson
|
||||
configuration, which is most of the time undesirable.
|
||||
|
||||
If help2man is installed on the build machine, then the build would fail
|
||||
because of this, so add an option to disable generating the man pages.
|
||||
|
||||
With later versions of meson, it will be possible to automatically
|
||||
detect this condition.
|
||||
|
||||
[Retrieved (and backported) from:
|
||||
https://gitlab.freedesktop.org/mobile-broadband/libmbim/-/commit/792af73ea90e9689703ab526dd444fdb1c2f8e40]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
meson.build | 8 +++++++-
|
||||
meson_options.txt | 1 +
|
||||
2 files changed, 8 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 1c5ee2d..59f1727 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -184,8 +184,8 @@ if enable_gtk_doc
|
||||
subdir('docs/reference/libmbim-glib')
|
||||
endif
|
||||
|
||||
-help2man = find_program('help2man', required: false)
|
||||
-if help2man.found()
|
||||
+enable_man = get_option('man')
|
||||
+if enable_man
|
||||
subdir('docs/man')
|
||||
endif
|
||||
|
||||
@@ -198,6 +203,7 @@ summary({
|
||||
output += ' Documentation: ' + enable_gtk_doc.to_string() + '\n'
|
||||
output += ' bash completion: ' + enable_bash_completion.to_string() + '\n'
|
||||
output += ' gobject introspection: ' + enable_gir.to_string() + '\n\n'
|
||||
+output += ' man pages: ' + enable_man.to_string() + '\n\n'
|
||||
output += ' System paths\n'
|
||||
output += ' prefix: ' + mbim_prefix + '\n'
|
||||
output += ' udev base directory: ' + mbim_username + '\n\n'
|
||||
diff --git a/meson_options.txt b/meson_options.txt
|
||||
index 1305957..bfa33ab 100644
|
||||
--- a/meson_options.txt
|
||||
+++ b/meson_options.txt
|
||||
@@ -7,5 +7,6 @@ option('udevdir', type: 'string', value: '', description: 'where udev base direc
|
||||
|
||||
option('introspection', type: 'boolean', value: 'true', description: 'build introspection support')
|
||||
option('gtk_doc', type: 'boolean', value: false, description: 'use gtk-doc to build documentation')
|
||||
+option('man', type: 'boolean', value: 'true', description: 'build man pages using help2man')
|
||||
|
||||
option('bash_completion', type: 'boolean', value: true, description: 'install bash completion files')
|
||||
--
|
||||
GitLab
|
||||
|
@ -1,4 +1,4 @@
|
||||
# Locally computed
|
||||
sha256 63b53db0196dadea673f04524b0683ce40282f25bfd513d398e2a10b992cac01 libmbim-1.26.0.tar.gz
|
||||
sha256 c12e61ea462fca40ddba2a8e1e401242d4f13827944369fad27ff70936b1e09d libmbim-1.26.2.tar.gz
|
||||
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
|
||||
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 COPYING.LIB
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LIBMBIM_VERSION = 1.26.0
|
||||
LIBMBIM_VERSION = 1.26.2
|
||||
LIBMBIM_SITE = https://gitlab.freedesktop.org/mobile-broadband/libmbim/-/archive/$(LIBMBIM_VERSION)
|
||||
LIBMBIM_LICENSE = LGPL-2.0+ (library), GPL-2.0+ (programs)
|
||||
LIBMBIM_LICENSE_FILES = COPYING COPYING.LIB
|
||||
|
Loading…
Reference in New Issue
Block a user