python3: make the ossaudiodev module optional
Like was done for the 'python' package, also make the ossaudiodev module optional for 'python3'. ossaudiodev is always disabled for host-python3, and a new option is added to enable it for the target python3. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
9b79f2a637
commit
be6798ace7
21
package/python3/112-optional-ossaudiodev.patch
Normal file
21
package/python3/112-optional-ossaudiodev.patch
Normal file
@ -0,0 +1,21 @@
|
||||
Add an option to disable the ossaudiodev module
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
|
||||
Index: b/configure.ac
|
||||
===================================================================
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2417,6 +2417,12 @@
|
||||
fi
|
||||
AC_SUBST(MPDEC)
|
||||
|
||||
+AC_ARG_ENABLE(ossaudiodev,
|
||||
+ AS_HELP_STRING([--disable-ossaudiodev], [disable OSSAUDIODEV]),
|
||||
+ [ if test "$enableval" = "no"; then
|
||||
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} ossaudiodev"
|
||||
+ fi])
|
||||
+
|
||||
# Check for support for loadable sqlite extensions
|
||||
AC_MSG_CHECKING(for --enable-loadable-sqlite-extensions)
|
||||
AC_ARG_ENABLE(loadable-sqlite-extensions,
|
@ -61,6 +61,11 @@ config BR2_PACKAGE_PYTHON3_DECIMAL
|
||||
help
|
||||
decimal module for Python3.
|
||||
|
||||
config BR2_PACKAGE_PYTHON3_OSSAUDIODEV
|
||||
bool "ossaudiodev module"
|
||||
help
|
||||
ossaudiodev module for Python3.
|
||||
|
||||
config BR2_PACKAGE_PYTHON3_PYEXPAT
|
||||
select BR2_PACKAGE_EXPAT
|
||||
bool "pyexpat"
|
||||
|
@ -36,6 +36,7 @@ HOST_PYTHON3_CONF_OPTS += \
|
||||
--enable-unicodedata \
|
||||
--disable-test-modules \
|
||||
--disable-idle3 \
|
||||
--disable-ossaudiodev \
|
||||
--disable-pyo-build
|
||||
|
||||
# Make sure that LD_LIBRARY_PATH overrides -rpath.
|
||||
@ -108,6 +109,12 @@ ifeq ($(BR2_PACKAGE_PYTHON3_ZLIB),y)
|
||||
PYTHON3_DEPENDENCIES += zlib
|
||||
endif
|
||||
|
||||
ifeq ($(BR2_PACKAGE_PYTHON3_OSSAUDIODEV),y)
|
||||
PYTHON3_CONF_OPTS += --enable-ossaudiodev
|
||||
else
|
||||
PYTHON3_CONF_OPTS += --disable-ossaudiodev
|
||||
endif
|
||||
|
||||
PYTHON3_CONF_ENV += \
|
||||
ac_cv_have_long_long_format=yes \
|
||||
ac_cv_file__dev_ptmx=yes \
|
||||
|
Loading…
Reference in New Issue
Block a user