package/liblinear: bump to version 2.43
- Update hash of COPYRIGHT (update in year:65115f7426
acf2f9caf1
) - Refresh second patch - Update indentation in hash file (two spaces) Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
791938d1dc
commit
bdd05a2b13
@ -1,18 +1,20 @@
|
||||
Makefile: add a rule to build a static library
|
||||
|
||||
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
||||
[Fabrice: update for 2.43]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
diff -durN liblinear-1.96.orig/Makefile liblinear-1.96/Makefile
|
||||
--- liblinear-1.96.orig/Makefile 2014-11-15 07:50:23.000000000 +0100
|
||||
+++ liblinear-1.96/Makefile 2014-12-14 00:23:00.135893956 +0100
|
||||
@@ -16,6 +16,11 @@
|
||||
fi; \
|
||||
$(CXX) $${SHARED_LIB_FLAG} linear.o tron.o blas/blas.a -o liblinear.so.$(SHVER)
|
||||
$(CXX) $${SHARED_LIB_FLAG} linear.o newton.o blas/blas.a -o liblinear.so.$(SHVER)
|
||||
|
||||
+# Keeping blas/blas.a as a pre-requisite, to ensure all .o files are built
|
||||
+static-lib: linear.o tron.o blas/blas.a
|
||||
+ $(AR) rcv liblinear.a linear.o tron.o blas/*.o
|
||||
+static-lib: linear.o newton.o blas/blas.a
|
||||
+ $(AR) rcv liblinear.a linear.o newton.o blas/*.o
|
||||
+ $(RANLIB) liblinear.a
|
||||
+
|
||||
train: tron.o linear.o train.c blas/blas.a
|
||||
$(CXX) $(CFLAGS) -o train train.c tron.o linear.o $(LIBS)
|
||||
train: newton.o linear.o train.c blas/blas.a
|
||||
$(CXX) $(CFLAGS) -o train train.c newton.o linear.o $(LIBS)
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
# Locally calculated
|
||||
sha256 881c7039c6cf93119c781fb56263de91617b3eca8c3951f2c19a3797de95c6ac liblinear-2.30.tar.gz
|
||||
sha256 c366abf1cb3a003d8c6e6d9c111a23c432db1d001294f88d479b70b60d7c0af2 COPYRIGHT
|
||||
sha256 02bad43d745e2796f39a08ac9d117770e71939ef06b1ee7afc6ab7909e304807 liblinear-2.43.tar.gz
|
||||
sha256 c5c91211a0edaa4c77e352f6b27a8f9c6768afe27d48176d6094905c534eacb3 COPYRIGHT
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LIBLINEAR_VERSION = 2.30
|
||||
LIBLINEAR_VERSION = 2.43
|
||||
LIBLINEAR_SITE = http://www.csie.ntu.edu.tw/~cjlin/liblinear
|
||||
LIBLINEAR_LICENSE = BSD-3-Clause
|
||||
LIBLINEAR_LICENSE_FILES = COPYRIGHT
|
||||
|
Loading…
Reference in New Issue
Block a user