diff --git a/Config.in b/Config.in
index cdc66663f2..ca21595482 100644
--- a/Config.in
+++ b/Config.in
@@ -652,11 +652,36 @@ config BR2_DEPRECATED
 	  This option hides outdated/obsolete versions of packages.
 
 config BR2_USE_WCHAR
-	bool "Show packages that are require WCHAR support"
+	bool "Show packages that require WCHAR support"
 	default y
 	help
 	  This option hides packages which cannot be built without WCHAR.
 
+choice
+	prompt "strip"
+	default BR2_STRIP_strip
+	help
+	  Select whether to strip binaries and libraries for the target
+	  or not.
+	  strip   is the normal strip command
+	  sstrip  is a strip that discards more than the normal strip
+	  none    do not strip (only for debugging!)
+
+config BR2_STRIP_strip
+	bool "strip"
+	help
+	  strip   is the normal strip command
+config BR2_STRIP_sstrip
+	bool "sstrip"
+	select BR2_PACKAGE_SSTRIP_HOST
+	help
+	  sstrip  is a strip that discards more than the normal strip
+config BR2_STRIP_none
+	bool "none"
+	help
+	  none    do not strip (only for debugging!)
+endchoice
+
 config BR2_PREFER_STATIC_LIB
 	bool "prefer static libraries"
 	default n
diff --git a/package/Makefile.in b/package/Makefile.in
index 17302527da..071635b58c 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -131,9 +131,16 @@ endif
 TARGET_CC=$(TARGET_CROSS)gcc
 TARGET_CXX=$(TARGET_CROSS)g++
 TARGET_RANLIB=$(TARGET_CROSS)ranlib
-STRIP=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
 INSTALL=/usr/bin/install
-
+ifeq ($(BR2_STRIP_strip),y)
+STRIP=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
+endif
+ifeq ($(BR2_STRIP_sstrip),y)
+STRIP=$(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-sstrip
+endif
+ifeq ($(BR2_STRIP_none),y)
+STRIP=true -Not_stripping
+endif
 
 HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
 	-e 's/sparc.*/sparc/' \