package/open62541: bump to version 1.2.4
Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
cf629c4e32
commit
bb40efa6f4
@ -29,16 +29,16 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index bc839f27..963460d0 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -292,6 +292,8 @@ if(UA_FORCE_CPP)
|
||||
@@ -257,6 +257,8 @@ if(UA_FORCE_CPP)
|
||||
add_definitions(-D__STDC_CONSTANT_MACROS) # We need the UINT32_C define
|
||||
endif()
|
||||
|
||||
+option(UA_FORCE_WERROR "Force compilation with -Werror" ON)
|
||||
+
|
||||
#General PubSub setup
|
||||
option(UA_ENABLE_PUBSUB "Enable the PubSub protocol" OFF)
|
||||
|
||||
@@ -589,7 +591,9 @@ if(NOT UA_FORCE_CPP AND (CMAKE_COMPILER_IS_GNUCC OR "x${CMAKE_C_COMPILER_ID}" ST
|
||||
option(UA_ENABLE_PUBSUB "Enable publish/subscribe" OFF)
|
||||
mark_as_advanced(UA_ENABLE_PUBSUB)
|
||||
@@ -526,7 +528,9 @@ if(NOT UA_FORCE_CPP AND (CMAKE_COMPILER_IS_GNUCC OR "x${CMAKE_C_COMPILER_ID}" ST
|
||||
check_add_cc_flag("-Wall") # Warnings
|
||||
check_add_cc_flag("-Wextra") # More warnings
|
||||
check_add_cc_flag("-Wpedantic") # Standard compliance
|
||||
|
@ -3,7 +3,7 @@ config BR2_PACKAGE_OPEN62541
|
||||
help
|
||||
open62541 is an open source and free implementation of OPC UA.
|
||||
|
||||
http://open62541.org
|
||||
https://open62541.org/
|
||||
|
||||
if BR2_PACKAGE_OPEN62541
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
# Locally calculated
|
||||
sha256 c59c85b519a18350f5014b6e7b7545ee144ceeb15094e75b0b7ecec7dce43dd0 open62541-v1.2.2-br1.tar.gz
|
||||
sha256 e2e1b8e6285c4fd6d8e07f37d61a8728376d525e169fadb3d61918fa6a7c271a open62541-v1.2.4-br1.tar.gz
|
||||
sha256 fab3dd6bdab226f1c08630b1dd917e11fcb4ec5e1e020e2c16f83a0a13863e85 LICENSE
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
OPEN62541_VERSION = v1.2.2
|
||||
OPEN62541_VERSION = v1.2.4
|
||||
OPEN62541_SITE_METHOD = git
|
||||
OPEN62541_SITE = https://github.com/open62541/open62541.git
|
||||
OPEN62541_GIT_SUBMODULES = YES
|
||||
|
Loading…
Reference in New Issue
Block a user