motion: fix static linking of mysql with enabled libz library
Fixes ([1]): checking for mysql_init in -lmysqlclient... no configure: error: MySQL support can't build without MySQL libraries [1] http://autobuild.buildroot.net/results/6cf/6cf38698a2a9a041ff375c01ae8898eace17cfb2 Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
9e8cc4d5c8
commit
b83107e53c
@ -0,0 +1,31 @@
|
||||
From 5a1081d36bf2861ffc882354c583a0eb6b0ee3d5 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Seiderer <ps.report@gmx.net>
|
||||
Date: Tue, 25 Oct 2016 21:27:41 +0200
|
||||
Subject: [PATCH] configure.ac: use given CFLAGS/LIBS for mysqlclient library
|
||||
check
|
||||
|
||||
Needed for static linking of mysql with enabled libz.
|
||||
|
||||
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
||||
---
|
||||
configure.ac | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 5782fd6..aa5d9dd 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -618,8 +618,8 @@ else
|
||||
#LDFLAGS="-L$MYSQL_LIBDIR"
|
||||
saved_CFLAGS=$CFLAGS
|
||||
saved_LIBS=$LIBS
|
||||
- CFLAGS="-I$MYSQL_INCDIR"
|
||||
- LIBS="-L$MYSQL_LIBDIR"
|
||||
+ CFLAGS="-I$MYSQL_INCDIR $CFLAGS"
|
||||
+ LIBS="-L$MYSQL_LIBDIR $LIBS"
|
||||
AC_CHECK_LIB(mysqlclient,mysql_init,[
|
||||
TEMP_LIBS="$TEMP_LIBS -L$MYSQL_LIBDIR -lmysqlclient -lz"
|
||||
TEMP_CFLAGS="$TEMP_CFLAGS -I$MYSQL_INCDIR"
|
||||
--
|
||||
2.8.1
|
||||
|
@ -9,7 +9,7 @@ MOTION_SITE = $(call github,Motion-Project,motion,$(MOTION_VERSION))
|
||||
MOTION_LICENSE = GPLv2
|
||||
MOTION_LICENSE_FILES = COPYING
|
||||
MOTION_DEPENDENCIES = host-pkgconf jpeg
|
||||
# From git
|
||||
# From git and patched configure.ac
|
||||
MOTION_AUTORECONF = YES
|
||||
|
||||
# motion does not use any specific function of jpeg-turbo, so just relies on
|
||||
@ -29,6 +29,10 @@ MOTION_CONF_OPTS += \
|
||||
--with-mysql \
|
||||
--with-mysql-include=$(STAGING_DIR)/usr/include/mysql \
|
||||
--with-mysql-lib=$(STAGING_DIR)/usr/lib
|
||||
# static link of mysql needs -lz
|
||||
ifeq ($(BR2_STATIC_LIBS)$(BR2_PACKAGE_ZLIB),yy)
|
||||
MOTION_CONF_ENV += LIBS="-lz"
|
||||
endif
|
||||
else
|
||||
MOTION_CONF_OPTS += --without-mysql
|
||||
endif
|
||||
|
Loading…
Reference in New Issue
Block a user