package/multipath-tools: bump to version 0.8.9
Text has been added to README.md, but the section about licenses hasn't been modified. Unfortunately there are still many files without license info, so the small piece of text in README.md that says files with no license info are LGPL-2.0 is still relevant. Signed-off-by: Alexander Egorenkov <egorenar-dev@posteo.net> [Arnout: update README.md hash] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
5bc935665b
commit
b790ff27d5
@ -1,69 +0,0 @@
|
|||||||
From 922855e245c8bdadc0d24b5b706549b18fb5f079 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Alexander Egorenkov <egorenar-dev@posteo.net>
|
|
||||||
Date: Sat, 21 Nov 2020 11:08:56 +0100
|
|
||||||
Subject: [PATCH] kpartx, libmultipath: use pkg-config to get path to
|
|
||||||
headers
|
|
||||||
|
|
||||||
Use pkg-config in Makefile to find path to devmapper and udev headers
|
|
||||||
to enable cross-compilation.
|
|
||||||
|
|
||||||
Signed-off-by: Alexander Egorenkov <egorenar-dev@posteo.net>
|
|
||||||
---
|
|
||||||
kpartx/Makefile | 2 +-
|
|
||||||
libmultipath/Makefile | 12 ++++++------
|
|
||||||
2 files changed, 7 insertions(+), 7 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/kpartx/Makefile b/kpartx/Makefile
|
|
||||||
index 2906a984..29573890 100644
|
|
||||||
--- a/kpartx/Makefile
|
|
||||||
+++ b/kpartx/Makefile
|
|
||||||
@@ -8,7 +8,7 @@ LDFLAGS += $(BIN_LDFLAGS)
|
|
||||||
|
|
||||||
LIBDEPS += -ldevmapper
|
|
||||||
|
|
||||||
-ifneq ($(call check_func,dm_task_set_cookie,/usr/include/libdevmapper.h),0)
|
|
||||||
+ifneq ($(call check_func,dm_task_set_cookie,$(shell $(PKG_CONFIG) --variable=includedir devmapper)/libdevmapper.h),0)
|
|
||||||
CFLAGS += -DLIBDM_API_COOKIE
|
|
||||||
endif
|
|
||||||
|
|
||||||
diff --git a/libmultipath/Makefile b/libmultipath/Makefile
|
|
||||||
index 62ba16e8..3ad9130c 100644
|
|
||||||
--- a/libmultipath/Makefile
|
|
||||||
+++ b/libmultipath/Makefile
|
|
||||||
@@ -20,27 +20,27 @@ ifdef SYSTEMD
|
|
||||||
endif
|
|
||||||
endif
|
|
||||||
|
|
||||||
-ifneq ($(call check_func,dm_task_no_flush,/usr/include/libdevmapper.h),0)
|
|
||||||
+ifneq ($(call check_func,dm_task_no_flush,$(shell $(PKG_CONFIG) --variable=includedir devmapper)/libdevmapper.h),0)
|
|
||||||
CFLAGS += -DLIBDM_API_FLUSH -D_GNU_SOURCE
|
|
||||||
endif
|
|
||||||
|
|
||||||
-ifneq ($(call check_func,dm_task_get_errno,/usr/include/libdevmapper.h),0)
|
|
||||||
+ifneq ($(call check_func,dm_task_get_errno,$(shell $(PKG_CONFIG) --variable=includedir devmapper)/libdevmapper.h),0)
|
|
||||||
CFLAGS += -DLIBDM_API_GET_ERRNO
|
|
||||||
endif
|
|
||||||
|
|
||||||
-ifneq ($(call check_func,dm_task_set_cookie,/usr/include/libdevmapper.h),0)
|
|
||||||
+ifneq ($(call check_func,dm_task_set_cookie,$(shell $(PKG_CONFIG) --variable=includedir devmapper)/libdevmapper.h),0)
|
|
||||||
CFLAGS += -DLIBDM_API_COOKIE
|
|
||||||
endif
|
|
||||||
|
|
||||||
-ifneq ($(call check_func,udev_monitor_set_receive_buffer_size,/usr/include/libudev.h),0)
|
|
||||||
+ifneq ($(call check_func,udev_monitor_set_receive_buffer_size,$(shell $(PKG_CONFIG) --variable=includedir libudev)/libudev.h),0)
|
|
||||||
CFLAGS += -DLIBUDEV_API_RECVBUF
|
|
||||||
endif
|
|
||||||
|
|
||||||
-ifneq ($(call check_func,dm_task_deferred_remove,/usr/include/libdevmapper.h),0)
|
|
||||||
+ifneq ($(call check_func,dm_task_deferred_remove,$(shell $(PKG_CONFIG) --variable=includedir devmapper)/libdevmapper.h),0)
|
|
||||||
CFLAGS += -DLIBDM_API_DEFERRED
|
|
||||||
endif
|
|
||||||
|
|
||||||
-ifneq ($(call check_func,dm_hold_control_dev,/usr/include/libdevmapper.h),0)
|
|
||||||
+ifneq ($(call check_func,dm_hold_control_dev,$(shell $(PKG_CONFIG) --variable=includedir devmapper)/libdevmapper.h),0)
|
|
||||||
CFLAGS += -DLIBDM_API_HOLD_CONTROL
|
|
||||||
endif
|
|
||||||
|
|
||||||
--
|
|
||||||
2.29.2
|
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
# Locally computed:
|
# Locally computed:
|
||||||
sha256 ff45ddb18a1effbfbe5712f513dd3b7146c68141091fc1c2489af8d6197026ef multipath-tools-0.8.8.tar.gz
|
sha256 27a426facea0474e6dc48e026a94f7c86890d3f27b439b07ec26b0b9887b0cc4 multipath-tools-0.8.9.tar.gz
|
||||||
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 LICENSES/GPL-2.0
|
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 LICENSES/GPL-2.0
|
||||||
sha256 3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986 LICENSES/GPL-3.0
|
sha256 3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986 LICENSES/GPL-3.0
|
||||||
sha256 b7993225104d90ddd8024fd838faf300bea5e83d91203eab98e29512acebd69c LICENSES/LGPL-2.0
|
sha256 b7993225104d90ddd8024fd838faf300bea5e83d91203eab98e29512acebd69c LICENSES/LGPL-2.0
|
||||||
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 LICENSES/LGPL-2.1
|
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 LICENSES/LGPL-2.1
|
||||||
sha256 b1bd70cc61ab014cc2e744af6b117db481ef4fa5d59cb3a21d86059935c666df README.md
|
sha256 a3777a6b4433a23246eed8a88ca8466e3d21a2f758c03d060201fe2c44ff5484 README.md
|
||||||
|
@ -4,7 +4,7 @@
|
|||||||
#
|
#
|
||||||
################################################################################
|
################################################################################
|
||||||
|
|
||||||
MULTIPATH_TOOLS_VERSION = 0.8.8
|
MULTIPATH_TOOLS_VERSION = 0.8.9
|
||||||
MULTIPATH_TOOLS_SITE = $(call github,opensvc,multipath-tools,$(MULTIPATH_TOOLS_VERSION))
|
MULTIPATH_TOOLS_SITE = $(call github,opensvc,multipath-tools,$(MULTIPATH_TOOLS_VERSION))
|
||||||
|
|
||||||
MULTIPATH_TOOLS_LICENSE = \
|
MULTIPATH_TOOLS_LICENSE = \
|
||||||
|
Loading…
Reference in New Issue
Block a user