package/sdl: add upstream security fix for CVE-2022-34568

SDL v1.2 was discovered to contain a use-after-free via the XFree function
at /src/video/x11/SDL_x11yuv.c.

https://github.com/advisories/GHSA-wr7h-5wm3-p3h4

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
Peter Korsgaard 2022-11-21 08:24:43 +01:00 committed by Yann E. MORIN
parent 7928c51bf6
commit b7368099ae
2 changed files with 31 additions and 0 deletions

View File

@ -0,0 +1,28 @@
From d7e00208738a0bc6af302723fe64908ac35b777b Mon Sep 17 00:00:00 2001
From: Ozkan Sezer <sezeroz@gmail.com>
Date: Sat, 18 Jun 2022 14:55:00 +0300
Subject: [PATCH] SDL_x11yuv.c: fix possible use-after-free
Fixes: https://github.com/libsdl-org/SDL-1.2/issues/863
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
src/video/x11/SDL_x11yuv.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/video/x11/SDL_x11yuv.c b/src/video/x11/SDL_x11yuv.c
index 62698dfd..0d5754e3 100644
--- a/src/video/x11/SDL_x11yuv.c
+++ b/src/video/x11/SDL_x11yuv.c
@@ -374,8 +374,8 @@ SDL_Overlay *X11_CreateYUVOverlay(_THIS, int width, int height, Uint32 format, S
#ifdef PITCH_WORKAROUND
if ( hwdata->image != NULL && hwdata->image->pitches[0] != (width*bpp) ) {
/* Ajust overlay width according to pitch */
- XFree(hwdata->image);
width = hwdata->image->pitches[0] / bpp;
+ XFree(hwdata->image);
hwdata->image = SDL_NAME(XvCreateImage)(GFX_Display, xv_port, format,
0, width, height);
}
--
2.30.2

View File

@ -13,6 +13,9 @@ SDL_CPE_ID_VENDOR = libsdl
SDL_CPE_ID_PRODUCT = simple_directmedia_layer
SDL_INSTALL_STAGING = YES
# 0003-SDL_x11yuv.c-fix-possible-use-after-free.patch
SDL_IGNORE_CVES += CVE-2022-34568
# we're patching configure.in, but package cannot autoreconf with our version of
# autotools, so we have to do it manually instead of setting SDL_AUTORECONF = YES
define SDL_RUN_AUTOGEN