add support for gtk+ version 1.2

This commit is contained in:
Eric Andersen 2006-07-10 22:06:45 +00:00
parent 7909d9d1d9
commit b6de822b37
7 changed files with 51406 additions and 0 deletions

View File

@ -65,6 +65,7 @@ source "package/libcgicc/Config.in"
source "package/libelf/Config.in"
source "package/libfloat/Config.in"
source "package/libglib12/Config.in"
source "package/libgtk12/Config.in"
source "package/libmad/Config.in"
source "package/libpcap/Config.in"
source "package/libpng/Config.in"

View File

@ -0,0 +1,9 @@
config BR2_PACKAGE_LIBGTK12
bool "libgtk12"
default n
depends BR2_PACKAGE_LIBGLIB12
depends BR2_PACKAGE_XORG
help
The GTK+ graphical user interface library
http://www.gtk.org/

View File

@ -0,0 +1,689 @@
fixup configure.in, acinclude.m4 and Makefile.am's for reconfigurability. make
gtk-config use pkg-config
#
# Patch managed by http://www.holgerschurig.de/patcher.html
#
--- gtk+-1.2.10/configure.in~gtk+1.2-reconf-fix
+++ gtk+-1.2.10/configure.in
@@ -17,7 +17,9 @@
dnl we need to AC_DIVERT_PUSH/AC_DIVERT_POP these variable definitions so they
dnl are available for $ac_help expansion (don't we all *love* autoconf?)
-AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
+ifdef([AC_DIVERSION_NOTICE],
+ [AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)],
+ [AC_DIVERT_PUSH(NOTICE)])dnl
#
# Making releases:
# GTK_MICRO_VERSION += 1;
@@ -76,7 +78,10 @@
dnl figure debugging default, prior to $ac_help setup
dnl
-AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
+ifdef([AC_DIVERSION_NOTICE],
+ [AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)],
+ [AC_DIVERT_PUSH(NOTICE)])dnl
+
if test `expr $GTK_MINOR_VERSION \% 2` = 1 ; then
debug_default=yes
else
@@ -292,12 +297,9 @@
AC_SUBST(GLIB_DEPLIBS)
# Find the X11 include and library directories
-AC_PATH_X
AC_PATH_XTRA
-if test "x$x_includes" = "x"; then
- x_includes="/usr/include"
-fi
+PKG_CHECK_MODULES(X,x11 xau)
saved_cflags="$CFLAGS"
saved_ldflags="$LDFLAGS"
--- gtk+-1.2.10/gdk/Makefile.am~gtk+1.2-reconf-fix
+++ gtk+-1.2.10/gdk/Makefile.am
@@ -31,7 +31,7 @@
# setup source file variables
#
# GDK header files for public installation (non-generated)
-gdk_public_h_sources = @STRIP_BEGIN@ \
+gdk_public_h_sources = \
gdk.h \
gdkcursors.h \
gdkrgb.h \
@@ -39,9 +39,9 @@
gdkkeysyms.h \
gdkprivate.h \
gdktypes.h \
- gdkx.h \
-@STRIP_END@
-gdk_c_sources = @STRIP_BEGIN@ \
+ gdkx.h
+
+gdk_c_sources = \
gdk.c \
gdkcc.c \
gdkcolor.c \
@@ -72,18 +72,16 @@
MwmUtil.h \
gxid_lib.h \
gxid_proto.h \
- gxid_lib.c \
-@STRIP_END@
+ gxid_lib.c
#
# setup GDK sources and their dependancies
#
libgdkinclude_HEADERS = $(gdk_public_h_sources)
libgdk_la_SOURCES = $(gdk_c_sources)
-MAINTAINERCLEANFILES +=
-EXTRA_HEADERS +=
-EXTRA_DIST +=
-EXTRA_DIST +=
+MAINTAINERCLEANFILES =
+EXTRA_HEADERS =
+EXTRA_DIST =
#
# rules to generate built sources
--- gtk+-1.2.10/gtk/Makefile.am~gtk+1.2-reconf-fix
+++ gtk+-1.2.10/gtk/Makefile.am
@@ -39,7 +39,7 @@
# setup source file variables
#
# GTK+ header files for public installation (non-generated)
-gtk_public_h_sources = @STRIP_BEGIN@ \
+gtk_public_h_sources = \
gtk.h \
gtkaccelgroup.h \
gtkaccellabel.h \
@@ -148,13 +148,13 @@
gtkvscrollbar.h \
gtkvseparator.h \
gtkwidget.h \
- gtkwindow.h \
-@STRIP_END@
+ gtkwindow.h
+
# GTK+ header files that don't get installed
-gtk_private_h_sources = @STRIP_BEGIN@ \
-@STRIP_END@
+gtk_private_h_sources =
+
# GTK+ C sources to build the library from
-gtk_c_sources = @STRIP_BEGIN@ \
+gtk_c_sources = \
gtkaccelgroup.c \
gtkaccellabel.c \
gtkadjustment.c \
@@ -262,8 +262,8 @@
gtkwidget.c \
gtkwindow.c \
fnmatch.c \
- fnmatch.h \
-@STRIP_END@
+ fnmatch.h
+
# we use our own built_sources variable rules to avoid automake's
# BUILT_SOURCES oddities
# we generate frequently rebuild files piggyback on a stamp file, so sources
@@ -271,7 +271,7 @@
# content
#
# built sources that don't get installed
-gtk_built_sources = @STRIP_BEGIN@ \
+gtk_built_sources = \
stamp-gtk.defs \
stamp-gtktypebuiltins.h \
stamp-gtkmarshal.h \
@@ -279,17 +279,18 @@
gtktypebuiltins_ids.c \
gtktypebuiltins_evals.c \
gtkmarshal.c \
- gtk.defs \
-@STRIP_END@
+ gtk.defs
+
+
# built sources that get installed with the header files
-gtk_built_public_sources = @STRIP_BEGIN@ \
+gtk_built_public_sources = \
gtkmarshal.h \
- gtktypebuiltins.h \
-@STRIP_END@
+ gtktypebuiltins.h
+
# non-header sources (headers should be specified in the above variables)
# that don't serve as direct make target sources, i.e. they don't have
# their own .lo rules and don't get publically installed
-gtk_extra_sources = @STRIP_BEGIN@ \
+gtk_extra_sources = \
gtkfeatures.h.in \
makeenums.pl \
makeenums.awk \
@@ -298,8 +299,8 @@
gtkargcollector.c \
gtk-boxed.defs \
genmarshal.pl \
- gtkmarshal.list \
-@STRIP_END@
+ gtkmarshal.list
+
# Extra headers that are used for enum type array/id generation
gdk_headers = @STRIP_BEGIN@ \
../gdk/gdktypes.h \
@@ -311,9 +312,9 @@
#
libgtkinclude_HEADERS = $(gtk_public_h_sources) $(gtk_built_public_sources) gtkfeatures.h
libgtk_la_SOURCES = $(gtk_c_sources)
-MAINTAINERCLEANFILES += $(gtk_built_public_sources) $(gtk_built_sources)
-EXTRA_HEADERS +=
-EXTRA_DIST += $(gtk_private_h_sources)
+MAINTAINERCLEANFILES = $(gtk_built_public_sources) $(gtk_built_sources)
+EXTRA_HEADERS =
+EXTRA_DIST = $(gtk_private_h_sources)
EXTRA_DIST += $(gtk_built_sources) $(gtk_built_public_sources) $(gtk_extra_sources)
#
@@ -321,7 +322,7 @@
#
# setup autogeneration dependancies
gen_sources = xgen-gdef xgen-gtbh xgen-gtbvc xgen-gtbic xgen-gtbec xgen-gmh xgen-gmc
-CLEANFILES += $(gen_sources)
+CLEANFILES = $(gen_sources)
COPYING: $(gtk_built_public_sources) $(gtk_built_sources)
$(OBJECTS): COPYING # this is our oldest-source-stamp
# initial creation of the real stamp-* files
--- gtk+-1.2.10/docs/Makefile.am~gtk+1.2-reconf-fix
+++ gtk+-1.2.10/docs/Makefile.am
@@ -166,7 +166,7 @@
echo $$p; \
done
-EXTRA_DIST += \
+EXTRA_DIST = \
Changes-1.2.txt \
debugging.txt \
developers.txt \
--- gtk+-1.2.10/acinclude.m4~gtk+1.2-reconf-fix
+++ gtk+-1.2.10/acinclude.m4
@@ -21,428 +21,6 @@
## configuration script generated by Autoconf, you may include it under
## the same distribution terms that you use for the rest of that program.
-# serial 40 AC_PROG_LIBTOOL
-AC_DEFUN(AC_PROG_LIBTOOL,
-[AC_REQUIRE([AC_LIBTOOL_SETUP])dnl
-
-# Save cache, so that ltconfig can load it
-AC_CACHE_SAVE
-
-# Actually configure libtool. ac_aux_dir is where install-sh is found.
-CC="$CC" CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" \
-LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
-LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" \
-DLLTOOL="$DLLTOOL" AS="$AS" OBJDUMP="$OBJDUMP" \
-${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
-$libtool_flags --no-verify $ac_aux_dir/ltmain.sh $lt_target \
-|| AC_MSG_ERROR([libtool configure failed])
-
-# Reload cache, that may have been modified by ltconfig
-AC_CACHE_LOAD
-
-# This can be used to rebuild libtool when needed
-LIBTOOL_DEPS="$ac_aux_dir/ltconfig $ac_aux_dir/ltmain.sh"
-
-# Always use our own libtool.
-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-AC_SUBST(LIBTOOL)dnl
-
-# Redirect the config.log output again, so that the ltconfig log is not
-# clobbered by the next message.
-exec 5>>./config.log
-])
-
-AC_DEFUN(AC_LIBTOOL_SETUP,
-[AC_PREREQ(2.13)dnl
-AC_REQUIRE([AC_ENABLE_SHARED])dnl
-AC_REQUIRE([AC_ENABLE_STATIC])dnl
-AC_REQUIRE([AC_ENABLE_FAST_INSTALL])dnl
-AC_REQUIRE([AC_CANONICAL_HOST])dnl
-AC_REQUIRE([AC_CANONICAL_BUILD])dnl
-AC_REQUIRE([AC_PROG_RANLIB])dnl
-AC_REQUIRE([AC_PROG_CC])dnl
-AC_REQUIRE([AC_PROG_LD])dnl
-AC_REQUIRE([AC_PROG_NM])dnl
-AC_REQUIRE([AC_PROG_LN_S])dnl
-dnl
-
-case "$target" in
-NONE) lt_target="$host" ;;
-*) lt_target="$target" ;;
-esac
-
-# Check for any special flags to pass to ltconfig.
-libtool_flags="--cache-file=$cache_file"
-test "$enable_shared" = no && libtool_flags="$libtool_flags --disable-shared"
-test "$enable_static" = no && libtool_flags="$libtool_flags --disable-static"
-test "$enable_fast_install" = no && libtool_flags="$libtool_flags --disable-fast-install"
-test "$ac_cv_prog_gcc" = yes && libtool_flags="$libtool_flags --with-gcc"
-test "$ac_cv_prog_gnu_ld" = yes && libtool_flags="$libtool_flags --with-gnu-ld"
-ifdef([AC_PROVIDE_AC_LIBTOOL_DLOPEN],
-[libtool_flags="$libtool_flags --enable-dlopen"])
-ifdef([AC_PROVIDE_AC_LIBTOOL_WIN32_DLL],
-[libtool_flags="$libtool_flags --enable-win32-dll"])
-AC_ARG_ENABLE(libtool-lock,
- [ --disable-libtool-lock avoid locking (might break parallel builds)])
-test "x$enable_libtool_lock" = xno && libtool_flags="$libtool_flags --disable-lock"
-test x"$silent" = xyes && libtool_flags="$libtool_flags --silent"
-
-# Some flags need to be propagated to the compiler or linker for good
-# libtool support.
-case "$lt_target" in
-*-*-irix6*)
- # Find out which ABI we are using.
- echo '[#]line __oline__ "configure"' > conftest.$ac_ext
- if AC_TRY_EVAL(ac_compile); then
- case "`/usr/bin/file conftest.o`" in
- *32-bit*)
- LD="${LD-ld} -32"
- ;;
- *N32*)
- LD="${LD-ld} -n32"
- ;;
- *64-bit*)
- LD="${LD-ld} -64"
- ;;
- esac
- fi
- rm -rf conftest*
- ;;
-
-*-*-sco3.2v5*)
- # On SCO OpenServer 5, we need -belf to get full-featured binaries.
- SAVE_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS -belf"
- AC_CACHE_CHECK([whether the C compiler needs -belf], lt_cv_cc_needs_belf,
- [AC_TRY_LINK([],[],[lt_cv_cc_needs_belf=yes],[lt_cv_cc_needs_belf=no])])
- if test x"$lt_cv_cc_needs_belf" != x"yes"; then
- # this is probably gcc 2.8.0, egcs 1.0 or newer; no need for -belf
- CFLAGS="$SAVE_CFLAGS"
- fi
- ;;
-
-ifdef([AC_PROVIDE_AC_LIBTOOL_WIN32_DLL],
-[*-*-cygwin* | *-*-mingw*)
- AC_CHECK_TOOL(DLLTOOL, dlltool, false)
- AC_CHECK_TOOL(AS, as, false)
- AC_CHECK_TOOL(OBJDUMP, objdump, false)
- ;;
-])
-esac
-])
-
-# AC_LIBTOOL_DLOPEN - enable checks for dlopen support
-AC_DEFUN(AC_LIBTOOL_DLOPEN, [AC_BEFORE([$0],[AC_LIBTOOL_SETUP])])
-
-# AC_LIBTOOL_WIN32_DLL - declare package support for building win32 dll's
-AC_DEFUN(AC_LIBTOOL_WIN32_DLL, [AC_BEFORE([$0], [AC_LIBTOOL_SETUP])])
-
-# AC_ENABLE_SHARED - implement the --enable-shared flag
-# Usage: AC_ENABLE_SHARED[(DEFAULT)]
-# Where DEFAULT is either `yes' or `no'. If omitted, it defaults to
-# `yes'.
-AC_DEFUN(AC_ENABLE_SHARED, [dnl
-define([AC_ENABLE_SHARED_DEFAULT], ifelse($1, no, no, yes))dnl
-AC_ARG_ENABLE(shared,
-changequote(<<, >>)dnl
-<< --enable-shared[=PKGS] build shared libraries [default=>>AC_ENABLE_SHARED_DEFAULT],
-changequote([, ])dnl
-[p=${PACKAGE-default}
-case "$enableval" in
-yes) enable_shared=yes ;;
-no) enable_shared=no ;;
-*)
- enable_shared=no
- # Look at the argument we got. We use all the common list separators.
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:,"
- for pkg in $enableval; do
- if test "X$pkg" = "X$p"; then
- enable_shared=yes
- fi
- done
- IFS="$ac_save_ifs"
- ;;
-esac],
-enable_shared=AC_ENABLE_SHARED_DEFAULT)dnl
-])
-
-# AC_DISABLE_SHARED - set the default shared flag to --disable-shared
-AC_DEFUN(AC_DISABLE_SHARED, [AC_BEFORE([$0],[AC_LIBTOOL_SETUP])dnl
-AC_ENABLE_SHARED(no)])
-
-# AC_ENABLE_STATIC - implement the --enable-static flag
-# Usage: AC_ENABLE_STATIC[(DEFAULT)]
-# Where DEFAULT is either `yes' or `no'. If omitted, it defaults to
-# `yes'.
-AC_DEFUN(AC_ENABLE_STATIC, [dnl
-define([AC_ENABLE_STATIC_DEFAULT], ifelse($1, no, no, yes))dnl
-AC_ARG_ENABLE(static,
-changequote(<<, >>)dnl
-<< --enable-static[=PKGS] build static libraries [default=>>AC_ENABLE_STATIC_DEFAULT],
-changequote([, ])dnl
-[p=${PACKAGE-default}
-case "$enableval" in
-yes) enable_static=yes ;;
-no) enable_static=no ;;
-*)
- enable_static=no
- # Look at the argument we got. We use all the common list separators.
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:,"
- for pkg in $enableval; do
- if test "X$pkg" = "X$p"; then
- enable_static=yes
- fi
- done
- IFS="$ac_save_ifs"
- ;;
-esac],
-enable_static=AC_ENABLE_STATIC_DEFAULT)dnl
-])
-
-# AC_DISABLE_STATIC - set the default static flag to --disable-static
-AC_DEFUN(AC_DISABLE_STATIC, [AC_BEFORE([$0],[AC_LIBTOOL_SETUP])dnl
-AC_ENABLE_STATIC(no)])
-
-
-# AC_ENABLE_FAST_INSTALL - implement the --enable-fast-install flag
-# Usage: AC_ENABLE_FAST_INSTALL[(DEFAULT)]
-# Where DEFAULT is either `yes' or `no'. If omitted, it defaults to
-# `yes'.
-AC_DEFUN(AC_ENABLE_FAST_INSTALL, [dnl
-define([AC_ENABLE_FAST_INSTALL_DEFAULT], ifelse($1, no, no, yes))dnl
-AC_ARG_ENABLE(fast-install,
-changequote(<<, >>)dnl
-<< --enable-fast-install[=PKGS] optimize for fast installation [default=>>AC_ENABLE_FAST_INSTALL_DEFAULT],
-changequote([, ])dnl
-[p=${PACKAGE-default}
-case "$enableval" in
-yes) enable_fast_install=yes ;;
-no) enable_fast_install=no ;;
-*)
- enable_fast_install=no
- # Look at the argument we got. We use all the common list separators.
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:,"
- for pkg in $enableval; do
- if test "X$pkg" = "X$p"; then
- enable_fast_install=yes
- fi
- done
- IFS="$ac_save_ifs"
- ;;
-esac],
-enable_fast_install=AC_ENABLE_FAST_INSTALL_DEFAULT)dnl
-])
-
-# AC_ENABLE_FAST_INSTALL - set the default to --disable-fast-install
-AC_DEFUN(AC_DISABLE_FAST_INSTALL, [AC_BEFORE([$0],[AC_LIBTOOL_SETUP])dnl
-AC_ENABLE_FAST_INSTALL(no)])
-
-# AC_PROG_LD - find the path to the GNU or non-GNU linker
-AC_DEFUN(AC_PROG_LD,
-[AC_ARG_WITH(gnu-ld,
-[ --with-gnu-ld assume the C compiler uses GNU ld [default=no]],
-test "$withval" = no || with_gnu_ld=yes, with_gnu_ld=no)
-AC_REQUIRE([AC_PROG_CC])dnl
-AC_REQUIRE([AC_CANONICAL_HOST])dnl
-AC_REQUIRE([AC_CANONICAL_BUILD])dnl
-ac_prog=ld
-if test "$ac_cv_prog_gcc" = yes; then
- # Check if gcc -print-prog-name=ld gives a path.
- AC_MSG_CHECKING([for ld used by GCC])
- ac_prog=`($CC -print-prog-name=ld) 2>&5`
- case "$ac_prog" in
- # Accept absolute paths.
-changequote(,)dnl
- [\\/]* | [A-Za-z]:[\\/]*)
- re_direlt='/[^/][^/]*/\.\./'
-changequote([,])dnl
- # Canonicalize the path of ld
- ac_prog=`echo $ac_prog| sed 's%\\\\%/%g'`
- while echo $ac_prog | grep "$re_direlt" > /dev/null 2>&1; do
- ac_prog=`echo $ac_prog| sed "s%$re_direlt%/%"`
- done
- test -z "$LD" && LD="$ac_prog"
- ;;
- "")
- # If it fails, then pretend we aren't using GCC.
- ac_prog=ld
- ;;
- *)
- # If it is relative, then search for the first ld in PATH.
- with_gnu_ld=unknown
- ;;
- esac
-elif test "$with_gnu_ld" = yes; then
- AC_MSG_CHECKING([for GNU ld])
-else
- AC_MSG_CHECKING([for non-GNU ld])
-fi
-AC_CACHE_VAL(ac_cv_path_LD,
-[if test -z "$LD"; then
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}${PATH_SEPARATOR-:}"
- for ac_dir in $PATH; do
- test -z "$ac_dir" && ac_dir=.
- if test -f "$ac_dir/$ac_prog" || test -f "$ac_dir/$ac_prog$ac_exeext"; then
- ac_cv_path_LD="$ac_dir/$ac_prog"
- # Check to see if the program is GNU ld. I'd rather use --version,
- # but apparently some GNU ld's only accept -v.
- # Break only if it was the GNU/non-GNU ld that we prefer.
- if "$ac_cv_path_LD" -v 2>&1 < /dev/null | egrep '(GNU|with BFD)' > /dev/null; then
- test "$with_gnu_ld" != no && break
- else
- test "$with_gnu_ld" != yes && break
- fi
- fi
- done
- IFS="$ac_save_ifs"
-else
- ac_cv_path_LD="$LD" # Let the user override the test with a path.
-fi])
-LD="$ac_cv_path_LD"
-if test -n "$LD"; then
- AC_MSG_RESULT($LD)
-else
- AC_MSG_RESULT(no)
-fi
-test -z "$LD" && AC_MSG_ERROR([no acceptable ld found in \$PATH])
-AC_PROG_LD_GNU
-])
-
-AC_DEFUN(AC_PROG_LD_GNU,
-[AC_CACHE_CHECK([if the linker ($LD) is GNU ld], ac_cv_prog_gnu_ld,
-[# I'd rather use --version here, but apparently some GNU ld's only accept -v.
-if $LD -v 2>&1 </dev/null | egrep '(GNU|with BFD)' 1>&5; then
- ac_cv_prog_gnu_ld=yes
-else
- ac_cv_prog_gnu_ld=no
-fi])
-])
-
-# AC_PROG_NM - find the path to a BSD-compatible name lister
-AC_DEFUN(AC_PROG_NM,
-[AC_MSG_CHECKING([for BSD-compatible nm])
-AC_CACHE_VAL(ac_cv_path_NM,
-[if test -n "$NM"; then
- # Let the user override the test.
- ac_cv_path_NM="$NM"
-else
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}${PATH_SEPARATOR-:}"
- for ac_dir in $PATH /usr/ccs/bin /usr/ucb /bin; do
- test -z "$ac_dir" && ac_dir=.
- if test -f $ac_dir/nm || test -f $ac_dir/nm$ac_exeext ; then
- # Check to see if the nm accepts a BSD-compat flag.
- # Adding the `sed 1q' prevents false positives on HP-UX, which says:
- # nm: unknown option "B" ignored
- if ($ac_dir/nm -B /dev/null 2>&1 | sed '1q'; exit 0) | egrep /dev/null >/dev/null; then
- ac_cv_path_NM="$ac_dir/nm -B"
- break
- elif ($ac_dir/nm -p /dev/null 2>&1 | sed '1q'; exit 0) | egrep /dev/null >/dev/null; then
- ac_cv_path_NM="$ac_dir/nm -p"
- break
- else
- ac_cv_path_NM=${ac_cv_path_NM="$ac_dir/nm"} # keep the first match, but
- continue # so that we can try to find one that supports BSD flags
- fi
- fi
- done
- IFS="$ac_save_ifs"
- test -z "$ac_cv_path_NM" && ac_cv_path_NM=nm
-fi])
-NM="$ac_cv_path_NM"
-AC_MSG_RESULT([$NM])
-])
-
-# AC_CHECK_LIBM - check for math library
-AC_DEFUN(AC_CHECK_LIBM,
-[AC_REQUIRE([AC_CANONICAL_HOST])dnl
-LIBM=
-case "$lt_target" in
-*-*-beos* | *-*-cygwin*)
- # These system don't have libm
- ;;
-*-ncr-sysv4.3*)
- AC_CHECK_LIB(mw, _mwvalidcheckl, LIBM="-lmw")
- AC_CHECK_LIB(m, main, LIBM="$LIBM -lm")
- ;;
-*)
- AC_CHECK_LIB(m, main, LIBM="-lm")
- ;;
-esac
-])
-
-# AC_LIBLTDL_CONVENIENCE[(dir)] - sets LIBLTDL to the link flags for
-# the libltdl convenience library, adds --enable-ltdl-convenience to
-# the configure arguments. Note that LIBLTDL is not AC_SUBSTed, nor
-# is AC_CONFIG_SUBDIRS called. If DIR is not provided, it is assumed
-# to be `${top_builddir}/libltdl'. Make sure you start DIR with
-# '${top_builddir}/' (note the single quotes!) if your package is not
-# flat, and, if you're not using automake, define top_builddir as
-# appropriate in the Makefiles.
-AC_DEFUN(AC_LIBLTDL_CONVENIENCE, [AC_BEFORE([$0],[AC_LIBTOOL_SETUP])dnl
- case "$enable_ltdl_convenience" in
- no) AC_MSG_ERROR([this package needs a convenience libltdl]) ;;
- "") enable_ltdl_convenience=yes
- ac_configure_args="$ac_configure_args --enable-ltdl-convenience" ;;
- esac
- LIBLTDL=ifelse($#,1,$1,['${top_builddir}/libltdl'])/libltdlc.la
- INCLTDL=ifelse($#,1,-I$1,['-I${top_builddir}/libltdl'])
-])
-
-# AC_LIBLTDL_INSTALLABLE[(dir)] - sets LIBLTDL to the link flags for
-# the libltdl installable library, and adds --enable-ltdl-install to
-# the configure arguments. Note that LIBLTDL is not AC_SUBSTed, nor
-# is AC_CONFIG_SUBDIRS called. If DIR is not provided, it is assumed
-# to be `${top_builddir}/libltdl'. Make sure you start DIR with
-# '${top_builddir}/' (note the single quotes!) if your package is not
-# flat, and, if you're not using automake, define top_builddir as
-# appropriate in the Makefiles.
-# In the future, this macro may have to be called after AC_PROG_LIBTOOL.
-AC_DEFUN(AC_LIBLTDL_INSTALLABLE, [AC_BEFORE([$0],[AC_LIBTOOL_SETUP])dnl
- AC_CHECK_LIB(ltdl, main,
- [test x"$enable_ltdl_install" != xyes && enable_ltdl_install=no],
- [if test x"$enable_ltdl_install" = xno; then
- AC_MSG_WARN([libltdl not installed, but installation disabled])
- else
- enable_ltdl_install=yes
- fi
- ])
- if test x"$enable_ltdl_install" = x"yes"; then
- ac_configure_args="$ac_configure_args --enable-ltdl-install"
- LIBLTDL=ifelse($#,1,$1,['${top_builddir}/libltdl'])/libltdl.la
- INCLTDL=ifelse($#,1,-I$1,['-I${top_builddir}/libltdl'])
- else
- ac_configure_args="$ac_configure_args --enable-ltdl-install=no"
- LIBLTDL="-lltdl"
- INCLTDL=
- fi
-])
-
-dnl old names
-AC_DEFUN(AM_PROG_LIBTOOL, [indir([AC_PROG_LIBTOOL])])dnl
-AC_DEFUN(AM_ENABLE_SHARED, [indir([AC_ENABLE_SHARED], $@)])dnl
-AC_DEFUN(AM_ENABLE_STATIC, [indir([AC_ENABLE_STATIC], $@)])dnl
-AC_DEFUN(AM_DISABLE_SHARED, [indir([AC_DISABLE_SHARED], $@)])dnl
-AC_DEFUN(AM_DISABLE_STATIC, [indir([AC_DISABLE_STATIC], $@)])dnl
-AC_DEFUN(AM_PROG_LD, [indir([AC_PROG_LD])])dnl
-AC_DEFUN(AM_PROG_NM, [indir([AC_PROG_NM])])dnl
-
-dnl This is just to silence aclocal about the macro not being used
-ifelse([AC_DISABLE_FAST_INSTALL])dnl
-
-# Macro to add for using GNU gettext.
-# Ulrich Drepper <drepper@cygnus.com>, 1995.
-#
-# Modified to never use included libintl.
-# Owen Taylor <otaylor@redhat.com>, 12/15/1998
-#
-#
-# This file can be copied and used freely without restrictions. It can
-# be used in projects which are not available under the GNU Public License
-# but which still want to provide support for the GNU gettext functionality.
-# Please note that the actual code is *not* freely available.
-
-# serial 5
-
AC_DEFUN(AM_GTK_WITH_NLS,
[AC_MSG_CHECKING([whether NLS is requested])
dnl Default is enabled NLS
--- gtk+-1.2.10/gtk-config.in~gtk+1.2-reconf-fix
+++ gtk+-1.2.10/gtk-config.in
@@ -1,10 +1,5 @@
#!/bin/sh
-glib_libs="@glib_libs@"
-glib_cflags="@glib_cflags@"
-glib_thread_libs="@glib_thread_libs@"
-glib_thread_cflags="@glib_thread_cflags@"
-
prefix=@prefix@
exec_prefix=@exec_prefix@
exec_prefix_set=no
@@ -86,27 +81,16 @@
fi
if test "$lib_gthread" = "yes"; then
- glib_cflags="$glib_thread_cflags"
- glib_libs="$glib_thread_libs"
+ modules="gtk+ gthread"
+else
+ modules="gtk+"
fi
if test "$echo_cflags" = "yes"; then
- echo -I@includedir@/gtk-1.2 $glib_cflags @x_cflags@
+ echo `pkg-config --cflags $modules`
fi
if test "$echo_libs" = "yes"; then
- my_glib_libs=
- libdirs=-L@libdir@
- for i in $glib_libs ; do
- if test $i != -L@libdir@ ; then
- if test -z "$my_glib_libs" ; then
- my_glib_libs="$i"
- else
- my_glib_libs="$my_glib_libs $i"
- fi
- fi
- done
-
- echo $libdirs @x_ldflags@ -lgtk -lgdk $my_glib_libs @INTLLIBS@ @x_libs@ @GDK_WLIBS@ -lm
+ echo `pkg-config --libs $modules`
fi

View File

@ -0,0 +1,98 @@
#############################################################
#
# libgtk1.2
#
#############################################################
LIBGTK12_SOURCE:=gtk+-1.2.10.tar.gz
LIBGTK12_SITE:=http://ftp.gnome.org/pub/gnome/sources/gtk+/1.2
LIBGTK12_CAT:=zcat
LIBGTK12_DIR:=$(BUILD_DIR)/gtk+-1.2.10
LIBGTK12_BINARY:=libgtk.a
$(DL_DIR)/$(LIBGTK12_SOURCE):
$(WGET) -P $(DL_DIR) $(LIBGTK12_SITE)/$(LIBGTK12_SOURCE)
libgtk12-source: $(DL_DIR)/$(LIBGTK12_SOURCE)
$(LIBGTK12_DIR)/.unpacked: $(DL_DIR)/$(LIBGTK12_SOURCE)
$(LIBGTK12_CAT) $(DL_DIR)/$(LIBGTK12_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
toolchain/patch-kernel.sh $(LIBGTK12_DIR) package/libgtk12/ \*.patch*
$(CONFIG_UPDATE) $(LIBGTK12_DIR)
touch $(LIBGTK12_DIR)/.unpacked
$(LIBGTK12_DIR)/.configured: $(LIBGTK12_DIR)/.unpacked
(cd $(LIBGTK12_DIR); rm -rf config.cache; \
$(TARGET_CONFIGURE_OPTS) \
ac_cv_func_mmap_fixed_mapped=yes \
./configure \
--host=$(REAL_GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
--libexecdir=/usr/lib \
--sysconfdir=/etc \
--datadir=/usr/share \
--localstatedir=/var \
--mandir=/usr/man \
--infodir=/usr/info \
$(DISABLE_NLS) \
--x-includes=$(STAGING_DIR)/usr/X11R6/include \
--x-libraries=$(STAGING_DIR)/usr/X11R6/lib \
--with-glib-prefix=$(STAGING_DIR) \
--enable-debug=no \
--disable-glibtest \
--disable-xim \
--enable-shared \
);
touch $(LIBGTK12_DIR)/.configured
$(LIBGTK12_DIR)/.libs/$(LIBGTK12_BINARY): $(LIBGTK12_DIR)/.configured
$(MAKE) CC=$(TARGET_CC) -C $(LIBGTK12_DIR)
$(STAGING_DIR)/lib/$(LIBGTK12_BINARY): $(LIBGTK12_DIR)/.libs/$(LIBGTK12_BINARY)
$(MAKE) prefix=$(STAGING_DIR) \
exec_prefix=$(STAGING_DIR) \
bindir=$(STAGING_DIR)/bin \
sbindir=$(STAGING_DIR)/sbin \
libexecdir=$(STAGING_DIR)/libexec \
datadir=$(STAGING_DIR)/share \
sysconfdir=$(STAGING_DIR)/etc \
sharedstatedir=$(STAGING_DIR)/com \
localstatedir=$(STAGING_DIR)/var \
libdir=$(STAGING_DIR)/lib \
includedir=$(STAGING_DIR)/include \
oldincludedir=$(STAGING_DIR)/include \
infodir=$(STAGING_DIR)/info \
mandir=$(STAGING_DIR)/man \
-C $(LIBGTK12_DIR) install;
$(TARGET_DIR)/lib/libgtk-1.2.so.0.9.1: $(STAGING_DIR)/lib/$(LIBGTK12_BINARY)
cp -a $(STAGING_DIR)/lib/libgtk.so $(TARGET_DIR)/lib/
cp -a $(STAGING_DIR)/lib/libgtk-1.2.so.0 $(TARGET_DIR)/lib/
cp -a $(STAGING_DIR)/lib/libgtk-1.2.so.0.9.1 $(TARGET_DIR)/lib/
cp -a $(STAGING_DIR)/lib/libgdk.so $(TARGET_DIR)/lib/
cp -a $(STAGING_DIR)/lib/libgdk-1.2.so.0 $(TARGET_DIR)/lib/
cp -a $(STAGING_DIR)/lib/libgdk-1.2.so.0.9.1 $(TARGET_DIR)/lib/
$(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libgtk-1.2.so.0.9.1
$(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libgdk-1.2.so.0.9.1
libgtk12: uclibc libglib12 xorg $(TARGET_DIR)/lib/libgtk-1.2.so.0.9.1
libgtk12-clean:
rm -f $(TARGET_DIR)/lib/libgtk* $(TARGET_DIR)/lib/libgdk*
-$(MAKE) -C $(LIBGTK12_DIR) clean
libgtk12-dirclean:
rm -rf $(LIBGTK12_DIR)
#############################################################
#
# Toplevel Makefile options
#
#############################################################
ifeq ($(strip $(BR2_PACKAGE_LIBGTK12)),y)
TARGETS+=libgtk12
endif

View File

@ -0,0 +1,267 @@
remove mb and XWC support, as tinyx doesnt support this
#
# Patch managed by http://www.holgerschurig.de/patcher.html
#
--- gtk+-1.2.10/gdk/gdkdraw.c~no-xwc
+++ gtk+-1.2.10/gdk/gdkdraw.c
@@ -236,12 +236,14 @@
strlen (string) / 2);
}
}
+#ifdef HAVE_XWC
else if (font->type == GDK_FONT_FONTSET)
{
XFontSet fontset = (XFontSet) font_private->xfont;
XmbDrawString (drawable_private->xdisplay, drawable_private->xwindow,
fontset, gc_private->xgc, x, y, string, strlen (string));
}
+#endif
else
g_error("undefined font type\n");
}
@@ -291,12 +293,14 @@
gc_private->xgc, x, y, (XChar2b *) text, text_length / 2);
}
}
+#ifdef HAVE_XWC
else if (font->type == GDK_FONT_FONTSET)
{
XFontSet fontset = (XFontSet) font_private->xfont;
XmbDrawString (drawable_private->xdisplay, drawable_private->xwindow,
fontset, gc_private->xgc, x, y, text, text_length);
}
+#endif
else
g_error("undefined font type\n");
}
@@ -337,6 +341,7 @@
g_free (glyphs);
}
}
+#ifdef HAVE_XWC
else if (font->type == GDK_FONT_FONTSET)
{
if (sizeof(GdkWChar) == sizeof(wchar_t))
@@ -357,6 +362,7 @@
g_free (text_wchar);
}
}
+#endif
else
g_error("undefined font type\n");
}
--- gtk+-1.2.10/gdk/gdkim.c~no-xwc
+++ gtk+-1.2.10/gdk/gdkim.c
@@ -121,6 +121,7 @@
current_locale = setlocale (LC_ALL, NULL);
+#ifdef HAVE_XWC
if ((strcmp (current_locale, "C")) && (strcmp (current_locale, "POSIX")))
{
gdk_use_mb = TRUE;
@@ -145,7 +146,8 @@
GDK_NOTE (XIM,
g_message ("%s multi-byte string functions.",
gdk_use_mb ? "Using" : "Not using"));
-
+#endif
+
return current_locale;
}
@@ -1551,6 +1553,7 @@
else
length = len;
+#ifdef HAVE_XWC
if (gdk_use_mb)
{
XTextProperty tpr;
@@ -1589,6 +1592,7 @@
g_free (src_wc);
}
else
+#endif
{
gint i;
@@ -1644,6 +1648,7 @@
/* NoMem or LocaleNotSupp */
return -1;
}
+#ifdef HAVE_XWC
if (XwcTextPropertyToTextList (gdk_display, &tpr, &wstrs, &num_wstrs)
!= Success)
{
@@ -1659,6 +1664,7 @@
dest[len_cpy] = wstr_src[len_cpy];
XwcFreeStringList (wstrs);
return len_cpy;
+#endif
}
else
{
--- gtk+-1.2.10/gdk/gdkfont.c~no-xwc
+++ gtk+-1.2.10/gdk/gdkfont.c
@@ -244,9 +244,11 @@
gdk_xid_table_remove (((XFontStruct *) private->xfont)->fid);
XFreeFont (private->xdisplay, (XFontStruct *) private->xfont);
break;
+#ifdef HAVE_XWC
case GDK_FONT_FONTSET:
XFreeFontSet (private->xdisplay, (XFontSet) private->xfont);
break;
+#endif
default:
g_error ("unknown font type.");
break;
@@ -292,6 +294,7 @@
return (((XFontStruct *) privatea->xfont)->fid ==
((XFontStruct *) privateb->xfont)->fid);
}
+#ifdef HAVE_XWC
else if (fonta->type == GDK_FONT_FONTSET && fontb->type == GDK_FONT_FONTSET)
{
gchar *namea, *nameb;
@@ -301,6 +304,7 @@
return (strcmp(namea, nameb) == 0);
}
+#endif
else
/* fontset != font */
return FALSE;
@@ -333,10 +337,12 @@
width = XTextWidth16 (xfont, (XChar2b *) string, strlen (string) / 2);
}
break;
+#ifdef HAVE_XWC
case GDK_FONT_FONTSET:
fontset = (XFontSet) font_private->xfont;
width = XmbTextEscapement (fontset, string, strlen(string));
break;
+#endif
default:
width = 0;
}
@@ -372,10 +378,12 @@
width = XTextWidth16 (xfont, (XChar2b *) text, text_length / 2);
}
break;
+#ifdef HAVE_XWC
case GDK_FONT_FONTSET:
fontset = (XFontSet) private->xfont;
width = XmbTextEscapement (fontset, text, text_length);
break;
+#endif
default:
width = 0;
}
@@ -414,6 +422,7 @@
break;
}
+#ifdef HAVE_XWC
case GDK_FONT_FONTSET:
if (sizeof(GdkWChar) == sizeof(wchar_t))
{
@@ -431,6 +440,7 @@
g_free (text_wchar);
}
break;
+#endif
default:
width = 0;
}
@@ -474,10 +484,12 @@
width = XTextWidth (xfont, &character, 1);
}
break;
+#ifdef HAVE_XWC
case GDK_FONT_FONTSET:
fontset = (XFontSet) private->xfont;
width = XmbTextEscapement (fontset, &character, 1) ;
break;
+#endif
default:
width = 0;
}
@@ -523,6 +535,7 @@
break;
}
+#ifdef HAVE_XWC
case GDK_FONT_FONTSET:
fontset = (XFontSet) private->xfont;
{
@@ -530,6 +543,7 @@
width = XwcTextEscapement (fontset, &char_wc, 1) ;
}
break;
+#endif
default:
width = 0;
}
@@ -597,6 +611,7 @@
if (descent)
*descent = overall.descent;
break;
+#ifdef HAVE_XWC
case GDK_FONT_FONTSET:
fontset = (XFontSet) private->xfont;
XmbTextExtents (fontset, text, text_length, &ink, &logical);
@@ -611,6 +626,7 @@
if (descent)
*descent = ink.y + ink.height;
break;
+#endif
}
}
@@ -664,6 +680,7 @@
break;
}
+#ifdef HAVE_XWC
case GDK_FONT_FONTSET:
fontset = (XFontSet) private->xfont;
@@ -691,6 +708,7 @@
if (descent)
*descent = ink.y + ink.height;
break;
+#endif
}
}
@@ -750,11 +768,13 @@
}
width = overall.rbearing;
break;
+#ifdef HAVE_XWC
case GDK_FONT_FONTSET:
fontset = (XFontSet) private->xfont;
XmbTextExtents (fontset, text, text_length, &ink, &log);
width = ink.x + ink.width;
break;
+#endif
default:
width = 0;
}
@@ -818,11 +838,13 @@
}
height = overall.ascent + overall.descent;
break;
+#ifdef HAVE_XWC
case GDK_FONT_FONTSET:
fontset = (XFontSet) private->xfont;
XmbTextExtents (fontset, text, text_length, &ink, &log);
height = log.height;
break;
+#endif
default:
height = 0;
}

View File

@ -0,0 +1,15 @@
diff -NurBabdH gtk+-1.2.10/gtk/testrgb.c gtk+-1.2.10-timezone-fix/gtk/testrgb.c
--- gtk+-1.2.10/gtk/testrgb.c 2000-08-18 23:36:34.000000000 +0200
+++ gtk+-1.2.10-timezone-fix/gtk/testrgb.c 2005-03-03 11:18:09.000000000 +0100
@@ -49,7 +49,10 @@
get_time (void)
{
struct timeval tv;
- struct timezone tz;
+ struct timezone {
+ int tz_minuteswest; /* minutes W of Greenwich */
+ int tz_dsttime; /* type of dst correction */
+ } tz;
gettimeofday (&tv, &tz);

File diff suppressed because it is too large Load Diff