package/pkcs11-helper: bump to version 1.30.0

Drop patch (already in version) and so drop autoreconf

https://github.com/OpenSC/pkcs11-helper/releases/tag/pkcs11-helper-1.30.0

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
Fabrice Fontaine 2023-12-26 21:36:47 +01:00 committed by Yann E. MORIN
parent 0a8d669f8e
commit b50c3a431a
4 changed files with 2 additions and 74 deletions

View File

@ -1063,7 +1063,6 @@ package/pigpio/S50pigpio Shellcheck Variables
package/pistache/0001-src-common-transport.cc-fallback-value-for-RUSAGE_TH.patch Upstream
package/pistache/0002-src-server-listener.cc-fix-libressl-build.patch Upstream
package/pixman/0001-Disable-tests.patch Upstream
package/pkcs11-helper/0001-openssl-libressl-3-5-0-does-not-have-DSA_meth_set1_name.patch Upstream
package/pkgconf/0001-Only-prefix-with-the-sysroot-a-subset-of-variables.patch Upstream
package/pkgconf/0002-Revert-main-assume-modversion-insted-of-version-if-o.patch Upstream
package/pkgconf/pkg-config.in Shellcheck

View File

@ -1,69 +0,0 @@
From 17d10b0dfb2b56a047db307687640adcd560e199 Mon Sep 17 00:00:00 2001
From: Alon Bar-Lev <alon.barlev@gmail.com>
Date: Mon, 2 May 2022 21:26:58 +0300
Subject: [PATCH] openssl: libressl-3.5.0 does not have DSA_meth_set1_name
while it does not expose the DSA_METHOD structure.
[Retrieved (and updated to remove ChangeLog update) from:
https://github.com/OpenSC/pkcs11-helper/commit/17d10b0dfb2b56a047db307687640adcd560e199]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
ChangeLog | 1 +
configure.ac | 16 ++++++++++++++++
lib/pkcs11h-openssl.c | 4 ++++
3 files changed, 21 insertions(+)
diff --git a/configure.ac b/configure.ac
index 716bb8d8..57697a3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -300,7 +300,9 @@ if test "${have_openssl}" = "no"; then
fi
if test "${have_openssl}" = "yes"; then
+ old_CFLAGS="${CFLAGS}"
old_LIBS="${LIBS}"
+ CFLAGS="${CFLAGS} ${OPENSSL_CFLAGS}"
LIBS="${LIBS} ${OPENSSL_LIBS}"
AC_CHECK_FUNCS([ \
RSA_meth_dup RSA_meth_free \
@@ -344,6 +346,20 @@ if test "${have_openssl}" = "yes"; then
)
AC_MSG_CHECKING([for OpenSSL ec support])
AC_MSG_RESULT([${openssl_ec}])
+ # https://github.com/OpenSC/pkcs11-helper/pull/55
+ AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM(
+ [[#include <openssl/dsa.h>]],
+ [[
+ int foo() {
+ DSA_METHOD *meth = NULL;
+ sizeof(meth->name);
+ }
+ ]]
+ )],
+ [AC_DEFINE([HAVE_DSA_METHOD_NAME], [1], [Have DSA_METHOD->name])]
+ )
+ CFLAGS="${old_CFLAGS}"
LIBS="${old_LIBS}"
fi
diff --git a/lib/pkcs11h-openssl.c b/lib/pkcs11h-openssl.c
index 961c955c..38ee8e2d 100644
--- a/lib/pkcs11h-openssl.c
+++ b/lib/pkcs11h-openssl.c
@@ -235,9 +235,13 @@ DSA_meth_free (DSA_METHOD *meth)
static int
DSA_meth_set1_name (DSA_METHOD *meth, const char *name)
{
+#ifdef HAVE_DSA_METHOD_NAME
CK_RV rv;
rv = _pkcs11h_mem_strdup ((void *)&meth->name, name);
return rv == CKR_OK ? 1 : 0;
+#else
+ return 0;
+#endif
}
#endif

View File

@ -1,5 +1,5 @@
# Locally computed
sha256 996846a3c8395e03d8c0515111dc84d82e6e3648d44ba28cb2dbbbca2d4db7d6 pkcs11-helper-1.29.0.tar.bz2
sha256 4c5815ba910cabf26df08d449ca2909daf4538c9899aa7f7fadc61229d3488a9 pkcs11-helper-1.30.0.tar.bz2
sha256 808705ac1daafe07a76431929575c5712a8693977a39ec9102aed25f030754d9 COPYING
sha256 865496cf23a6c792739ff2f9ea11e95ac99db89cfe3780a295b4e1495a9c19fe COPYING.BSD
sha256 cd2e7d63a11058f19c58b06fb8c759140ce70788369dce6e6e9db40d3475021e COPYING.GPL

View File

@ -4,15 +4,13 @@
#
################################################################################
PKCS11_HELPER_VERSION = 1.29.0
PKCS11_HELPER_VERSION = 1.30.0
PKCS11_HELPER_SOURCE = pkcs11-helper-$(PKCS11_HELPER_VERSION).tar.bz2
PKCS11_HELPER_SITE = https://github.com/OpenSC/pkcs11-helper/releases/download/pkcs11-helper-$(PKCS11_HELPER_VERSION)
PKCS11_HELPER_LICENSE = GPL-2.0 or BSD-3-Clause
PKCS11_HELPER_LICENSE_FILES = COPYING COPYING.BSD COPYING.GPL
PKCS11_HELPER_DEPENDENCIES = host-pkgconf
PKCS11_HELPER_INSTALL_STAGING = YES
# We're patching configure.ac
PKCS11_HELPER_AUTORECONF = YES
PKCS11_HELPER_CONF_OPTS = \
--disable-crypto-engine-polarssl \