package/htpdate: bump to version 1.3.4

Removing also the upstreamed patch.

Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Angelo Compagnucci 2022-04-26 23:01:28 +02:00 committed by Thomas Petazzoni
parent 2e49ff1020
commit b3f42bf100
3 changed files with 2 additions and 39 deletions

View File

@ -1,37 +0,0 @@
From 4ba90fedd553c3b06c925fb6ff5245a5dcabace9 Mon Sep 17 00:00:00 2001
From: Eddy Vervest <eddy@vervest.org>
Date: Sat, 29 Jan 2022 10:58:13 +0100
Subject: [PATCH] Allow SSL_LIBS to be configured from environment
[Retrieved from:
https://github.com/twekkel/htpdate/commit/4ba90fedd553c3b06c925fb6ff5245a5dcabace9]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Makefile | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/Makefile b/Makefile
index 4796efa..cf077e6 100644
--- a/Makefile
+++ b/Makefile
@@ -2,8 +2,9 @@ prefix = $(DESTDIR)/usr
bindir = ${prefix}/sbin
mandir = ${prefix}/share/man
-CC ?= gcc
-CFLAGS += -Wall -std=c11 -pedantic -O2
+CC ?= gcc
+CFLAGS += -Wall -std=c11 -pedantic -O2
+SSL_LIBS ?= -lssl
INSTALL ?= install -c
STRIP ?= strip -s
@@ -14,7 +15,7 @@ htpdate: htpdate.c
$(CC) $(CFLAGS) -o htpdate htpdate.c
https: htpdate.c
- $(CC) $(CFLAGS) -DENABLE_HTTPS -o htpdate htpdate.c -lssl
+ $(CC) $(CFLAGS) -DENABLE_HTTPS -o htpdate htpdate.c $(SSL_LIBS)
install: all
$(STRIP) htpdate

View File

@ -1,3 +1,3 @@
# Locally calculated:
sha256 74f34b013eba6f99369819fa4b3d48e9ab5e531ad04f6af59cc04e8777c76ed7 htpdate-1.3.3.tar.gz
sha256 744f9200cfd3b008a5516c5eb6da727af532255a329126a7b8f49a5623985642 htpdate-1.3.4.tar.gz
sha256 7989949df09a0489434723c571541604cd3f2e0418c6a6aa9179bfaf8ec807cc LICENSE

View File

@ -4,7 +4,7 @@
#
################################################################################
HTPDATE_VERSION = 1.3.3
HTPDATE_VERSION = 1.3.4
HTPDATE_SITE = $(call github,twekkel,htpdate,v$(HTPDATE_VERSION))
HTPDATE_LICENSE = GPL-2.0+
HTPDATE_LICENSE_FILES = LICENSE