package/octave: bump to version 8.1.0

For change log, see:
https://octave.org/NEWS-8.html

Notable changes in this commit:
- the package patch was rebased and updated for this new version
- a comment in .hash file about signature verification is added
- the pcre dependency is replaced by pcre2, following the upstream
  package recommendation and preference. See:
  https://octave.org/NEWS-8.html#general-improvements
  This change also adds the host-pkgconf as a dependency.

Signed-off-by: Julien Olivain <ju.o@free.fr>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
Julien Olivain 2023-03-15 07:14:15 +01:00 committed by Yann E. MORIN
parent b97f479a9f
commit b36e4b10f3
4 changed files with 15 additions and 13 deletions

View File

@ -1,4 +1,4 @@
From e4dcfefac4215ee66c3dda5b067dd6d06066b0a2 Mon Sep 17 00:00:00 2001 From 75b973373ed2e9a7a30f62dfe330299306ecff75 Mon Sep 17 00:00:00 2001
From: Julien Olivain <ju.o@free.fr> From: Julien Olivain <ju.o@free.fr>
Date: Sat, 5 Mar 2022 12:36:09 +0100 Date: Sat, 5 Mar 2022 12:36:09 +0100
Subject: [PATCH] Fix BLAS library integer size detection Subject: [PATCH] Fix BLAS library integer size detection
@ -19,22 +19,22 @@ Signed-off-by: Julien Olivain <ju.o@free.fr>
1 file changed, 6 insertions(+) 1 file changed, 6 insertions(+)
diff --git a/configure.ac b/configure.ac diff --git a/configure.ac b/configure.ac
index de7a00a330..383ce27b06 100644 index 4092e5915d..f4ea2c1987 100644
--- a/configure.ac --- a/configure.ac
+++ b/configure.ac +++ b/configure.ac
@@ -781,6 +781,12 @@ if test $ax_blas_ok = no || test $ax_lapack_ok = no; then @@ -757,6 +757,12 @@ if test $ax_blas_ok = no || test $ax_lapack_ok = no; then
AC_MSG_ERROR([BLAS and LAPACK libraries are required]) AC_MSG_ERROR([BLAS and LAPACK libraries are required])
fi fi
+if ac_fn_f77_try_run "$LINENO"; then : +if ac_fn_f77_try_run "$LINENO"; then :
+ ax_blas_integer_size=8 + ax_cv_blas_integer_size=8
+else +else
+ ax_blas_integer_size=4 + ax_cv_blas_integer_size=4
+fi +fi
+ +
case $ax_blas_integer_size in case $ax_cv_blas_integer_size in
4) 4)
HAVE_64_BIT_BLAS=no HAVE_64_BIT_BLAS=no
-- --
2.36.0 2.39.2

View File

@ -13,8 +13,7 @@ config BR2_PACKAGE_OCTAVE
# used by the "utils/test-pkg" script. # used by the "utils/test-pkg" script.
depends on !BR2_TOOLCHAIN_EXTERNAL_BOOTLIN || !BR2_x86_64 depends on !BR2_TOOLCHAIN_EXTERNAL_BOOTLIN || !BR2_x86_64
select BR2_PACKAGE_OPENBLAS select BR2_PACKAGE_OPENBLAS
select BR2_PACKAGE_PCRE select BR2_PACKAGE_PCRE2
select BR2_PACKAGE_PCRE_UTF
help help
GNU Octave is a high-level language, primarily intended for GNU Octave is a high-level language, primarily intended for
numerical computations. It provides a convenient command numerical computations. It provides a convenient command

View File

@ -1,3 +1,5 @@
# Locally computed # Locally computed after checking signature
sha256 fdb32602252289e068431329add2eed146e6f26301cbb5fc4412f9d972db9475 octave-7.3.0.tar.lz # https://ftp.gnu.org/gnu/octave/octave-8.1.0.tar.lz.sig
# using key DBD9C84E39FE1AAE99F04446B05F05B75D36644B
sha256 79f35c249e5ed71c6cafcf26ef72ffcf4845637093efde309b499a6690154b4f octave-8.1.0.tar.lz
sha256 3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986 COPYING sha256 3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986 COPYING

View File

@ -4,7 +4,7 @@
# #
################################################################################ ################################################################################
OCTAVE_VERSION = 7.3.0 OCTAVE_VERSION = 8.1.0
OCTAVE_SITE = https://ftp.gnu.org/gnu/octave OCTAVE_SITE = https://ftp.gnu.org/gnu/octave
OCTAVE_SOURCE = octave-$(OCTAVE_VERSION).tar.lz OCTAVE_SOURCE = octave-$(OCTAVE_VERSION).tar.lz
OCTAVE_LICENSE = GPL-3.0+ OCTAVE_LICENSE = GPL-3.0+
@ -15,8 +15,9 @@ OCTAVE_CONF_OPTS = --disable-java
OCTAVE_DEPENDENCIES = \ OCTAVE_DEPENDENCIES = \
host-gperf \ host-gperf \
host-pkgconf \
openblas \ openblas \
pcre pcre2
ifeq ($(BR2_PACKAGE_READLINE),y) ifeq ($(BR2_PACKAGE_READLINE),y)
OCTAVE_CONF_OPTS += --enable-readline OCTAVE_CONF_OPTS += --enable-readline