From b2c6fe8f7843b96ddbf60ff49a63b13dcea4994c Mon Sep 17 00:00:00 2001
From: Eric Andersen <andersen@codepoet.org>
Date: Fri, 14 Feb 2003 12:20:38 +0000
Subject: [PATCH] Remove unwanted docs

---
 make/autoconf.mk  | 3 ++-
 make/automake.mk  | 3 ++-
 make/gdb.mk       | 2 ++
 make/gdbserver.mk | 2 ++
 make/libtool.mk   | 3 ++-
 make/m4.mk        | 3 ++-
 6 files changed, 12 insertions(+), 4 deletions(-)

diff --git a/make/autoconf.mk b/make/autoconf.mk
index 92b4df36d5..fe11b2c7d8 100644
--- a/make/autoconf.mk
+++ b/make/autoconf.mk
@@ -55,7 +55,8 @@ $(TARGET_DIR)/$(AUTOCONF_TARGET_BINARY): $(AUTOCONF_DIR)/bin/$(AUTOCONF_BINARY)
 	    mandir=$(TARGET_DIR)/usr/man \
 	    includedir=$(TARGET_DIR)/usr/include \
 	    -C $(AUTOCONF_DIR) install;
-	rm -rf $(TARGET_DIR)/share/locale
+	rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+		$(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
 
 autoconf: uclibc $(TARGET_DIR)/$(AUTOCONF_TARGET_BINARY)
 
diff --git a/make/automake.mk b/make/automake.mk
index bc226c10f4..6d4bbaa7d6 100644
--- a/make/automake.mk
+++ b/make/automake.mk
@@ -56,7 +56,8 @@ $(TARGET_DIR)/$(AUTOMAKE_TARGET_BINARY): $(AUTOMAKE_DIR)/$(AUTOMAKE_BINARY)
 	    mandir=$(TARGET_DIR)/usr/man \
 	    includedir=$(TARGET_DIR)/usr/include \
 	    -C $(AUTOMAKE_DIR) install;
-	rm -rf $(TARGET_DIR)/share/locale
+	rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+		$(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
 	touch -c $(TARGET_DIR)/$(AUTOMAKE_TARGET_BINARY)
 
 automake: uclibc $(TARGET_DIR)/$(AUTOMAKE_TARGET_BINARY)
diff --git a/make/gdb.mk b/make/gdb.mk
index 5b6650af76..8d54f82260 100644
--- a/make/gdb.mk
+++ b/make/gdb.mk
@@ -49,6 +49,8 @@ $(GDB_DIR)/gdb/gdb: $(GDB_DIR)/.configured
 
 $(TARGET_DIR)/usr/bin/gdb: $(GDB_DIR)/gdb/gdb
 	install -c $(GDB_DIR)/gdb/gdb $(TARGET_DIR)/usr/bin/gdb
+	rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+		$(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
 
 gdb: $(TARGET_DIR)/usr/bin/gdb
 
diff --git a/make/gdbserver.mk b/make/gdbserver.mk
index c1ef1f1aa2..bafd4d9e17 100644
--- a/make/gdbserver.mk
+++ b/make/gdbserver.mk
@@ -42,6 +42,8 @@ $(GDB_WDIR)/gdbserver: $(GDB_WDIR)/.configured
 
 $(TARGET_DIR)/usr/bin/gdbserver: $(GDB_WDIR)/gdbserver
 	install -c $(GDB_WDIR)/gdbserver $(TARGET_DIR)/usr/bin/gdbserver
+	rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+		$(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
 
 gdbserver: $(TARGET_DIR)/usr/bin/gdbserver
 
diff --git a/make/libtool.mk b/make/libtool.mk
index 6043f52856..126b720d84 100644
--- a/make/libtool.mk
+++ b/make/libtool.mk
@@ -59,7 +59,8 @@ $(TARGET_DIR)/$(LIBTOOL_TARGET_BINARY): $(LIBTOOL_DIR)/$(LIBTOOL_BINARY)
 	    -C $(LIBTOOL_DIR) install;
 	perl -pi -e "s,^CC.*,CC=\"/usr/bin/gcc\"," $(TARGET_DIR)/usr/bin/libtool
 	perl -pi -e "s,^LD.*,LD=\"/usr/bin/ld\"," $(TARGET_DIR)/usr/bin/libtool
-	rm -rf $(TARGET_DIR)/share/locale
+	rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+		$(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
 
 libtool: uclibc $(TARGET_DIR)/$(LIBTOOL_TARGET_BINARY)
 
diff --git a/make/m4.mk b/make/m4.mk
index 8be5ddedb1..e435386e92 100644
--- a/make/m4.mk
+++ b/make/m4.mk
@@ -47,7 +47,8 @@ $(TARGET_DIR)/$(M4_TARGET_BINARY): $(M4_DIR)/src/$(M4_BINARY)
 	    mandir=$(TARGET_DIR)/usr/man \
 	    includedir=$(TARGET_DIR)/usr/include \
 	    -C $(M4_DIR) install;
-	rm -rf $(TARGET_DIR)/share/locale
+	rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+		$(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
 
 m4: uclibc $(TARGET_DIR)/$(M4_TARGET_BINARY)