package/pixman: bump version to 0.33.4

Removed patches applied upstream.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Bernd Kuhls 2015-11-14 00:26:40 +01:00 committed by Peter Korsgaard
parent de2ea6ad54
commit b282351c13
4 changed files with 4 additions and 77 deletions

View File

@ -1,41 +0,0 @@
Add a check for FE_DIVBYZERO
Some architectures (namely Microblaze) do have fenv.h and
feenableexcept, but they don't have the FE_DIVBYZERO definition. This
patch adds a configure check for FE_DIVBYZERO, and only uses it if
it's available.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -838,6 +838,11 @@
AC_DEFINE(HAVE_FEENABLEEXCEPT, 1, [Whether we have feenableexcept()])
fi
+AC_CHECK_DECL([FE_DIVBYZERO], [], [], [[#include <fenv.h>]])
+if test x$ac_cv_have_decl_FE_DIVBYZERO = xyes; then
+ AC_DEFINE(HAVE_FEDIVBYZERO, 1, [Whether we have FE_DIVBYZERO])
+fi
+
AC_CHECK_FUNC(gettimeofday, have_gettimeofday=yes, have_gettimeofday=no)
AC_CHECK_HEADER(sys/time.h, have_sys_time_h=yes, have_sys_time_h=no)
if test x$have_gettimeofday = xyes && test x$have_sys_time_h = xyes; then
Index: b/test/utils.c
===================================================================
--- a/test/utils.c
+++ b/test/utils.c
@@ -776,9 +776,11 @@
{
#ifdef HAVE_FENV_H
#ifdef HAVE_FEENABLEEXCEPT
+#ifdef HAVE_FE_DIVBYZERO
feenableexcept (FE_DIVBYZERO);
#endif
#endif
+#endif
}
void *

View File

@ -1,33 +0,0 @@
pixman: Fix C pre-processor issues in LEAF_MIPS32R2
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
From 3a60aa8d574f4dfc4fa3ddb13aaa13c7d955105b Mon Sep 17 00:00:00 2001
From: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Date: Thu, 11 Sep 2014 10:24:10 +0100
Subject: [PATCH] Fix C pre-processor issues in LEAF_MIPS32R2
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
---
pixman/pixman-mips-dspr2-asm.h | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/pixman/pixman-mips-dspr2-asm.h b/pixman/pixman-mips-dspr2-asm.h
index 11849bd..b2696d0 100644
--- a/pixman/pixman-mips-dspr2-asm.h
+++ b/pixman/pixman-mips-dspr2-asm.h
@@ -72,10 +72,10 @@
#define LEAF_MIPS32R2(symbol) \
.globl symbol; \
.align 2; \
-#ifdef __ELF__
+ .if __ELF__; \
.hidden symbol; \
.type symbol, @function; \
-#endif
+ .endif; \
.ent symbol, 0; \
symbol: .frame sp, 0, ra; \
.set push; \
--
1.7.1

View File

@ -1,2 +1,2 @@
# From http://cairographics.org/releases/pixman-0.32.8.tar.gz.sha1
sha1 c1119bbdb587c56009b653e6f81c083f98a20135 pixman-0.32.8.tar.gz
# From http://lists.x.org/archives/xorg-announce/2015-October/002644.html
sha1 dff77cd08412b33ab0294057ade93e401c8a9302 pixman-0.33.4.tar.bz2

View File

@ -4,7 +4,8 @@
#
################################################################################
PIXMAN_VERSION = 0.32.8
PIXMAN_VERSION = 0.33.4
PIXMAN_SOURCE = pixman-$(PIXMAN_VERSION).tar.bz2
PIXMAN_SITE = http://xorg.freedesktop.org/releases/individual/lib
PIXMAN_LICENSE = MIT
PIXMAN_LICENSE_FILES = COPYING