package/libusb: bump to version 1.0.26

Remove upstreamed patches.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
[Peter: drop _AUTORECONF]
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Yegor Yefremov 2022-06-20 14:56:36 +02:00 committed by Peter Korsgaard
parent 9b7f8da96b
commit b1fe952835
4 changed files with 2 additions and 80 deletions

View File

@ -1,39 +0,0 @@
From 0b857081d687f7ee41483a3d7e9846af44a5ba7d Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Mon, 7 Feb 2022 11:55:54 +0100
Subject: [PATCH] configure.ac: link with -latomic if needed
libusb unconditionally uses atomic_fetch_add since version 1.0.25 and
https://github.com/libusb/libusb/commit/1a08aa84d96397a3840a75abe66051f5360c2c84
https://github.com/libusb/libusb/commit/eed8a371ea53939096ba94d44001e0637d042572
but some architectures (e.g. sparc) needs to link with -latomic to be
able to use it. So check if -latomic is needed and update libusb-1.0.pc
accordingly to avoid the following build failure with openocd:
/home/buildroot/autobuild/instance-0/output-1/host/opt/ext-toolchain/bin/../lib/gcc/sparc-buildroot-linux-uclibc/10.3.0/../../../../sparc-buildroot-linux-uclibc/bin/ld: /home/buildroot/autobuild/instance-0/output-1/host/sparc-buildroot-linux-uclibc/sysroot/usr/lib/libusb-1.0.so: undefined reference to `__atomic_fetch_add_4'
collect2: error: ld returned 1 exit status
Fixes:
- http://autobuild.buildroot.org/results/4a27a769bb3cdf78643c3049b87d792178d6512c
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://github.com/libusb/libusb/pull/1064]
---
configure.ac | 1 +
1 file changed, 1 insertion(+)
diff --git a/configure.ac b/configure.ac
index f6cf2f9..002bcf6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -152,6 +152,7 @@ if test "x$platform" = xposix; then
AC_SEARCH_LIBS([pthread_create], [pthread],
[test "x$ac_cv_search_pthread_create" != "xnone required" && AC_SUBST(THREAD_LIBS, [-lpthread])],
[], [])
+ AC_SEARCH_LIBS([__atomic_fetch_add_4], [atomic])
elif test "x$platform" = xwindows; then
AC_DEFINE([PLATFORM_WINDOWS], [1], [Define to 1 if compiling for a Windows platform.])
else
--
2.34.1

View File

@ -1,37 +0,0 @@
From bea5891591402f14940a607eafbdcd169ff8827f Mon Sep 17 00:00:00 2001
From: Yegor Yefremov <yegorslists@googlemail.com>
Date: Sun, 6 Feb 2022 07:12:14 +0100
Subject: [PATCH] linux_usbfs: fix maybe-uninitialized error
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Initialize active_config to an invalid value to avoid the following
compilation error:
os/linux_usbfs.c: In function op_get_configuration:
os/linux_usbfs.c:1452:12: error: active_config may be used uninitialized in this function [-Werror=maybe-uninitialized]
1452 | *config = (uint8_t)active_config;
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Upstream: https://github.com/libusb/libusb/pull/1062
---
libusb/os/linux_usbfs.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libusb/os/linux_usbfs.c b/libusb/os/linux_usbfs.c
index c300675..285d9ca 100644
--- a/libusb/os/linux_usbfs.c
+++ b/libusb/os/linux_usbfs.c
@@ -1429,7 +1429,7 @@ static int op_get_configuration(struct libusb_device_handle *handle,
uint8_t *config)
{
struct linux_device_priv *priv = usbi_get_device_priv(handle->dev);
- int active_config;
+ int active_config = -1; /* to please compiler */
int r;
if (priv->sysfs_dir) {
--
2.17.0

View File

@ -1,3 +1,3 @@
# Locally computed:
sha256 8a28ef197a797ebac2702f095e81975e2b02b2eeff2774fa909c78a74ef50849 libusb-1.0.25.tar.bz2
sha256 12ce7a61fc9854d1d2a1ffe095f7b5fac19ddba095c259e6067a46500381b5a5 libusb-1.0.26.tar.bz2
sha256 5df07007198989c622f5d41de8d703e7bef3d0e79d62e24332ee739a452af62a COPYING

View File

@ -5,7 +5,7 @@
################################################################################
LIBUSB_VERSION_MAJOR = 1.0
LIBUSB_VERSION = $(LIBUSB_VERSION_MAJOR).25
LIBUSB_VERSION = $(LIBUSB_VERSION_MAJOR).26
LIBUSB_SOURCE = libusb-$(LIBUSB_VERSION).tar.bz2
LIBUSB_SITE = https://github.com/libusb/libusb/releases/download/v$(LIBUSB_VERSION)
LIBUSB_LICENSE = LGPL-2.1+
@ -13,8 +13,6 @@ LIBUSB_LICENSE_FILES = COPYING
LIBUSB_CPE_ID_VENDOR = libusb
LIBUSB_DEPENDENCIES = host-pkgconf
LIBUSB_INSTALL_STAGING = YES
# We're patching configure.ac
LIBUSB_AUTORECONF = YES
# Avoid the discovery of udev for the host variant
HOST_LIBUSB_CONF_OPTS = --disable-udev