ntfsprogs: remove deprecated
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
4e57e9ce77
commit
b1a70b76ab
@ -200,7 +200,6 @@ source "package/memtester/Config.in"
|
||||
source "package/minicom/Config.in"
|
||||
source "package/mtd/Config.in"
|
||||
source "package/ntfs-3g/Config.in"
|
||||
source "package/ntfsprogs/Config.in"
|
||||
source "package/open2300/Config.in"
|
||||
source "package/openocd/Config.in"
|
||||
source "package/pciutils/Config.in"
|
||||
|
@ -1,12 +0,0 @@
|
||||
config BR2_PACKAGE_NTFSPROGS
|
||||
bool "ntfsprogs"
|
||||
depends on BR2_USE_WCHAR
|
||||
depends on BR2_LARGEFILE
|
||||
depends on BR2_DEPRECATED
|
||||
help
|
||||
wide collection of NTFS utilities
|
||||
|
||||
http://www.linux-ntfs.org/
|
||||
|
||||
comment "ntfsprogs requires a toolchain with WCHAR and LARGEFILE support"
|
||||
depends on !BR2_USE_WCHAR || !BR2_LARGEFILE
|
@ -1,42 +0,0 @@
|
||||
[PATCH] ntfsprogs: don't override PKG_CONFIG_PATH
|
||||
|
||||
Adding hardcoded directories to the pkg-config search path breaks
|
||||
cross compilation (E.G. if the host has a .pc for a package the
|
||||
target doesn't have).
|
||||
|
||||
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
|
||||
---
|
||||
configure | 4 ----
|
||||
configure.ac | 4 ----
|
||||
2 files changed, 8 deletions(-)
|
||||
|
||||
Index: ntfsprogs-2.0.0/configure.ac
|
||||
===================================================================
|
||||
--- ntfsprogs-2.0.0.orig/configure.ac
|
||||
+++ ntfsprogs-2.0.0/configure.ac
|
||||
@@ -168,10 +168,6 @@ AC_PROG_MAKE_SET
|
||||
AC_PROG_LIBTOOL
|
||||
PKG_PROG_PKG_CONFIG
|
||||
|
||||
-# Libraries often install their metadata .pc files in directories not searched
|
||||
-# by pkg-config. Let's workaround this.
|
||||
-export PKG_CONFIG_PATH=${PKG_CONFIG_PATH}:/usr/lib/pkgconfig:/opt/gnome/lib/pkgconfig:/usr/share/pkgconfig:/usr/local/lib/pkgconfig:$prefix/lib/pkgconfig:/opt/gnome/share/pkgconfig:/usr/local/share/pkgconfig
|
||||
-
|
||||
# Enable large file support.
|
||||
AC_SYS_LARGEFILE
|
||||
|
||||
Index: ntfsprogs-2.0.0/configure
|
||||
===================================================================
|
||||
--- ntfsprogs-2.0.0.orig/configure
|
||||
+++ ntfsprogs-2.0.0/configure
|
||||
@@ -20210,10 +20210,6 @@ echo "${ECHO_T}no" >&6; }
|
||||
|
||||
fi
|
||||
|
||||
-# Libraries often install their metadata .pc files in directories not searched
|
||||
-# by pkg-config. Let's workaround this.
|
||||
-export PKG_CONFIG_PATH=${PKG_CONFIG_PATH}:/usr/lib/pkgconfig:/opt/gnome/lib/pkgconfig:/usr/share/pkgconfig:/usr/local/lib/pkgconfig:$prefix/lib/pkgconfig:/opt/gnome/share/pkgconfig:/usr/local/share/pkgconfig
|
||||
-
|
||||
# Enable large file support.
|
||||
# Check whether --enable-largefile was given.
|
||||
if test "${enable_largefile+set}" = set; then
|
@ -1,26 +0,0 @@
|
||||
#############################################################
|
||||
#
|
||||
# ntfsprogs
|
||||
#
|
||||
#############################################################
|
||||
NTFSPROGS_VERSION:=2.0.0
|
||||
NTFSPROGS_SOURCE:=ntfsprogs-$(NTFSPROGS_VERSION).tar.gz
|
||||
NTFSPROGS_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/linux-ntfs/
|
||||
NTFSPROGS_CONF_OPT:=--disable-gnome-vfs --disable-crypto
|
||||
NTFSPROGS_INSTALL_STAGING:=yes
|
||||
|
||||
NTFSPROGS_BIN:=ntfscat ntfscluster ntfscmp ntfsfix ntfsinfo ntfsls
|
||||
NTFSPROGS_SBIN:=ntfsclone ntfscp ntfslabel ntfsresize ntfsundelete mkntfs
|
||||
|
||||
ifeq ($(BR2_PACKAGE_LIBFUSE),y)
|
||||
NTFSPROGS_DEPENDENCIES += libfuse
|
||||
endif
|
||||
|
||||
define NTFSPROGS_UNINSTALL_TARGET_CMDS
|
||||
rm -f $(TARGET_DIR)/usr/lib/libntfs.so*
|
||||
rm -f $(addprefix $(TARGET_DIR)/usr/bin/,$(NTFSPROGS_BIN))
|
||||
rm -f $(addprefix $(TARGET_DIR)/usr/sbin/,$(NTFSPROGS_SBIN))
|
||||
-unlink $(TARGET_DIR)/sbin/mkfs.ntfs
|
||||
endef
|
||||
|
||||
$(eval $(call AUTOTARGETS))
|
Loading…
Reference in New Issue
Block a user