package/htop: bump to version 3.2.0
remove merged patch, and AUTORECONF becomes useless. Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
1183fd1411
commit
b054353e59
@ -1,54 +0,0 @@
|
|||||||
From 4ccad4604586c921b4ad831b254496c2cdece9fc Mon Sep 17 00:00:00 2001
|
|
||||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
||||||
Date: Sat, 2 Apr 2022 17:27:01 +0200
|
|
||||||
Subject: [PATCH] configure.ac: fix static build with hwloc
|
|
||||||
|
|
||||||
Retrieve hwloc dependencies through pkg-config to avoid the following
|
|
||||||
static build failure:
|
|
||||||
|
|
||||||
checking for hwloc_get_proc_cpubind in -lhwloc... no
|
|
||||||
configure: error: can not find required library libhwloc
|
|
||||||
|
|
||||||
This build failure is raised because without pkg-config, hwloc
|
|
||||||
dependencies such as libxml2 are not retrieved:
|
|
||||||
|
|
||||||
configure:8999: checking for hwloc_get_proc_cpubind in -lhwloc
|
|
||||||
configure:9022: /home/autobuild/autobuild/instance-0/output-1/host/bin/powerpc-buildroot-linux-uclibc-gcc -o conftest -D_GNU_SOURCE -I/home/autobuild/autobuild/instance-0/output-1/host/powerpc-buildroot-linux-uclibc/sysroot/usr/bin/../../usr/include -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -Og -g0 -static -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -static conftest.c -lhwloc -llzma -L/home/autobuild/autobuild/instance-0/output-1/host/powerpc-buildroot-linux-uclibc/sysroot/usr/bin/../../usr/lib -lncurses -lm >&5
|
|
||||||
/home/autobuild/autobuild/instance-0/output-1/host/lib/gcc/powerpc-buildroot-linux-uclibc/10.3.0/../../../../powerpc-buildroot-linux-uclibc/bin/ld: /home/autobuild/autobuild/instance-0/output-1/host/powerpc-buildroot-linux-uclibc/sysroot/usr/bin/../../usr/lib/libhwloc.a(topology-xml-libxml.o): in function `hwloc_libxml_free_buffer':
|
|
||||||
topology-xml-libxml.c:(.text+0x6a): undefined reference to `xmlFree'
|
|
||||||
|
|
||||||
Fixes:
|
|
||||||
- http://autobuild.buildroot.org/results/5d815ec08c580005a863df6ac9ac29deff7d4128
|
|
||||||
|
|
||||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
||||||
[Retrieved from:
|
|
||||||
https://github.com/htop-dev/htop/commit/4ccad4604586c921b4ad831b254496c2cdece9fc]
|
|
||||||
---
|
|
||||||
configure.ac | 14 ++++++++++++--
|
|
||||||
1 file changed, 12 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 4ecac1ecf..6bb7eb69f 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -456,8 +456,18 @@ case "$enable_hwloc" in
|
|
||||||
no)
|
|
||||||
;;
|
|
||||||
yes)
|
|
||||||
- AC_CHECK_LIB([hwloc], [hwloc_get_proc_cpubind], [], [AC_MSG_ERROR([can not find required library libhwloc])])
|
|
||||||
- AC_CHECK_HEADERS([hwloc.h], [], [AC_MSG_ERROR([can not find require header file hwloc.h])])
|
|
||||||
+ m4_ifdef([PKG_PROG_PKG_CONFIG], [
|
|
||||||
+ PKG_PROG_PKG_CONFIG()
|
|
||||||
+ PKG_CHECK_MODULES(HWLOC, hwloc, [
|
|
||||||
+ CFLAGS="$CFLAGS $HWLOC_CFLAGS" LIBS="$LIBS $HWLOC_LIBS"
|
|
||||||
+ ], [
|
|
||||||
+ AC_CHECK_LIB([hwloc], [hwloc_get_proc_cpubind], [], [AC_MSG_ERROR([can not find required library libhwloc])])
|
|
||||||
+ AC_CHECK_HEADERS([hwloc.h], [], [AC_MSG_ERROR([can not find require header file hwloc.h])])
|
|
||||||
+ ])
|
|
||||||
+ ], [
|
|
||||||
+ AC_CHECK_LIB([hwloc], [hwloc_get_proc_cpubind], [], [AC_MSG_ERROR([can not find required library libhwloc])])
|
|
||||||
+ AC_CHECK_HEADERS([hwloc.h], [], [AC_MSG_ERROR([can not find require header file hwloc.h])])
|
|
||||||
+ ])
|
|
||||||
;;
|
|
||||||
*)
|
|
||||||
AC_MSG_ERROR([bad value '$enable_hwloc' for --enable-hwloc])
|
|
@ -1,5 +1,5 @@
|
|||||||
# From https://github.com/htop-dev/htop/releases/download/3.1.2/htop-3.1.2.tar.xz.sha256
|
# From https://github.com/htop-dev/htop/releases/download/3.2.0/htop-3.2.0.tar.xz.sha256
|
||||||
sha256 884bce5b58cb113127860b9e368609019e92416a81550fdf0752052f3a64b388 htop-3.1.2.tar.xz
|
sha256 e0f645d4ac324f2c4c48aaa7a3a96d007b95516559550be0b56e423fc5b6d783 htop-3.2.0.tar.xz
|
||||||
|
|
||||||
# Locally calculated
|
# Locally calculated
|
||||||
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
|
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
|
||||||
|
@ -4,11 +4,10 @@
|
|||||||
#
|
#
|
||||||
################################################################################
|
################################################################################
|
||||||
|
|
||||||
HTOP_VERSION = 3.1.2
|
HTOP_VERSION = 3.2.0
|
||||||
HTOP_SOURCE = htop-$(HTOP_VERSION).tar.xz
|
HTOP_SOURCE = htop-$(HTOP_VERSION).tar.xz
|
||||||
HTOP_SITE = https://github.com/htop-dev/htop/releases/download/$(HTOP_VERSION)
|
HTOP_SITE = https://github.com/htop-dev/htop/releases/download/$(HTOP_VERSION)
|
||||||
HTOP_DEPENDENCIES = ncurses
|
HTOP_DEPENDENCIES = ncurses
|
||||||
HTOP_AUTORECONF = YES
|
|
||||||
# Prevent htop build system from searching the host paths
|
# Prevent htop build system from searching the host paths
|
||||||
HTOP_CONF_ENV = HTOP_NCURSES_CONFIG_SCRIPT=$(STAGING_DIR)/usr/bin/$(NCURSES_CONFIG_SCRIPTS)
|
HTOP_CONF_ENV = HTOP_NCURSES_CONFIG_SCRIPT=$(STAGING_DIR)/usr/bin/$(NCURSES_CONFIG_SCRIPTS)
|
||||||
HTOP_LICENSE = GPL-2.0+
|
HTOP_LICENSE = GPL-2.0+
|
||||||
|
Loading…
Reference in New Issue
Block a user