Move AVR32 kernel patches to target/device/Atmel/arch-avr32
Add linux-2.6.22.1-008-atmel-gpio_mouse-setup-for-atstk1000-board.patch Move AT91 kernel patches to target/device/Atmel/arch-arm Change name from "target/device/Atmel/Linux" to "target/device/Atmel/linux" "kernel-headers" will apply all patches in $(LINUX26_KERNEL_PATCH_DIR) if this is available. Define LINUX26_KERNEL_PATCH_DIR in target/device/Atmel/Makefile.in as above "arch-arm/kernel-patches-..." if an AT91 or as above "arch-avr32/kernel-patches-..." if an AVR32 target is selected Test build done for arm,avr32 and x86
This commit is contained in:
parent
134a61d9f7
commit
afec678745
@ -20,7 +20,8 @@ include target/*/*.mk
|
||||
|
||||
ifeq ($(strip $(subst ",,$(BR2_PACKAGE_LINUX_EXPERIMENTAL_CONFIG))),y)
|
||||
#"))
|
||||
include target/linux-experimental/Makefile.in
|
||||
include target/linux/Makefile.in
|
||||
#include target/linux-experimental/Makefile.in
|
||||
else
|
||||
include target/linux/Makefile.in
|
||||
endif
|
||||
|
@ -44,7 +44,17 @@ LINUX26_BINLOC=$(LINUX26_FORMAT)
|
||||
|
||||
LINUX26_COPYTO:=/tftpboot
|
||||
|
||||
LINUX26_PATCH_DIR:=target/device/Atmel/Linux/kernel-patches-$(DOWNLOAD_LINUX26_VERSION)
|
||||
# Patch during kernel header build
|
||||
ifeq ($(BR2_avr32),y)
|
||||
LINUX26_KERNEL_PATCH_DIR:=target/device/Atmel/arch-avr32/kernel-patches-$(DOWNLOAD_LINUX26_VERSION)
|
||||
endif
|
||||
|
||||
# Patch during kernel build
|
||||
ifeq ($(BR2_arm),y)
|
||||
#LINUX26_PATCH_DIR:=target/device/Atmel/arch-at91/kernel-patches-$(DOWNLOAD_LINUX26_VERSION)
|
||||
LINUX26_KERNEL_PATCH_DIR:=target/device/Atmel/arch-at91/kernel-patches-$(DOWNLOAD_LINUX26_VERSION)
|
||||
endif
|
||||
|
||||
|
||||
# The board specific Makefile.in can redefine BOARD_NAME's
|
||||
LINUX_BOARD_NAME:=$(BOARD_NAME)
|
||||
@ -64,7 +74,7 @@ UBOOT_CONFIG:=$(UBOOT_BOARD_NAME)_config
|
||||
UBOOT_CONFIG_FILE:=$(BOARD_PATH)/u-boot/$(UBOOT_BOARD_NAME).h
|
||||
|
||||
ifeq ($(strip $(BR2_PACKAGE_LINUX)),y)
|
||||
include $(ATMEL_PATH)/Linux/linux.mk
|
||||
include $(ATMEL_PATH)/linux/linux.mk
|
||||
endif
|
||||
|
||||
ifeq ($(strip $(BR2_TARGET_UBOOT)),y)
|
||||
|
File diff suppressed because it is too large
Load Diff
14630
target/device/Atmel/arch-arm/kernel-patches-2.6.21.1/2.6.21.1-at91.patch
Normal file
14630
target/device/Atmel/arch-arm/kernel-patches-2.6.21.1/2.6.21.1-at91.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -0,0 +1,36 @@
|
||||
diff -urN linux-2.6.21.1-0rig/drivers/video/atmel_lcdfb.c linux-2.6.21.1/drivers/video/atmel_lcdfb.c
|
||||
--- linux-2.6.21.1-0rig/drivers/video/atmel_lcdfb.c 2007-05-12 13:28:34.000000000 +0200
|
||||
+++ linux-2.6.21.1/drivers/video/atmel_lcdfb.c 2007-05-12 19:41:45.000000000 +0200
|
||||
@@ -540,7 +540,7 @@
|
||||
info->fix = atmel_lcdfb_fix;
|
||||
|
||||
/* Enable LCDC Clocks */
|
||||
- if (cpu_is_at91sam9261() {
|
||||
+ if (cpu_is_at91sam9261()) {
|
||||
sinfo->bus_clk = clk_get(dev, "hck1");
|
||||
if (IS_ERR(sinfo->bus_clk)) {
|
||||
ret = PTR_ERR(sinfo->bus_clk);
|
||||
diff -urN linux-2.6.21.1-0rig/include/asm-arm/arch-at91/cpu.h linux-2.6.21.1/include/asm-arm/arch-at91/cpu.h
|
||||
--- linux-2.6.21.1-0rig/include/asm-arm/arch-at91/cpu.h 2007-05-12 13:28:34.000000000 +0200
|
||||
+++ linux-2.6.21.1/include/asm-arm/arch-at91/cpu.h 2007-05-12 13:27:28.000000000 +0200
|
||||
@@ -17,7 +17,7 @@
|
||||
#include <asm/arch/at91_dbgu.h>
|
||||
|
||||
|
||||
-#define ARCH_ID_AT91RM9200 0x09290780
|
||||
+#define ARCH_ID_AT91RM9200 0x09290780
|
||||
#define ARCH_ID_AT91SAM9260 0x019803a0
|
||||
#define ARCH_ID_AT91SAM9261 0x019703a0
|
||||
#define ARCH_ID_AT91SAM9263 0x019607a0
|
||||
@@ -76,4 +76,11 @@
|
||||
#define cpu_is_at91sam9rl() (0)
|
||||
#endif
|
||||
|
||||
+#define cpu_is_at32ap7000() (0)
|
||||
+#define cpu_is_at32ap7001() (0)
|
||||
+#define cpu_is_at32ap7002() (0)
|
||||
+#define cpu_is_at32ap7200() (0)
|
||||
+#define cpu_is_at32ap7010() (0)
|
||||
+#define cpu_is_at32ap7020() (0)
|
||||
+
|
||||
#endif
|
File diff suppressed because it is too large
Load Diff
@ -0,0 +1,130 @@
|
||||
>From 9c5fa914202d20756c56e0c4fd76035ed8f8ced8 Mon Sep 17 00:00:00 2001
|
||||
From: Hans-Christian Egtvedt <hcegtvedt@atmel.com>
|
||||
Date: Mon, 6 Aug 2007 08:31:14 +0200
|
||||
Subject: [PATCH 1/1] Add gpio_mouse board setup to atstk1000 board
|
||||
|
||||
This patch adds a gpio_mouse_platform_data to the atstk1000 board code and
|
||||
registers a gpio_mouse platform_device. This will enable a GPIO mouse on header
|
||||
J1 on GPIO of the ATSTK1000 development kit. The board code is enabled/disabled
|
||||
in menuconfig.
|
||||
|
||||
By connecting J1 (GPIO) to J25 (SWITCH) you can use the following keys to
|
||||
simulate a mouse:
|
||||
|
||||
SW0: right
|
||||
SW1: down
|
||||
SW2: up
|
||||
SW3: left
|
||||
SW5: right button
|
||||
SW6: middle button
|
||||
SW7: left button
|
||||
|
||||
Signed-off-by: Hans-Christian Egtvedt <hcegtvedt@atmel.com>
|
||||
---
|
||||
arch/avr32/boards/atstk1000/Kconfig | 16 ++++++++++
|
||||
arch/avr32/boards/atstk1000/atstk1002.c | 48 +++++++++++++++++++++++++++++++
|
||||
2 files changed, 64 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/arch/avr32/boards/atstk1000/Kconfig b/arch/avr32/boards/atstk1000/Kconfig
|
||||
index 718578f..d99d4bd 100644
|
||||
--- a/arch/avr32/boards/atstk1000/Kconfig
|
||||
+++ b/arch/avr32/boards/atstk1000/Kconfig
|
||||
@@ -50,6 +50,22 @@ config BOARD_ATSTK1002_SPI1
|
||||
GPIO lines and accessed through the J1 jumper block. Say "y"
|
||||
here to configure that SPI controller.
|
||||
|
||||
+config BOARD_ATSTK1002_GPIO_MOUSE
|
||||
+ bool "Configure gpio_mouse on GPIO J1 header"
|
||||
+ depends on !BOARD_ATSTK1002_SW4_CUSTOM
|
||||
+ help
|
||||
+ Enable gpio_mouse board configuration on GPIO 0 to 7. Connecting a
|
||||
+ 10-pin flat cable from J1 (GPIO) to J25 (SWITCH) will let a user give
|
||||
+ mouse inputs using the the switches SW0 to SW7.
|
||||
+
|
||||
+ SW0: right
|
||||
+ SW1: down
|
||||
+ SW2: up
|
||||
+ SW3: left
|
||||
+ SW5: right button
|
||||
+ SW6: middle button
|
||||
+ SW7: left button
|
||||
+
|
||||
config BOARD_ATSTK1002_J2_LED
|
||||
bool
|
||||
default BOARD_ATSTK1002_J2_LED8 || BOARD_ATSTK1002_J2_RGB
|
||||
diff --git a/arch/avr32/boards/atstk1000/atstk1002.c b/arch/avr32/boards/atstk1000/atstk1002.c
|
||||
index c958fd4..c7560e5 100644
|
||||
--- a/arch/avr32/boards/atstk1000/atstk1002.c
|
||||
+++ b/arch/avr32/boards/atstk1000/atstk1002.c
|
||||
@@ -17,6 +17,7 @@
|
||||
#include <linux/types.h>
|
||||
#include <linux/spi/spi.h>
|
||||
#include <linux/spi/at73c213.h>
|
||||
+#include <linux/gpio_mouse.h>
|
||||
|
||||
#include <video/atmel_lcdc.h>
|
||||
|
||||
@@ -91,6 +92,49 @@ static struct mci_platform_data __initdata mci0_data = {
|
||||
.wp_pin = GPIO_PIN_NONE,
|
||||
};
|
||||
|
||||
+#ifdef CONFIG_BOARD_ATSTK1002_GPIO_MOUSE
|
||||
+static struct gpio_mouse_platform_data gpio_mouse0_data = {
|
||||
+ .polarity = GPIO_MOUSE_POLARITY_ACT_LOW,
|
||||
+ {
|
||||
+ {
|
||||
+ .up = GPIO_PIN_PB(2),
|
||||
+ .down = GPIO_PIN_PB(1),
|
||||
+ .left = GPIO_PIN_PB(3),
|
||||
+ .right = GPIO_PIN_PB(0),
|
||||
+ .bleft = GPIO_PIN_PB(7),
|
||||
+ .bmiddle = GPIO_PIN_PB(6),
|
||||
+ .bright = GPIO_PIN_PB(5),
|
||||
+ },
|
||||
+ },
|
||||
+ .scan_ms = 10,
|
||||
+};
|
||||
+
|
||||
+static struct platform_device gpio_mouse0_device = {
|
||||
+ .name = "gpio_mouse",
|
||||
+ .id = 0,
|
||||
+ .dev = {
|
||||
+ .platform_data = &gpio_mouse0_data,
|
||||
+ },
|
||||
+};
|
||||
+
|
||||
+static void __init add_device_gpio_mouse0(void)
|
||||
+{
|
||||
+ struct platform_device *pdev = &gpio_mouse0_device;
|
||||
+ struct gpio_mouse_platform_data *data = pdev->dev.platform_data;
|
||||
+
|
||||
+ at32_select_gpio(data->up, 0);
|
||||
+ at32_select_gpio(data->down, 0);
|
||||
+ at32_select_gpio(data->left, 0);
|
||||
+ at32_select_gpio(data->right, 0);
|
||||
+
|
||||
+ at32_select_gpio(data->bleft, 0);
|
||||
+ at32_select_gpio(data->bmiddle, 0);
|
||||
+ at32_select_gpio(data->bright, 0);
|
||||
+
|
||||
+ platform_device_register(pdev);
|
||||
+}
|
||||
+#endif
|
||||
+
|
||||
/*
|
||||
* The next two functions should go away as the boot loader is
|
||||
* supposed to initialize the macb address registers with a valid
|
||||
@@ -317,6 +361,10 @@ static int __init atstk1002_init(void)
|
||||
#endif
|
||||
#endif
|
||||
|
||||
+#ifdef CONFIG_BOARD_ATSTK1002_GPIO_MOUSE
|
||||
+ add_device_gpio_mouse0();
|
||||
+#endif
|
||||
+
|
||||
return 0;
|
||||
}
|
||||
postcore_initcall(atstk1002_init);
|
||||
--
|
||||
1.5.2.3
|
||||
|
0
target/device/Atmel/linux/linux.mk
Normal file
0
target/device/Atmel/linux/linux.mk
Normal file
@ -63,6 +63,10 @@ ifeq ($(BR2_KERNEL_HEADERS_LZMA),y)
|
||||
toolchain/patch-kernel.sh $(LINUX_HEADERS_UNPACK_DIR) toolchain/kernel-headers/lzma \
|
||||
linux-$(LINUX_HEADERS_VERSION)-\*.patch{,.gz,.bz2}
|
||||
endif
|
||||
ifneq ($(LINUX26_HEADERS_PATCH_DIR),)
|
||||
toolchain/patch-kernel.sh $(LINUX_HEADERS_UNPACK_DIR) $(LINUX26_HEADERS_PATCH_DIR) \
|
||||
linux-$(LINUX_HEADERS_VERSION)-\*.patch{,.gz,.bz2}
|
||||
endif
|
||||
ifeq ($(BR2_PACKAGE_OPENSWAN),y)
|
||||
toolchain/patch-kernel.sh $(LINUX_HEADERS_UNPACK_DIR) package/openswan \
|
||||
linux-$(LINUX_HEADERS_VERSION)-\*.patch{,.gz,.bz2}
|
||||
|
Loading…
Reference in New Issue
Block a user