Merge branch 'squashfs-fixes' of git://git.busybox.net/~tpetazzoni/git/buildroot
This commit is contained in:
commit
af850ce10f
@ -18,7 +18,7 @@ define SQUASHFS_INSTALL_TARGET_CMDS
|
||||
endef
|
||||
|
||||
define HOST_SQUASHFS_BUILD_CMDS
|
||||
$(HOST_MAKE_ENV) $(MAKE) -C $(@D)/squashfs-tools/
|
||||
$(HOST_MAKE_ENV) $(MAKE) CFLAGS="$(HOST_CFLAGS)" LDFLAGS="$(HOST_LDFLAGS)" -C $(@D)/squashfs-tools/
|
||||
endef
|
||||
|
||||
define HOST_SQUASHFS_INSTALL_CMDS
|
||||
|
@ -9,9 +9,9 @@ Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
|
||||
|
||||
Index: squashfs3.4/squashfs-tools/Makefile
|
||||
===================================================================
|
||||
--- squashfs3.4.orig/squashfs-tools/Makefile
|
||||
+++ squashfs3.4/squashfs-tools/Makefile
|
||||
@@ -2,12 +2,12 @@ INSTALL_DIR = /usr/local/bin
|
||||
--- squashfs3.4.orig/squashfs-tools/Makefile 2008-08-26 09:10:13.000000000 +0200
|
||||
+++ squashfs3.4/squashfs-tools/Makefile 2010-05-06 21:09:28.000000000 +0200
|
||||
@@ -2,12 +2,12 @@
|
||||
|
||||
INCLUDEDIR = .
|
||||
|
||||
@ -26,3 +26,12 @@ Index: squashfs3.4/squashfs-tools/Makefile
|
||||
|
||||
mksquashfs.o: mksquashfs.c squashfs_fs.h mksquashfs.h global.h sort.h
|
||||
|
||||
@@ -16,7 +16,7 @@
|
||||
sort.o: sort.c squashfs_fs.h global.h sort.h
|
||||
|
||||
unsquashfs: unsquashfs.o
|
||||
- $(CC) unsquashfs.o -lz -lpthread -lm -o $@
|
||||
+ $(CC) $(LDFLAGS) unsquashfs.o -lz -lpthread -lm -o $@
|
||||
|
||||
unsquashfs.o: unsquashfs.c squashfs_fs.h read_fs.h global.h
|
||||
|
@ -18,7 +18,7 @@ define SQUASHFS3_INSTALL_TARGET_CMDS
|
||||
endef
|
||||
|
||||
define HOST_SQUASHFS3_BUILD_CMDS
|
||||
$(HOST_MAKE_ENV) $(MAKE) -C $(@D)/squashfs-tools/
|
||||
$(HOST_MAKE_ENV) $(MAKE) CFLAGS="$(HOST_CFLAGS)" LDFLAGS="$(HOST_LDFLAGS)" -C $(@D)/squashfs-tools/
|
||||
endef
|
||||
|
||||
define HOST_SQUASHFS3_INSTALL_CMDS
|
||||
|
Loading…
Reference in New Issue
Block a user