package/lightning: bump version to 2.2.0
Notable changes in this new version include support for the Apple Aarch64 ABI, and compare-and-swap atomic instructions. Signed-off-by: Paul Cercueil <paul@crapouillou.net> [Peter: drop _AUTORECONF] Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
7165965fe5
commit
af6f7aa76d
@ -1,38 +0,0 @@
|
||||
From 604c931bc673c507254a84c0f423c9ec8ce6e3a1 Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Thu, 10 Oct 2019 20:36:46 +0200
|
||||
Subject: [PATCH] include/Makefile.am: don't install lightning.h twice
|
||||
|
||||
Commit 17164ed32d8f3530153b9cad67a4399c65f24512 added lightning.h to
|
||||
nodist_include_HEADERS without removing it from include_HEADERS
|
||||
|
||||
This raises the following error on one of the buildroot autobuilders:
|
||||
/usr/bin/install -c -m 644 lightning.h '/home/test/autobuild/run/instance-3/output-1/target/usr/include'
|
||||
/usr/bin/install -c -m 644 lightning.h '/home/test/autobuild/run/instance-3/output-1/target/usr/include'
|
||||
/usr/bin/install: cannot create regular file `/home/test/autobuild/run/instance-3/output-1/target/usr/include/lightning.h': File exists
|
||||
|
||||
Fix this by removing lightning.h from include_HEADERS
|
||||
|
||||
Fixes:
|
||||
- http://autobuild.buildroot.org/results/05ebc75598627d2a08e08e194f51cb8464f97b95
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
include/Makefile.am | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/include/Makefile.am b/include/Makefile.am
|
||||
index e754dd3..8f91594 100644
|
||||
--- a/include/Makefile.am
|
||||
+++ b/include/Makefile.am
|
||||
@@ -14,7 +14,6 @@
|
||||
# License for more details.
|
||||
#
|
||||
|
||||
-include_HEADERS = lightning.h
|
||||
SUBDIRS = \
|
||||
lightning
|
||||
|
||||
--
|
||||
2.23.0
|
||||
|
@ -1,3 +1,3 @@
|
||||
# Locally computed
|
||||
sha256 ed856b866dc6f68678dc1151579118fab1c65fad687cf847fc2d94ca045efdc9 lightning-2.1.3.tar.gz
|
||||
sha256 4e3984ff1ccf0ba30a985211d40fc5c06b25f014ebdf3d80d0fe3d0c80dd7c0e lightning-2.2.0.tar.gz
|
||||
sha256 a853c2ffec17057872340eee242ae4d96cbf2b520ae27d903e1b2fef1a5f9d1c COPYING.LESSER
|
||||
|
@ -4,14 +4,12 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LIGHTNING_VERSION = 2.1.3
|
||||
LIGHTNING_VERSION = 2.2.0
|
||||
LIGHTNING_SITE = $(BR2_GNU_MIRROR)/lightning
|
||||
LIGHTNING_LICENSE = LGPL-3.0+
|
||||
LIGHTNING_LICENSE_FILES = COPYING.LESSER
|
||||
LIGHTNING_INSTALL_STAGING = YES
|
||||
LIGHTNING_CPE_ID_VENDOR = gnu
|
||||
# We're patching include/Makefile.am
|
||||
LIGHTNING_AUTORECONF = YES
|
||||
|
||||
ifeq ($(BR2_PACKAGE_LIGHTNING_DISASSEMBLER),y)
|
||||
LIGHTNING_DEPENDENCIES += binutils zlib
|
||||
|
Loading…
Reference in New Issue
Block a user