diff --git a/package/stellarium/0001-Fixed-building-Stellarium-without-scripting.patch b/package/stellarium/0001-Fixed-building-Stellarium-without-scripting.patch
new file mode 100644
index 0000000000..57f15a8eff
--- /dev/null
+++ b/package/stellarium/0001-Fixed-building-Stellarium-without-scripting.patch
@@ -0,0 +1,49 @@
+From 710d1c5acd9e962260ce395474819ded2eb6ce12 Mon Sep 17 00:00:00 2001
+From: "Alexander V. Wolf" <alex.v.wolf@gmail.com>
+Date: Tue, 29 Mar 2022 18:57:06 +0700
+Subject: [PATCH] Fixed building Stellarium without scripting
+
+Downloaded from upstream commit:
+https://github.com/Stellarium/stellarium/commit/710d1c5acd9e962260ce395474819ded2eb6ce12
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+---
+ plugins/Calendars/src/Calendars.cpp | 2 ++
+ plugins/Calendars/src/Calendars.hpp | 2 ++
+ 2 files changed, 4 insertions(+)
+
+diff --git a/plugins/Calendars/src/Calendars.cpp b/plugins/Calendars/src/Calendars.cpp
+index e5d89a4c063..4df6caee42e 100644
+--- a/plugins/Calendars/src/Calendars.cpp
++++ b/plugins/Calendars/src/Calendars.cpp
+@@ -251,6 +251,7 @@ void Calendars::init()
+ 	}
+ }
+ 
++#ifdef ENABLE_SCRIPTING
+ // Add calendar as scriptable object! Some scripting functions won't work though, as they use object types unknown to the scripting engine.
+ void Calendars::makeCalendarsScriptable(StelScriptMgr *ssm)
+ {
+@@ -260,6 +261,7 @@ void Calendars::makeCalendarsScriptable(StelScriptMgr *ssm)
+ 		ssm->addObject(cal);
+ 	}
+ }
++#endif
+ 
+ void Calendars::loadSettings()
+ {
+diff --git a/plugins/Calendars/src/Calendars.hpp b/plugins/Calendars/src/Calendars.hpp
+index 461ae1bd9ba..4696183d9d2 100644
+--- a/plugins/Calendars/src/Calendars.hpp
++++ b/plugins/Calendars/src/Calendars.hpp
+@@ -145,8 +145,10 @@ class Calendars : public StelModule
+ 	//! TODO: ADD HERE: Chinese, NewHinduSolar, NewHinduLunar, ...
+ 	Calendar* getCal(QString name);
+ 
++	#ifdef ENABLE_SCRIPTING
+ 	//! to be called after program startup, when StelScriptMgr has been set up.
+ 	void makeCalendarsScriptable(StelScriptMgr *ssm);
++	#endif
+ 
+ signals:
+ 	//void jdChanged(double jd);
diff --git a/package/stellarium/Config.in b/package/stellarium/Config.in
index 5922162d44..566f8edc83 100644
--- a/package/stellarium/Config.in
+++ b/package/stellarium/Config.in
@@ -9,6 +9,7 @@ config BR2_PACKAGE_STELLARIUM
 	select BR2_PACKAGE_QT5BASE_OPENGL
 	select BR2_PACKAGE_QT5BASE_PRINTSUPPORT
 	select BR2_PACKAGE_QT5BASE_WIDGETS
+	select BR2_PACKAGE_QT5CHARTS
 	select BR2_PACKAGE_QT5LOCATION
 	select BR2_PACKAGE_QT5MULTIMEDIA
 	select BR2_PACKAGE_ZLIB
diff --git a/package/stellarium/stellarium.hash b/package/stellarium/stellarium.hash
index c3f2e0e8d4..2c2427bf0e 100644
--- a/package/stellarium/stellarium.hash
+++ b/package/stellarium/stellarium.hash
@@ -1,5 +1,5 @@
 # From https://github.com/Stellarium/stellarium/releases
-sha1  a3396c403050e073c592da695faeb048c1d5e19b  stellarium-0.21.3.tar.gz
-sha256  8ac6c054d12f136fe0d5c0deaaa8d7b69dd2a462be1711a187364574aef97e7f  stellarium-0.21.3.tar.gz
+sha1  c4a00fd756c66fb7df633f496dd3be4300bf1d2b  stellarium-0.22.0.tar.gz
+sha256  0b4dc23cf9054b5e76cd9bc5ad68e172eb221999e90af37e93667d04fe78c885  stellarium-0.22.0.tar.gz
 # Locally computed
 sha256  3aeeb5bb98bf7041ab82cffe15efa28ac58ee2bdf162b71301f5c192be631259  COPYING
diff --git a/package/stellarium/stellarium.mk b/package/stellarium/stellarium.mk
index ca5c07b2a7..1226b1190d 100644
--- a/package/stellarium/stellarium.mk
+++ b/package/stellarium/stellarium.mk
@@ -4,18 +4,20 @@
 #
 ################################################################################
 
-STELLARIUM_VERSION = 0.21.3
+STELLARIUM_VERSION = 0.22.0
 STELLARIUM_SITE = https://github.com/Stellarium/stellarium/releases/download/v$(STELLARIUM_VERSION)
 STELLARIUM_LICENSE = GPL-2.0+
 STELLARIUM_LICENSE_FILES = COPYING
 STELLARIUM_DEPENDENCIES = \
 	qt5base \
+	qt5charts \
 	qt5location \
 	qt5multimedia \
 	zlib
 STELLARIUM_CONF_OPTS = \
 	-DENABLE_MEDIA=ON \
 	-DENABLE_NLS=OFF \
+	-DENABLE_QTWEBENGINE=OFF \
 	-DUSE_SYSTEM_ZLIB=ON
 
 ifeq ($(BR2_PACKAGE_QT5SCRIPT),y)