package/binutils: add support for 2.42
Note that the hash of the tarball does not need to be added, as it was
already added as part of commit 11b439ce1b
("package/binutils-bare-metal: new package").
Our existing 2 patches are simply rebased, with minor conflict
resolution required.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
[yann.morin.1998@free.fr: keep version list in strict version order]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
parent
f7f03445cf
commit
ae910aac62
50
package/binutils/2.42/0001-sh-conf.patch
Normal file
50
package/binutils/2.42/0001-sh-conf.patch
Normal file
@ -0,0 +1,50 @@
|
|||||||
|
From d71fb5a9999ee7c8963342caa0d5cbb16872ab07 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Romain Naour <romain.naour@gmail.com>
|
||||||
|
Date: Fri, 25 Dec 2015 11:38:13 +0100
|
||||||
|
Subject: [PATCH] sh-conf
|
||||||
|
|
||||||
|
Likewise, binutils has no idea about any of these new targets either, so we
|
||||||
|
fix that up too.. now we're able to actually build a real toolchain for
|
||||||
|
sh2a_nofpu- and other more ineptly named toolchains (and yes, there are more
|
||||||
|
inept targets than that one, really. Go look, I promise).
|
||||||
|
|
||||||
|
Upstream: N/A [Buildroot specific]
|
||||||
|
|
||||||
|
[Romain: rebase on top of 2.32]
|
||||||
|
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
||||||
|
[Thomas: rebase on top of 2.29, in which sh64 support was removed.]
|
||||||
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||||
|
---
|
||||||
|
configure | 2 +-
|
||||||
|
configure.ac | 2 +-
|
||||||
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure b/configure
|
||||||
|
index 670684d83d1..967c6708a0c 100755
|
||||||
|
--- a/configure
|
||||||
|
+++ b/configure
|
||||||
|
@@ -4042,7 +4042,7 @@ case "${target}" in
|
||||||
|
nvptx*-*-*)
|
||||||
|
noconfigdirs="$noconfigdirs target-libssp target-libstdc++-v3 target-libobjc"
|
||||||
|
;;
|
||||||
|
- sh-*-*)
|
||||||
|
+ sh*-*-*)
|
||||||
|
case "${target}" in
|
||||||
|
sh*-*-elf)
|
||||||
|
;;
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 88b4800e298..2c8d08ff6ec 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -1269,7 +1269,7 @@ case "${target}" in
|
||||||
|
nvptx*-*-*)
|
||||||
|
noconfigdirs="$noconfigdirs target-libssp target-libstdc++-v3 target-libobjc"
|
||||||
|
;;
|
||||||
|
- sh-*-*)
|
||||||
|
+ sh*-*-*)
|
||||||
|
case "${target}" in
|
||||||
|
sh*-*-elf)
|
||||||
|
;;
|
||||||
|
--
|
||||||
|
2.43.0
|
||||||
|
|
309
package/binutils/2.42/0002-poison-system-directories.patch
Normal file
309
package/binutils/2.42/0002-poison-system-directories.patch
Normal file
@ -0,0 +1,309 @@
|
|||||||
|
From 00f6b0a7d31085831429834b2bc8f511b8fab6ce Mon Sep 17 00:00:00 2001
|
||||||
|
From: Romain Naour <romain.naour@gmail.com>
|
||||||
|
Date: Fri, 25 Dec 2015 11:45:38 +0100
|
||||||
|
Subject: [PATCH] poison-system-directories
|
||||||
|
|
||||||
|
Patch adapted to binutils 2.23.2 and extended to use
|
||||||
|
BR_COMPILER_PARANOID_UNSAFE_PATH by Thomas Petazzoni.
|
||||||
|
|
||||||
|
[Waldemar: rebase on top of 2.39]
|
||||||
|
Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
|
||||||
|
[Romain: rebase on top of 2.33.1]
|
||||||
|
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
||||||
|
[Gustavo: adapt to binutils 2.25]
|
||||||
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||||
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||||
|
|
||||||
|
Upstream-Status: Inappropriate [distribution: codesourcery]
|
||||||
|
Upstream: N/A [Buildroot specific]
|
||||||
|
|
||||||
|
Patch originally created by Mark Hatle, forward-ported to
|
||||||
|
binutils 2.21 by Scott Garman.
|
||||||
|
|
||||||
|
purpose: warn for uses of system directories when cross linking
|
||||||
|
|
||||||
|
Code Merged from Sourcery G++ binutils 2.19 - 4.4-277
|
||||||
|
|
||||||
|
2008-07-02 Joseph Myers <joseph@codesourcery.com>
|
||||||
|
|
||||||
|
ld/
|
||||||
|
* ld.h (args_type): Add error_poison_system_directories.
|
||||||
|
* ld.texinfo (--error-poison-system-directories): Document.
|
||||||
|
* ldfile.c (ldfile_add_library_path): Check
|
||||||
|
command_line.error_poison_system_directories.
|
||||||
|
* ldmain.c (main): Initialize
|
||||||
|
command_line.error_poison_system_directories.
|
||||||
|
* lexsup.c (enum option_values): Add
|
||||||
|
OPTION_ERROR_POISON_SYSTEM_DIRECTORIES.
|
||||||
|
(ld_options): Add --error-poison-system-directories.
|
||||||
|
(parse_args): Handle new option.
|
||||||
|
|
||||||
|
2007-06-13 Joseph Myers <joseph@codesourcery.com>
|
||||||
|
|
||||||
|
ld/
|
||||||
|
* config.in: Regenerate.
|
||||||
|
* ld.h (args_type): Add poison_system_directories.
|
||||||
|
* ld.texinfo (--no-poison-system-directories): Document.
|
||||||
|
* ldfile.c (ldfile_add_library_path): Check
|
||||||
|
command_line.poison_system_directories.
|
||||||
|
* ldmain.c (main): Initialize
|
||||||
|
command_line.poison_system_directories.
|
||||||
|
* lexsup.c (enum option_values): Add
|
||||||
|
OPTION_NO_POISON_SYSTEM_DIRECTORIES.
|
||||||
|
(ld_options): Add --no-poison-system-directories.
|
||||||
|
(parse_args): Handle new option.
|
||||||
|
|
||||||
|
2007-04-20 Joseph Myers <joseph@codesourcery.com>
|
||||||
|
|
||||||
|
Merge from Sourcery G++ binutils 2.17:
|
||||||
|
|
||||||
|
2007-03-20 Joseph Myers <joseph@codesourcery.com>
|
||||||
|
Based on patch by Mark Hatle <mark.hatle@windriver.com>.
|
||||||
|
ld/
|
||||||
|
* configure.ac (--enable-poison-system-directories): New option.
|
||||||
|
* configure, config.in: Regenerate.
|
||||||
|
* ldfile.c (ldfile_add_library_path): If
|
||||||
|
ENABLE_POISON_SYSTEM_DIRECTORIES defined, warn for use of /lib,
|
||||||
|
/usr/lib, /usr/local/lib or /usr/X11R6/lib.
|
||||||
|
|
||||||
|
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
|
||||||
|
Signed-off-by: Scott Garman <scott.a.garman@intel.com>
|
||||||
|
---
|
||||||
|
ld/config.in | 3 +++
|
||||||
|
ld/configure | 14 ++++++++++++++
|
||||||
|
ld/configure.ac | 10 ++++++++++
|
||||||
|
ld/ld.h | 8 ++++++++
|
||||||
|
ld/ld.texi | 12 ++++++++++++
|
||||||
|
ld/ldfile.c | 17 +++++++++++++++++
|
||||||
|
ld/ldlex.h | 2 ++
|
||||||
|
ld/ldmain.c | 2 ++
|
||||||
|
ld/lexsup.c | 21 +++++++++++++++++++++
|
||||||
|
9 files changed, 89 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/ld/config.in b/ld/config.in
|
||||||
|
index 52d62f06ff0..b5944e7ba55 100644
|
||||||
|
--- a/ld/config.in
|
||||||
|
+++ b/ld/config.in
|
||||||
|
@@ -70,6 +70,9 @@
|
||||||
|
language is requested. */
|
||||||
|
#undef ENABLE_NLS
|
||||||
|
|
||||||
|
+/* Define to warn for use of native system library directories */
|
||||||
|
+#undef ENABLE_POISON_SYSTEM_DIRECTORIES
|
||||||
|
+
|
||||||
|
/* Additional extension a shared object might have. */
|
||||||
|
#undef EXTRA_SHLIB_EXTENSION
|
||||||
|
|
||||||
|
diff --git a/ld/configure b/ld/configure
|
||||||
|
index ba1e5e2a215..2220d7afe2a 100755
|
||||||
|
--- a/ld/configure
|
||||||
|
+++ b/ld/configure
|
||||||
|
@@ -844,6 +844,7 @@ with_lib_path
|
||||||
|
enable_targets
|
||||||
|
enable_64_bit_bfd
|
||||||
|
with_sysroot
|
||||||
|
+enable_poison_system_directories
|
||||||
|
enable_gold
|
||||||
|
enable_got
|
||||||
|
enable_compressed_debug_sections
|
||||||
|
@@ -1534,6 +1535,8 @@ Optional Features:
|
||||||
|
--enable-checking enable run-time checks
|
||||||
|
--enable-targets alternative target configurations
|
||||||
|
--enable-64-bit-bfd 64-bit support (on hosts with narrower word sizes)
|
||||||
|
+ --enable-poison-system-directories
|
||||||
|
+ warn for use of native system library directories
|
||||||
|
--enable-gold[=ARG] build gold [ARG={default,yes,no}]
|
||||||
|
--enable-got=<type> GOT handling scheme (target, single, negative,
|
||||||
|
multigot)
|
||||||
|
@@ -15587,7 +15590,18 @@ else
|
||||||
|
fi
|
||||||
|
|
||||||
|
|
||||||
|
+# Check whether --enable-poison-system-directories was given.
|
||||||
|
+if test "${enable_poison_system_directories+set}" = set; then :
|
||||||
|
+ enableval=$enable_poison_system_directories;
|
||||||
|
+else
|
||||||
|
+ enable_poison_system_directories=no
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+if test "x${enable_poison_system_directories}" = "xyes"; then
|
||||||
|
|
||||||
|
+$as_echo "#define ENABLE_POISON_SYSTEM_DIRECTORIES 1" >>confdefs.h
|
||||||
|
+
|
||||||
|
+fi
|
||||||
|
|
||||||
|
# Check whether --enable-got was given.
|
||||||
|
if test "${enable_got+set}" = set; then :
|
||||||
|
diff --git a/ld/configure.ac b/ld/configure.ac
|
||||||
|
index 4a11787ae71..104a531fb0f 100644
|
||||||
|
--- a/ld/configure.ac
|
||||||
|
+++ b/ld/configure.ac
|
||||||
|
@@ -103,6 +103,16 @@ AC_SUBST(use_sysroot)
|
||||||
|
AC_SUBST(TARGET_SYSTEM_ROOT)
|
||||||
|
AC_SUBST(TARGET_SYSTEM_ROOT_DEFINE)
|
||||||
|
|
||||||
|
+AC_ARG_ENABLE([poison-system-directories],
|
||||||
|
+ AS_HELP_STRING([--enable-poison-system-directories],
|
||||||
|
+ [warn for use of native system library directories]),,
|
||||||
|
+ [enable_poison_system_directories=no])
|
||||||
|
+if test "x${enable_poison_system_directories}" = "xyes"; then
|
||||||
|
+ AC_DEFINE([ENABLE_POISON_SYSTEM_DIRECTORIES],
|
||||||
|
+ [1],
|
||||||
|
+ [Define to warn for use of native system library directories])
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
dnl Use --enable-gold to decide if this linker should be the default.
|
||||||
|
dnl "install_as_default" is set to false if gold is the default linker.
|
||||||
|
dnl "installed_linker" is the installed BFD linker name.
|
||||||
|
diff --git a/ld/ld.h b/ld/ld.h
|
||||||
|
index 54d9079678c..9f0163b2911 100644
|
||||||
|
--- a/ld/ld.h
|
||||||
|
+++ b/ld/ld.h
|
||||||
|
@@ -166,6 +166,14 @@ typedef struct
|
||||||
|
in the linker script. */
|
||||||
|
bool force_group_allocation;
|
||||||
|
|
||||||
|
+ /* If TRUE (the default) warn for uses of system directories when
|
||||||
|
+ cross linking. */
|
||||||
|
+ bool poison_system_directories;
|
||||||
|
+
|
||||||
|
+ /* If TRUE (default FALSE) give an error for uses of system
|
||||||
|
+ directories when cross linking instead of a warning. */
|
||||||
|
+ bool error_poison_system_directories;
|
||||||
|
+
|
||||||
|
/* Big or little endian as set on command line. */
|
||||||
|
enum endian_enum endian;
|
||||||
|
|
||||||
|
diff --git a/ld/ld.texi b/ld/ld.texi
|
||||||
|
index 4fda259a552..11fd8f7547b 100644
|
||||||
|
--- a/ld/ld.texi
|
||||||
|
+++ b/ld/ld.texi
|
||||||
|
@@ -3108,6 +3108,18 @@ string identifying the original linked file does not change.
|
||||||
|
Passing @code{none} for @var{style} disables the setting from any
|
||||||
|
@code{--build-id} options earlier on the command line.
|
||||||
|
|
||||||
|
+@kindex --no-poison-system-directories
|
||||||
|
+@item --no-poison-system-directories
|
||||||
|
+Do not warn for @option{-L} options using system directories such as
|
||||||
|
+@file{/usr/lib} when cross linking. This option is intended for use
|
||||||
|
+in chroot environments when such directories contain the correct
|
||||||
|
+libraries for the target system rather than the host.
|
||||||
|
+
|
||||||
|
+@kindex --error-poison-system-directories
|
||||||
|
+@item --error-poison-system-directories
|
||||||
|
+Give an error instead of a warning for @option{-L} options using
|
||||||
|
+system directories when cross linking.
|
||||||
|
+
|
||||||
|
@kindex --package-metadata=@var{JSON}
|
||||||
|
@item --package-metadata=@var{JSON}
|
||||||
|
Request the creation of a @code{.note.package} ELF note section. The
|
||||||
|
diff --git a/ld/ldfile.c b/ld/ldfile.c
|
||||||
|
index dc9875d8813..49d899ee49d 100644
|
||||||
|
--- a/ld/ldfile.c
|
||||||
|
+++ b/ld/ldfile.c
|
||||||
|
@@ -327,6 +327,23 @@ ldfile_add_library_path (const char *name, bool cmdline)
|
||||||
|
new_dirs->name = concat (ld_sysroot, name + strlen ("$SYSROOT"), (const char *) NULL);
|
||||||
|
else
|
||||||
|
new_dirs->name = xstrdup (name);
|
||||||
|
+
|
||||||
|
+#ifdef ENABLE_POISON_SYSTEM_DIRECTORIES
|
||||||
|
+ if (command_line.poison_system_directories
|
||||||
|
+ && ((!strncmp (name, "/lib", 4))
|
||||||
|
+ || (!strncmp (name, "/usr/lib", 8))
|
||||||
|
+ || (!strncmp (name, "/usr/local/lib", 14))
|
||||||
|
+ || (!strncmp (name, "/usr/X11R6/lib", 14))))
|
||||||
|
+ {
|
||||||
|
+ if (command_line.error_poison_system_directories)
|
||||||
|
+ einfo (_("%X%P: error: library search path \"%s\" is unsafe for "
|
||||||
|
+ "cross-compilation\n"), name);
|
||||||
|
+ else
|
||||||
|
+ einfo (_("%P: warning: library search path \"%s\" is unsafe for "
|
||||||
|
+ "cross-compilation\n"), name);
|
||||||
|
+ }
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
}
|
||||||
|
|
||||||
|
/* Try to open a BFD for a lang_input_statement. */
|
||||||
|
diff --git a/ld/ldlex.h b/ld/ldlex.h
|
||||||
|
index 161a9d4d8dc..4ca50b9c299 100644
|
||||||
|
--- a/ld/ldlex.h
|
||||||
|
+++ b/ld/ldlex.h
|
||||||
|
@@ -168,6 +168,8 @@ enum option_values
|
||||||
|
OPTION_CTF_VARIABLES,
|
||||||
|
OPTION_NO_CTF_VARIABLES,
|
||||||
|
OPTION_CTF_SHARE_TYPES,
|
||||||
|
+ OPTION_NO_POISON_SYSTEM_DIRECTORIES,
|
||||||
|
+ OPTION_ERROR_POISON_SYSTEM_DIRECTORIES,
|
||||||
|
OPTION_ERROR_EXECSTACK,
|
||||||
|
OPTION_NO_ERROR_EXECSTACK,
|
||||||
|
OPTION_WARN_EXECSTACK_OBJECTS,
|
||||||
|
diff --git a/ld/ldmain.c b/ld/ldmain.c
|
||||||
|
index e90c2021b33..43fe888eba8 100644
|
||||||
|
--- a/ld/ldmain.c
|
||||||
|
+++ b/ld/ldmain.c
|
||||||
|
@@ -325,6 +325,8 @@ main (int argc, char **argv)
|
||||||
|
command_line.warn_mismatch = true;
|
||||||
|
command_line.warn_search_mismatch = true;
|
||||||
|
command_line.check_section_addresses = -1;
|
||||||
|
+ command_line.poison_system_directories = true;
|
||||||
|
+ command_line.error_poison_system_directories = false;
|
||||||
|
|
||||||
|
/* We initialize DEMANGLING based on the environment variable
|
||||||
|
COLLECT_NO_DEMANGLE. The gcc collect2 program will demangle the
|
||||||
|
diff --git a/ld/lexsup.c b/ld/lexsup.c
|
||||||
|
index 099dff8ecde..01626712c77 100644
|
||||||
|
--- a/ld/lexsup.c
|
||||||
|
+++ b/ld/lexsup.c
|
||||||
|
@@ -642,6 +642,14 @@ static const struct ld_option ld_options[] =
|
||||||
|
" <method> is: share-unconflicted (default),\n"
|
||||||
|
" share-duplicated"),
|
||||||
|
TWO_DASHES },
|
||||||
|
+ { {"no-poison-system-directories", no_argument, NULL,
|
||||||
|
+ OPTION_NO_POISON_SYSTEM_DIRECTORIES},
|
||||||
|
+ '\0', NULL, N_("Do not warn for -L options using system directories"),
|
||||||
|
+ TWO_DASHES },
|
||||||
|
+ { {"error-poison-system-directories", no_argument, NULL,
|
||||||
|
+ OPTION_ERROR_POISON_SYSTEM_DIRECTORIES},
|
||||||
|
+ '\0', NULL, N_("Give an error for -L options using system directories"),
|
||||||
|
+ TWO_DASHES },
|
||||||
|
};
|
||||||
|
|
||||||
|
#define OPTION_COUNT ARRAY_SIZE (ld_options)
|
||||||
|
@@ -654,6 +662,7 @@ parse_args (unsigned argc, char **argv)
|
||||||
|
int ingroup = 0;
|
||||||
|
char *default_dirlist = NULL;
|
||||||
|
char *shortopts;
|
||||||
|
+ char *BR_paranoid_env;
|
||||||
|
struct option *longopts;
|
||||||
|
struct option *really_longopts;
|
||||||
|
int last_optind;
|
||||||
|
@@ -1769,6 +1778,14 @@ parse_args (unsigned argc, char **argv)
|
||||||
|
}
|
||||||
|
break;
|
||||||
|
|
||||||
|
+ case OPTION_NO_POISON_SYSTEM_DIRECTORIES:
|
||||||
|
+ command_line.poison_system_directories = false;
|
||||||
|
+ break;
|
||||||
|
+
|
||||||
|
+ case OPTION_ERROR_POISON_SYSTEM_DIRECTORIES:
|
||||||
|
+ command_line.error_poison_system_directories = true;
|
||||||
|
+ break;
|
||||||
|
+
|
||||||
|
case OPTION_PUSH_STATE:
|
||||||
|
input_flags.pushed = xmemdup (&input_flags,
|
||||||
|
sizeof (input_flags),
|
||||||
|
@@ -1922,6 +1939,10 @@ parse_args (unsigned argc, char **argv)
|
||||||
|
command_line.soname = NULL;
|
||||||
|
}
|
||||||
|
|
||||||
|
+ BR_paranoid_env = getenv("BR_COMPILER_PARANOID_UNSAFE_PATH");
|
||||||
|
+ if (BR_paranoid_env && strlen(BR_paranoid_env) > 0)
|
||||||
|
+ command_line.error_poison_system_directories = true;
|
||||||
|
+
|
||||||
|
while (ingroup)
|
||||||
|
{
|
||||||
|
einfo (_("%P: missing --end-group; added as last command line option\n"));
|
||||||
|
--
|
||||||
|
2.43.0
|
||||||
|
|
@ -29,6 +29,9 @@ config BR2_BINUTILS_VERSION_ARC
|
|||||||
bool "binutils arc (2.41)"
|
bool "binutils arc (2.41)"
|
||||||
depends on BR2_arc
|
depends on BR2_arc
|
||||||
|
|
||||||
|
config BR2_BINUTILS_VERSION_2_42_X
|
||||||
|
bool "binutils 2.42"
|
||||||
|
|
||||||
endchoice
|
endchoice
|
||||||
|
|
||||||
config BR2_BINUTILS_VERSION
|
config BR2_BINUTILS_VERSION
|
||||||
@ -37,6 +40,7 @@ config BR2_BINUTILS_VERSION
|
|||||||
default "2.39" if BR2_BINUTILS_VERSION_2_39_X
|
default "2.39" if BR2_BINUTILS_VERSION_2_39_X
|
||||||
default "2.40" if BR2_BINUTILS_VERSION_2_40_X
|
default "2.40" if BR2_BINUTILS_VERSION_2_40_X
|
||||||
default "2.41" if BR2_BINUTILS_VERSION_2_41_X
|
default "2.41" if BR2_BINUTILS_VERSION_2_41_X
|
||||||
|
default "2.42" if BR2_BINUTILS_VERSION_2_42_X
|
||||||
|
|
||||||
config BR2_BINUTILS_GPROFNG
|
config BR2_BINUTILS_GPROFNG
|
||||||
bool "gprofng support"
|
bool "gprofng support"
|
||||||
|
Loading…
Reference in New Issue
Block a user