package/gdb: add support for GDB 13.2
Sadly, the stack of patches remain exactly the same, none of the changes have been upstreamed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
7dd27cbe5b
commit
ae0b6f4383
@ -522,6 +522,15 @@ package/gdb/12.1/0006-Fix-getrandom-compile-for-uclibc-v1.0.35.patch Upstream
|
|||||||
package/gdb/12.1/0007-fix-musl-build-on-riscv.patch Upstream
|
package/gdb/12.1/0007-fix-musl-build-on-riscv.patch Upstream
|
||||||
package/gdb/12.1/0008-gdbserver-Makefile.in-fix-NLS-build.patch Upstream
|
package/gdb/12.1/0008-gdbserver-Makefile.in-fix-NLS-build.patch Upstream
|
||||||
package/gdb/12.1/0009-gdb-Fix-native-build-on-xtensa.patch Upstream
|
package/gdb/12.1/0009-gdb-Fix-native-build-on-xtensa.patch Upstream
|
||||||
|
package/gdb/13.2/0001-ppc-ptrace-Define-pt_regs-uapi_pt_regs-on-GLIBC-syst.patch Upstream
|
||||||
|
package/gdb/13.2/0002-sh-ptrace-Define-pt_-dsp-regs-uapi_pt_-dsp-regs-on-G.patch Upstream
|
||||||
|
package/gdb/13.2/0003-use-asm-sgidefs.h.patch Upstream
|
||||||
|
package/gdb/13.2/0004-gdbserver-fix-build-for-m68k.patch Upstream
|
||||||
|
package/gdb/13.2/0005-nat-fork-inferior-include-linux-ptrace.h.patch Upstream
|
||||||
|
package/gdb/13.2/0006-Fix-getrandom-compile-for-uclibc-v1.0.35.patch Upstream
|
||||||
|
package/gdb/13.2/0007-fix-musl-build-on-riscv.patch Upstream
|
||||||
|
package/gdb/13.2/0008-gdbserver-Makefile.in-fix-NLS-build.patch Upstream
|
||||||
|
package/gdb/13.2/0009-gdb-Fix-native-build-on-xtensa.patch Upstream
|
||||||
package/gengetopt/0001-configure.ac-add-disable-doc-option.patch Upstream
|
package/gengetopt/0001-configure.ac-add-disable-doc-option.patch Upstream
|
||||||
package/genpart/0001-fix-return-code.patch Upstream
|
package/genpart/0001-fix-return-code.patch Upstream
|
||||||
package/genromfs/0001-build-system.patch Sob Upstream
|
package/genromfs/0001-build-system.patch Sob Upstream
|
||||||
|
@ -0,0 +1,55 @@
|
|||||||
|
From 2edb66509607289ea7462db99e247de1200454c1 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Khem Raj <raj.khem@gmail.com>
|
||||||
|
Date: Sat, 6 Aug 2016 17:32:50 -0700
|
||||||
|
Subject: [PATCH] ppc/ptrace: Define pt_regs uapi_pt_regs on !GLIBC systems
|
||||||
|
|
||||||
|
Upstream-Status: Pending
|
||||||
|
|
||||||
|
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||||
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||||
|
[Rebase on gdb 8.3]
|
||||||
|
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
||||||
|
---
|
||||||
|
gdb/nat/ppc-linux.h | 6 ++++++
|
||||||
|
gdbserver/linux-ppc-low.cc | 6 ++++++
|
||||||
|
2 files changed, 12 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/gdb/nat/ppc-linux.h b/gdb/nat/ppc-linux.h
|
||||||
|
index c84f9146bbd..8c8580c95e1 100644
|
||||||
|
--- a/gdb/nat/ppc-linux.h
|
||||||
|
+++ b/gdb/nat/ppc-linux.h
|
||||||
|
@@ -18,7 +18,13 @@
|
||||||
|
#ifndef NAT_PPC_LINUX_H
|
||||||
|
#define NAT_PPC_LINUX_H
|
||||||
|
|
||||||
|
+#if !defined(__GLIBC__)
|
||||||
|
+# define pt_regs uapi_pt_regs
|
||||||
|
+#endif
|
||||||
|
#include <asm/ptrace.h>
|
||||||
|
+#if !defined(__GLIBC__)
|
||||||
|
+# undef pt_regs
|
||||||
|
+#endif
|
||||||
|
#include <asm/cputable.h>
|
||||||
|
|
||||||
|
/* This sometimes isn't defined. */
|
||||||
|
diff --git a/gdbserver/linux-ppc-low.cc b/gdbserver/linux-ppc-low.cc
|
||||||
|
index fdf74727e39..f64afd09b7a 100644
|
||||||
|
--- a/gdbserver/linux-ppc-low.cc
|
||||||
|
+++ b/gdbserver/linux-ppc-low.cc
|
||||||
|
@@ -23,7 +23,13 @@
|
||||||
|
#include "elf/common.h"
|
||||||
|
#include <sys/uio.h>
|
||||||
|
#include <elf.h>
|
||||||
|
+#if !defined(__GLIBC__)
|
||||||
|
+# define pt_regs uapi_pt_regs
|
||||||
|
+#endif
|
||||||
|
#include <asm/ptrace.h>
|
||||||
|
+#if !defined(__GLIBC__)
|
||||||
|
+# undef pt_regs
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
#include "arch/ppc-linux-common.h"
|
||||||
|
#include "arch/ppc-linux-tdesc.h"
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
@ -0,0 +1,43 @@
|
|||||||
|
From 2dd3ed43936f26d2929d0e42b200f29e128d4f0d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||||
|
Date: Sat, 3 Jun 2017 21:23:52 +0200
|
||||||
|
Subject: [PATCH] sh/ptrace: Define pt_{dsp,}regs uapi_pt_{dsp,}regs on !GLIBC
|
||||||
|
systems
|
||||||
|
|
||||||
|
Fixes a pt_{dsp,}regs redefinition when building with the musl C library
|
||||||
|
on SuperH.
|
||||||
|
|
||||||
|
Inspired by
|
||||||
|
http://git.yoctoproject.org/clean/cgit.cgi/poky/plain/meta/recipes-devtools/gdb/gdb/0004-ppc-ptrace-Define-pt_regs-uapi_pt_regs-on-GLIBC-syst.patch,
|
||||||
|
adapted for SuperH.
|
||||||
|
|
||||||
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||||
|
[Rebase on gdb 8.0]
|
||||||
|
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
||||||
|
---
|
||||||
|
gdbserver/linux-sh-low.cc | 8 ++++++++
|
||||||
|
1 file changed, 8 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/gdbserver/linux-sh-low.cc b/gdbserver/linux-sh-low.cc
|
||||||
|
index 782b8292010..e42f29b845a 100644
|
||||||
|
--- a/gdbserver/linux-sh-low.cc
|
||||||
|
+++ b/gdbserver/linux-sh-low.cc
|
||||||
|
@@ -76,7 +76,15 @@ extern const struct target_desc *tdesc_sh;
|
||||||
|
#include <sys/reg.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#if !defined(__GLIBC__)
|
||||||
|
+# define pt_regs uapi_pt_regs
|
||||||
|
+# define pt_dspregs uapi_pt_dspregs
|
||||||
|
+#endif
|
||||||
|
#include <asm/ptrace.h>
|
||||||
|
+#if !defined(__GLIBC__)
|
||||||
|
+# undef pt_regs
|
||||||
|
+# undef pt_dspregs
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
#define sh_num_regs 41
|
||||||
|
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
40
package/gdb/13.2/0003-use-asm-sgidefs.h.patch
Normal file
40
package/gdb/13.2/0003-use-asm-sgidefs.h.patch
Normal file
@ -0,0 +1,40 @@
|
|||||||
|
From 7f05121278d5d5a1939276cfd9f913a0bbe004e1 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Andre McCurdy <amccurdy@gmail.com>
|
||||||
|
Date: Sat, 30 Apr 2016 15:29:06 -0700
|
||||||
|
Subject: [PATCH] use <asm/sgidefs.h>
|
||||||
|
|
||||||
|
Build fix for MIPS with musl libc
|
||||||
|
|
||||||
|
The MIPS specific header <sgidefs.h> is provided by glibc and uclibc
|
||||||
|
but not by musl. Regardless of the libc, the kernel headers provide
|
||||||
|
<asm/sgidefs.h> which provides the same definitions, so use that
|
||||||
|
instead.
|
||||||
|
|
||||||
|
Upstream-Status: Pending
|
||||||
|
|
||||||
|
[Vincent:
|
||||||
|
Taken from: https://sourceware.org/bugzilla/show_bug.cgi?id=21070]
|
||||||
|
|
||||||
|
Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
|
||||||
|
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||||
|
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
||||||
|
---
|
||||||
|
gdb/mips-linux-nat.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/gdb/mips-linux-nat.c b/gdb/mips-linux-nat.c
|
||||||
|
index 972b5db8e76..e3d838dd9a4 100644
|
||||||
|
--- a/gdb/mips-linux-nat.c
|
||||||
|
+++ b/gdb/mips-linux-nat.c
|
||||||
|
@@ -31,7 +31,7 @@
|
||||||
|
#include "gdb_proc_service.h"
|
||||||
|
#include "gregset.h"
|
||||||
|
|
||||||
|
-#include <sgidefs.h>
|
||||||
|
+#include <asm/sgidefs.h>
|
||||||
|
#include "nat/gdb_ptrace.h"
|
||||||
|
#include <asm/ptrace.h>
|
||||||
|
#include "inf-ptrace.h"
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
63
package/gdb/13.2/0004-gdbserver-fix-build-for-m68k.patch
Normal file
63
package/gdb/13.2/0004-gdbserver-fix-build-for-m68k.patch
Normal file
@ -0,0 +1,63 @@
|
|||||||
|
From e1eef0a642f7aa8aa6071b99b7c0119c436dec11 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Romain Naour <romain.naour@gmail.com>
|
||||||
|
Date: Fri, 22 Jun 2018 22:40:26 +0200
|
||||||
|
Subject: [PATCH] gdbserver: fix build for m68k
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
As for strace [1], when <sys/reg.h> is included after <linux/ptrace.h>,
|
||||||
|
the build fails on m68k with the following diagnostics:
|
||||||
|
|
||||||
|
In file included from ./../nat/linux-ptrace.h:28:0,
|
||||||
|
from linux-low.h:27,
|
||||||
|
from linux-m68k-low.c:20:
|
||||||
|
[...]/usr/include/sys/reg.h:26:3: error: expected identifier before numeric constant
|
||||||
|
PT_D1 = 0,
|
||||||
|
^
|
||||||
|
[...]usr/include/sys/reg.h:26:3: error: expected « } » before numeric constant
|
||||||
|
[...]usr/include/sys/reg.h:26:3: error: expected unqualified-id before numeric constant
|
||||||
|
In file included from linux-m68k-low.c:27:0:
|
||||||
|
[...]usr/include/sys/reg.h:99:1: error: expected declaration before « } » token
|
||||||
|
};
|
||||||
|
^
|
||||||
|
|
||||||
|
Fix this by moving <sys/reg.h> on top of "linux-low.h".
|
||||||
|
|
||||||
|
[1] https://github.com/strace/strace/commit/6ebf6c4f9e5ebca123a5b5f24afe67cf0473cf92
|
||||||
|
|
||||||
|
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
||||||
|
---
|
||||||
|
gdbserver/linux-m68k-low.cc | 9 +++++----
|
||||||
|
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/gdbserver/linux-m68k-low.cc b/gdbserver/linux-m68k-low.cc
|
||||||
|
index 6094fd914f5..3613d9f642a 100644
|
||||||
|
--- a/gdbserver/linux-m68k-low.cc
|
||||||
|
+++ b/gdbserver/linux-m68k-low.cc
|
||||||
|
@@ -17,6 +17,11 @@
|
||||||
|
along with this program. If not, see <http://www.gnu.org/licenses/>. */
|
||||||
|
|
||||||
|
#include "server.h"
|
||||||
|
+
|
||||||
|
+#ifdef HAVE_SYS_REG_H
|
||||||
|
+#include <sys/reg.h>
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
#include "linux-low.h"
|
||||||
|
|
||||||
|
/* Linux target op definitions for the m68k architecture. */
|
||||||
|
@@ -80,10 +85,6 @@ m68k_target::low_decr_pc_after_break ()
|
||||||
|
void init_registers_m68k (void);
|
||||||
|
extern const struct target_desc *tdesc_m68k;
|
||||||
|
|
||||||
|
-#ifdef HAVE_SYS_REG_H
|
||||||
|
-#include <sys/reg.h>
|
||||||
|
-#endif
|
||||||
|
-
|
||||||
|
#define m68k_num_regs 29
|
||||||
|
#define m68k_num_gregs 18
|
||||||
|
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
@ -0,0 +1,53 @@
|
|||||||
|
From 1527c8a790f50be8386eef413483248ff281ed28 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||||
|
Date: Sun, 24 Jun 2018 23:33:55 +0200
|
||||||
|
Subject: [PATCH] nat/fork-inferior: include linux-ptrace.h
|
||||||
|
|
||||||
|
To decide whether fork() or vfork() should be used, fork-inferior.c
|
||||||
|
uses the following test:
|
||||||
|
|
||||||
|
#if !(defined(__UCLIBC__) && defined(HAS_NOMMU))
|
||||||
|
|
||||||
|
However, HAS_NOMMU is never defined, because it gets defined in
|
||||||
|
linux-ptrace.h, which is not included by fork-inferior.c. Due to this,
|
||||||
|
gdbserver fails to build on noMMU architectures. This commit fixes
|
||||||
|
that by simply including linux-ptrace.h.
|
||||||
|
|
||||||
|
This bug was introduced by commit
|
||||||
|
2090129c36c7e582943b7d300968d19b46160d84 ("Share fork_inferior et al
|
||||||
|
with gdbserver"). Indeed, the same fork()/vfork() selection was done,
|
||||||
|
but in another file where linux-ptrace.h was included.
|
||||||
|
|
||||||
|
Fixes the following build issue:
|
||||||
|
|
||||||
|
../nat/fork-inferior.c: In function 'pid_t fork_inferior(const char*, const string&, char**, void (*)(), void (*)(int), void (*)(), const char*, void (*)(const char*, char* const*, char* const*))':
|
||||||
|
../nat/fork-inferior.c:376:11: error: 'fork' was not declared in this scope
|
||||||
|
pid = fork ();
|
||||||
|
^~~~
|
||||||
|
../nat/fork-inferior.c:376:11: note: suggested alternative: 'vfork'
|
||||||
|
pid = fork ();
|
||||||
|
^~~~
|
||||||
|
vfork
|
||||||
|
|
||||||
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||||
|
[Romain: rebase on gdb 8.3]
|
||||||
|
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
||||||
|
---
|
||||||
|
gdb/nat/fork-inferior.c | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/gdb/nat/fork-inferior.c b/gdb/nat/fork-inferior.c
|
||||||
|
index 968983b2021..8ef620c7193 100644
|
||||||
|
--- a/gdb/nat/fork-inferior.c
|
||||||
|
+++ b/gdb/nat/fork-inferior.c
|
||||||
|
@@ -27,6 +27,7 @@
|
||||||
|
#include "gdbsupport/pathstuff.h"
|
||||||
|
#include "gdbsupport/signals-state-save-restore.h"
|
||||||
|
#include "gdbsupport/gdb_tilde_expand.h"
|
||||||
|
+#include "linux-ptrace.h"
|
||||||
|
#include <vector>
|
||||||
|
|
||||||
|
extern char **environ;
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
@ -0,0 +1,39 @@
|
|||||||
|
From a9a4213216d95b4e7cbe4f96d993233bfa2f21e6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Peter Seiderer <ps.report@gmx.net>
|
||||||
|
Date: Sat, 6 Nov 2021 10:06:25 +0100
|
||||||
|
Subject: [PATCH] Fix getrandom compile for uclibc < v1.0.35
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
- fix getrandom compile for uclibc < v1.0.35, add missing stddef.h
|
||||||
|
include (fixed in uclibc since v1.0.35, see [1])
|
||||||
|
|
||||||
|
Fixes:
|
||||||
|
|
||||||
|
.../host/x86_64-buildroot-linux-uclibc/sysroot/usr/include/sys/random.h:27:35: error: unknown type name ‘size_t’
|
||||||
|
27 | extern int getrandom(void *__buf, size_t count, unsigned int flags)
|
||||||
|
| ^~~~~~
|
||||||
|
|
||||||
|
[1] https://cgit.uclibc-ng.org/cgi/cgit/uclibc-ng.git/commit/?id=00972c02c2b6e0a95d5def4a71bdfb188e091782t
|
||||||
|
|
||||||
|
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
||||||
|
---
|
||||||
|
gnulib/import/getrandom.c | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/gnulib/import/getrandom.c b/gnulib/import/getrandom.c
|
||||||
|
index e1468730933..3948d8d552a 100644
|
||||||
|
--- a/gnulib/import/getrandom.c
|
||||||
|
+++ b/gnulib/import/getrandom.c
|
||||||
|
@@ -19,6 +19,7 @@
|
||||||
|
|
||||||
|
#include <config.h>
|
||||||
|
|
||||||
|
+#include <stddef.h>
|
||||||
|
#include <sys/random.h>
|
||||||
|
|
||||||
|
#include <errno.h>
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
60
package/gdb/13.2/0007-fix-musl-build-on-riscv.patch
Normal file
60
package/gdb/13.2/0007-fix-musl-build-on-riscv.patch
Normal file
@ -0,0 +1,60 @@
|
|||||||
|
From dcadf89351e1944986d3f8c96081142b65f131eb Mon Sep 17 00:00:00 2001
|
||||||
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||||
|
Date: Wed, 10 Nov 2021 23:14:54 +0100
|
||||||
|
Subject: [PATCH] fix musl build on riscv
|
||||||
|
|
||||||
|
Fix the following build failure raised with musl:
|
||||||
|
|
||||||
|
../../gdbserver/linux-riscv-low.cc: In function 'void riscv_fill_fpregset(regcache*, void*)':
|
||||||
|
../../gdbserver/linux-riscv-low.cc:140:19: error: 'ELF_NFPREG' was not declared in this scope; did you mean 'ELF_NGREG'?
|
||||||
|
140 | for (i = 0; i < ELF_NFPREG - 1; i++, regbuf += flen)
|
||||||
|
| ^~~~~~~~~~
|
||||||
|
| ELF_NGREG
|
||||||
|
|
||||||
|
musl fixed the issue with
|
||||||
|
https://git.musl-libc.org/cgit/musl/commit/?id=e5d2823631bbfebacf48e1a34ed28f28d7cb2570
|
||||||
|
|
||||||
|
Fixes:
|
||||||
|
- http://autobuild.buildroot.org/results/16b19198980ce9c81a618b3f6e8dc9fe28247a28
|
||||||
|
|
||||||
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||||
|
---
|
||||||
|
gdb/nat/riscv-linux-tdesc.c | 5 +++++
|
||||||
|
gdbserver/linux-riscv-low.cc | 5 +++++
|
||||||
|
2 files changed, 10 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/gdb/nat/riscv-linux-tdesc.c b/gdb/nat/riscv-linux-tdesc.c
|
||||||
|
index d676233cc31..b620aab5b72 100644
|
||||||
|
--- a/gdb/nat/riscv-linux-tdesc.c
|
||||||
|
+++ b/gdb/nat/riscv-linux-tdesc.c
|
||||||
|
@@ -31,6 +31,11 @@
|
||||||
|
# define NFPREG 33
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+/* Work around musl breakage since version 1.1.24. */
|
||||||
|
+#ifndef ELF_NFPREG
|
||||||
|
+# define ELF_NFPREG 33
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
/* See nat/riscv-linux-tdesc.h. */
|
||||||
|
|
||||||
|
struct riscv_gdbarch_features
|
||||||
|
diff --git a/gdbserver/linux-riscv-low.cc b/gdbserver/linux-riscv-low.cc
|
||||||
|
index 129bc3b138b..a813a897de4 100644
|
||||||
|
--- a/gdbserver/linux-riscv-low.cc
|
||||||
|
+++ b/gdbserver/linux-riscv-low.cc
|
||||||
|
@@ -30,6 +30,11 @@
|
||||||
|
# define NFPREG 33
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+/* Work around musl breakage since version 1.1.24. */
|
||||||
|
+#ifndef ELF_NFPREG
|
||||||
|
+# define ELF_NFPREG 33
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
/* Linux target op definitions for the RISC-V architecture. */
|
||||||
|
|
||||||
|
class riscv_target : public linux_process_target
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
@ -0,0 +1,38 @@
|
|||||||
|
From a4535ce245a0675399877c62a9a12fb0fd36b510 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||||
|
Date: Thu, 18 Nov 2021 22:52:08 +0100
|
||||||
|
Subject: [PATCH] gdbserver/Makefile.in: fix NLS build
|
||||||
|
|
||||||
|
Fix the following build failure raised since gdb version 10.1 and
|
||||||
|
https://sourceware.org/git/?p=binutils-gdb.git;a=commit;h=9a665d62266e75f0519f3a663784c458885b5c63:
|
||||||
|
|
||||||
|
CXXLD libinproctrace.so
|
||||||
|
/home/buildroot/autobuild/instance-2/output-1/host/opt/ext-toolchain/bin/../lib/gcc/i586-buildroot-linux-musl/9.3.0/../../../../i586-buildroot-linux-musl/bin/ld: gdbsupport/tdesc-ipa.o: in function `print_xml_feature::visit(tdesc_type_builtin const*)':
|
||||||
|
/home/buildroot/autobuild/instance-2/output-1/build/gdb-10.2/build/gdbserver/../../gdbserver/../gdbsupport/tdesc.cc:310: undefined reference to `libintl_gettext'
|
||||||
|
|
||||||
|
Fixes:
|
||||||
|
- http://autobuild.buildroot.org/results/faacc874fe9d32b74cb3d3dea988ef661cb0e3d0
|
||||||
|
|
||||||
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||||
|
[Upstream status:
|
||||||
|
https://sourceware.org/pipermail/gdb-patches/2021-November/183580.html]
|
||||||
|
---
|
||||||
|
gdbserver/Makefile.in | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/gdbserver/Makefile.in b/gdbserver/Makefile.in
|
||||||
|
index 040f0b6faa0..07ca24cef5c 100644
|
||||||
|
--- a/gdbserver/Makefile.in
|
||||||
|
+++ b/gdbserver/Makefile.in
|
||||||
|
@@ -389,7 +389,7 @@ $(IPA_LIB): $(sort $(IPA_OBJS)) ${CDEPS}
|
||||||
|
$(ECHO_CXXLD) $(CC_LD) -shared -fPIC -Wl,--soname=$(IPA_LIB) \
|
||||||
|
-Wl,--no-undefined $(INTERNAL_CFLAGS) $(INTERNAL_LDFLAGS) \
|
||||||
|
$(CXXFLAGS) \
|
||||||
|
- -o $(IPA_LIB) ${IPA_OBJS} $(LIBIBERTY_FOR_SHLIB) -ldl -pthread
|
||||||
|
+ -o $(IPA_LIB) ${IPA_OBJS} $(LIBIBERTY_FOR_SHLIB) -ldl -pthread $(INTL)
|
||||||
|
|
||||||
|
# Put the proper machine-specific files first, so M-. on a machine
|
||||||
|
# specific routine gets the one for the correct machine.
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
57
package/gdb/13.2/0009-gdb-Fix-native-build-on-xtensa.patch
Normal file
57
package/gdb/13.2/0009-gdb-Fix-native-build-on-xtensa.patch
Normal file
@ -0,0 +1,57 @@
|
|||||||
|
From ed34c23325270b3eada8202f5478b8d53fb5846a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Romain Naour <romain.naour@gmail.com>
|
||||||
|
Date: Sun, 28 Aug 2022 23:21:37 +0200
|
||||||
|
Subject: [PATCH] gdb: Fix native build on xtensa
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
Apply a similar fix than for Alpha architecture on gdb 9:
|
||||||
|
https://sourceware.org/git/?p=binutils-gdb.git;a=commitdiff;h=7a27b85f6d9b5eea9bd1493f903158fbea4b2231
|
||||||
|
|
||||||
|
Fixes:
|
||||||
|
|
||||||
|
../../gdb/xtensa-linux-nat.c: In function ‘void fill_gregset(const regcache*, elf_greg_t (*)[128], int)’:
|
||||||
|
../../gdb/xtensa-linux-nat.c:66:17: error: ‘gdbarch_pc_regnum’ was not declared in this scope
|
||||||
|
66 | if (regnum == gdbarch_pc_regnum (gdbarch) || regnum == -1)
|
||||||
|
| ^~~~~~~~~~~~~~~~~
|
||||||
|
CXX complaints.o
|
||||||
|
../../gdb/xtensa-linux-nat.c:68:17: error: ‘gdbarch_ps_regnum’ was not declared in this scope
|
||||||
|
68 | if (regnum == gdbarch_ps_regnum (gdbarch) || regnum == -1)
|
||||||
|
| ^~~~~~~~~~~~~~~~~
|
||||||
|
../../gdb/xtensa-linux-nat.c:71:38: error: no matching function for call to ‘gdbarch_tdep::gdbarch_tdep(gdbarch*&)’
|
||||||
|
71 | if (regnum == gdbarch_tdep (gdbarch)->wb_regnum || regnum == -1)
|
||||||
|
| ^
|
||||||
|
In file included from ../../gdb/xtensa-linux-nat.c:38:
|
||||||
|
../../gdb/xtensa-tdep.h:160:8: note: candidate: ‘gdbarch_tdep::gdbarch_tdep()’
|
||||||
|
160 | struct gdbarch_tdep
|
||||||
|
| ^~~~~~~~~~~~
|
||||||
|
../../gdb/xtensa-tdep.h:160:8: note: candidate expects 0 arguments, 1 provided
|
||||||
|
../../gdb/xtensa-tdep.h:160:8: note: candidate: ‘constexpr gdbarch_tdep::gdbarch_tdep(const gdbarch_tdep&)’
|
||||||
|
../../gdb/xtensa-tdep.h:160:8: note: no known conversion for argument 1 from ‘gdbarch*’ to ‘const gdbarch_tdep&’
|
||||||
|
../../gdb/xtensa-tdep.h:160:8: note: candidate: ‘constexpr gdbarch_tdep::gdbarch_tdep(gdbarch_tdep&&)’
|
||||||
|
../../gdb/xtensa-tdep.h:160:8: note: no known conversion for argument 1 from ‘gdbarch*’ to ‘gdbarch_tdep&&’
|
||||||
|
../../gdb/xtensa-linux-nat.c:72:49: error: no matching function for call to ‘gdbarch_tdep::gdbarch_tdep(gdbarch*&)’
|
||||||
|
72 | regcache->raw_collect (gdbarch_tdep (gdbarch)->wb_regnum,
|
||||||
|
| ^
|
||||||
|
|
||||||
|
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
||||||
|
---
|
||||||
|
gdb/xtensa-linux-nat.c | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/gdb/xtensa-linux-nat.c b/gdb/xtensa-linux-nat.c
|
||||||
|
index e3da3c6a7a5..61834bc28d0 100644
|
||||||
|
--- a/gdb/xtensa-linux-nat.c
|
||||||
|
+++ b/gdb/xtensa-linux-nat.c
|
||||||
|
@@ -36,6 +36,7 @@
|
||||||
|
|
||||||
|
#include "gregset.h"
|
||||||
|
#include "xtensa-tdep.h"
|
||||||
|
+#include "gdbarch.h"
|
||||||
|
|
||||||
|
/* Defines ps_err_e, struct ps_prochandle. */
|
||||||
|
#include "gdb_proc_service.h"
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
@ -59,6 +59,9 @@ config BR2_GDB_VERSION_11
|
|||||||
config BR2_GDB_VERSION_12
|
config BR2_GDB_VERSION_12
|
||||||
bool "gdb 12.x"
|
bool "gdb 12.x"
|
||||||
|
|
||||||
|
config BR2_GDB_VERSION_13
|
||||||
|
bool "gdb 13.x"
|
||||||
|
|
||||||
endchoice
|
endchoice
|
||||||
|
|
||||||
endif
|
endif
|
||||||
@ -70,4 +73,5 @@ config BR2_GDB_VERSION
|
|||||||
default "10.2" if BR2_GDB_VERSION_10
|
default "10.2" if BR2_GDB_VERSION_10
|
||||||
default "11.2" if BR2_GDB_VERSION_11 || (!BR2_PACKAGE_HOST_GDB && !BR2_or1k)
|
default "11.2" if BR2_GDB_VERSION_11 || (!BR2_PACKAGE_HOST_GDB && !BR2_or1k)
|
||||||
default "12.1" if BR2_GDB_VERSION_12 || (!BR2_PACKAGE_HOST_GDB && BR2_or1k)
|
default "12.1" if BR2_GDB_VERSION_12 || (!BR2_PACKAGE_HOST_GDB && BR2_or1k)
|
||||||
|
default "13.2" if BR2_GDB_VERSION_13
|
||||||
depends on BR2_PACKAGE_GDB || BR2_PACKAGE_HOST_GDB
|
depends on BR2_PACKAGE_GDB || BR2_PACKAGE_HOST_GDB
|
||||||
|
@ -2,6 +2,7 @@
|
|||||||
sha512 3653762ac008e065c37cd641653184c9ff7ce51ee2222ade1122bec9d6cc64dffd4fb74888ef11ac1942064a08910e96b7865112ad37f4602eb0a16bed074caa gdb-10.2.tar.xz
|
sha512 3653762ac008e065c37cd641653184c9ff7ce51ee2222ade1122bec9d6cc64dffd4fb74888ef11ac1942064a08910e96b7865112ad37f4602eb0a16bed074caa gdb-10.2.tar.xz
|
||||||
sha512 07e9026423438049b11f4f784d57401ece4e940570f613bd6958b3714fe7fbc2c048470bcce3e7d7d9f93331cdf3881d30dcc964cb113a071143a02b28e5b127 gdb-11.2.tar.xz
|
sha512 07e9026423438049b11f4f784d57401ece4e940570f613bd6958b3714fe7fbc2c048470bcce3e7d7d9f93331cdf3881d30dcc964cb113a071143a02b28e5b127 gdb-11.2.tar.xz
|
||||||
sha512 425568d2e84672177d0fb87b1ad7daafdde097648d605e30cf0656970f66adc6a82ca2d83375ea4be583e9683a340e5bfdf5819668ddf66728200141ae50ff2d gdb-12.1.tar.xz
|
sha512 425568d2e84672177d0fb87b1ad7daafdde097648d605e30cf0656970f66adc6a82ca2d83375ea4be583e9683a340e5bfdf5819668ddf66728200141ae50ff2d gdb-12.1.tar.xz
|
||||||
|
sha512 8185d3e11ab60dafff5860a5016577bfe7dd7547ef01ebc867bc247603d82b74ff74c4f29492c7d2aee57076f52be33e289f4c6b414a4b870d4b3004909f4c34 gdb-13.2.tar.xz
|
||||||
|
|
||||||
# Locally calculated (fetched from Github)
|
# Locally calculated (fetched from Github)
|
||||||
sha512 5a2acf2fd33ab2ff589e1037ca40abda54328997dcff26b2b49b874bd3be980be5a63342962254f3c3bda98e32ce7a33af704d37353352833dee193135600458 gdb-arc-2020.09-release-gdb.tar.gz
|
sha512 5a2acf2fd33ab2ff589e1037ca40abda54328997dcff26b2b49b874bd3be980be5a63342962254f3c3bda98e32ce7a33af704d37353352833dee193135600458 gdb-arc-2020.09-release-gdb.tar.gz
|
||||||
|
Loading…
Reference in New Issue
Block a user