nezha_defconfig: bump u-boot to current top of d1-wip
This is now based on U-Boot 2022.10 and has gained SPL support, so use that instead of sun20-d1-spl. With this we can also drop the u-boot patch and patch directory. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
32c0225b72
commit
adc8355150
@ -4,34 +4,16 @@ image sdcard.img {
|
|||||||
hdimage {
|
hdimage {
|
||||||
}
|
}
|
||||||
|
|
||||||
partition boot0-1 {
|
partition u-boot {
|
||||||
in-partition-table = "no"
|
in-partition-table = false
|
||||||
image = "boot0_sdcard_sun20iw1p1.bin"
|
image = "u-boot-sunxi-with-spl.bin"
|
||||||
offset = 8K
|
offset = 8K
|
||||||
}
|
}
|
||||||
|
|
||||||
partition boot0-2 {
|
|
||||||
in-partition-table = "no"
|
|
||||||
image = "boot0_sdcard_sun20iw1p1.bin"
|
|
||||||
offset = 128K
|
|
||||||
}
|
|
||||||
|
|
||||||
partition u-boot-1 {
|
|
||||||
in-partition-table = "no"
|
|
||||||
image = "u-boot.toc1"
|
|
||||||
offset = 12M
|
|
||||||
}
|
|
||||||
|
|
||||||
partition u-boot-2 {
|
|
||||||
in-partition-table = "no"
|
|
||||||
image = "u-boot.toc1"
|
|
||||||
offset = 16400K
|
|
||||||
}
|
|
||||||
|
|
||||||
partition rootfs {
|
partition rootfs {
|
||||||
partition-type = 0x83
|
partition-type = 0x83
|
||||||
image = "rootfs.ext4"
|
image = "rootfs.ext4"
|
||||||
bootable = "true"
|
bootable = "true"
|
||||||
offset = 18M
|
offset = 1M
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
@ -1,54 +0,0 @@
|
|||||||
From 4a923e0e4ef6d2b41cb89d658e269adada847573 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Peter Korsgaard <peter@korsgaard.com>
|
|
||||||
Date: Thu, 4 Nov 2021 22:32:04 +0100
|
|
||||||
Subject: [PATCH] Makefile: HACK: Support building u-boot.toc1 for nezda board
|
|
||||||
|
|
||||||
For easier integration into Buildroot. The boot0 / toc1 logic is WIP until
|
|
||||||
U-Boot gains SPL support for the D1, so add a hack to make it easier to
|
|
||||||
integrate in Buildroot as-is.
|
|
||||||
|
|
||||||
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
|
|
||||||
---
|
|
||||||
Makefile | 9 +++++++++
|
|
||||||
nezha.cfg | 9 +++++++++
|
|
||||||
2 files changed, 18 insertions(+)
|
|
||||||
create mode 100644 nezha.cfg
|
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
|
||||||
index f911f70344..259d93bf80 100644
|
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -1084,6 +1084,15 @@ endif
|
|
||||||
.binman_stamp: FORCE
|
|
||||||
@touch $@
|
|
||||||
|
|
||||||
+fw_dynamic.bin: $(OPENSBI)
|
|
||||||
+ $(call if_changed,copy)
|
|
||||||
+
|
|
||||||
+MKIMAGEFLAGS_u-boot.toc1 = -T sunxi_toc1
|
|
||||||
+u-boot.toc1: nezha.cfg fw_dynamic.bin inputs
|
|
||||||
+ $(call if_changed,mkimage)
|
|
||||||
+
|
|
||||||
+all: u-boot.toc1
|
|
||||||
+
|
|
||||||
ifeq ($(CONFIG_DEPRECATED),y)
|
|
||||||
$(warning "You have deprecated configuration options enabled in your .config! Please check your configuration.")
|
|
||||||
endif
|
|
||||||
diff --git a/nezha.cfg b/nezha.cfg
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000000..2d23b9b388
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/nezha.cfg
|
|
||||||
@@ -0,0 +1,9 @@
|
|
||||||
+[opensbi]
|
|
||||||
+file = fw_dynamic.bin
|
|
||||||
+addr = 0x40000000
|
|
||||||
+[dtb]
|
|
||||||
+file = arch/riscv/dts/sun20i-d1-nezha.dtb
|
|
||||||
+addr = 0x44000000
|
|
||||||
+[u-boot]
|
|
||||||
+file = u-boot-nodtb.bin
|
|
||||||
+addr = 0x4a000000
|
|
||||||
--
|
|
||||||
2.20.1
|
|
||||||
|
|
@ -1,5 +1,4 @@
|
|||||||
BR2_riscv=y
|
BR2_riscv=y
|
||||||
BR2_GLOBAL_PATCH_DIR="board/nezha/patches"
|
|
||||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_5_19=y
|
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_5_19=y
|
||||||
BR2_SYSTEM_DHCP="eth0"
|
BR2_SYSTEM_DHCP="eth0"
|
||||||
BR2_ROOTFS_OVERLAY="board/nezha/overlay"
|
BR2_ROOTFS_OVERLAY="board/nezha/overlay"
|
||||||
@ -20,18 +19,16 @@ BR2_TARGET_OPENSBI_CUSTOM_TARBALL=y
|
|||||||
BR2_TARGET_OPENSBI_CUSTOM_TARBALL_LOCATION="$(call github,smaeul,opensbi,e6793dc36a71537023f078034fe795c64a9992a3)/opensbi-e6793dc36a71537023f078034fe795c64a9992a3.tar.gz"
|
BR2_TARGET_OPENSBI_CUSTOM_TARBALL_LOCATION="$(call github,smaeul,opensbi,e6793dc36a71537023f078034fe795c64a9992a3)/opensbi-e6793dc36a71537023f078034fe795c64a9992a3.tar.gz"
|
||||||
BR2_TARGET_OPENSBI_PLAT="generic"
|
BR2_TARGET_OPENSBI_PLAT="generic"
|
||||||
# BR2_TARGET_OPENSBI_INSTALL_JUMP_IMG is not set
|
# BR2_TARGET_OPENSBI_INSTALL_JUMP_IMG is not set
|
||||||
BR2_TARGET_SUN20I_D1_SPL=y
|
|
||||||
BR2_TARGET_UBOOT=y
|
BR2_TARGET_UBOOT=y
|
||||||
BR2_TARGET_UBOOT_BUILD_SYSTEM_KCONFIG=y
|
BR2_TARGET_UBOOT_BUILD_SYSTEM_KCONFIG=y
|
||||||
BR2_TARGET_UBOOT_CUSTOM_TARBALL=y
|
BR2_TARGET_UBOOT_CUSTOM_TARBALL=y
|
||||||
BR2_TARGET_UBOOT_CUSTOM_TARBALL_LOCATION="$(call github,smaeul,u-boot,d1-2022-05-26)/uboot-d1-2022-05-26.tar.gz"
|
BR2_TARGET_UBOOT_CUSTOM_TARBALL_LOCATION="$(call github,smaeul,u-boot,528ae9bc6c55edd3ffe642734b4132a8246ea777)/uboot-528ae9bc6c55edd3ffe642734b4132a8246ea777.tar.gz"
|
||||||
BR2_TARGET_UBOOT_BOARD_DEFCONFIG="nezha"
|
BR2_TARGET_UBOOT_BOARD_DEFCONFIG="nezha"
|
||||||
BR2_TARGET_UBOOT_NEEDS_DTC=y
|
BR2_TARGET_UBOOT_NEEDS_DTC=y
|
||||||
BR2_TARGET_UBOOT_NEEDS_PYTHON3=y
|
|
||||||
BR2_TARGET_UBOOT_NEEDS_PYLIBFDT=y
|
BR2_TARGET_UBOOT_NEEDS_PYLIBFDT=y
|
||||||
BR2_TARGET_UBOOT_NEEDS_OPENSSL=y
|
BR2_TARGET_UBOOT_NEEDS_OPENSSL=y
|
||||||
BR2_TARGET_UBOOT_NEEDS_OPENSBI=y
|
BR2_TARGET_UBOOT_NEEDS_OPENSBI=y
|
||||||
# BR2_TARGET_UBOOT_FORMAT_BIN is not set
|
# BR2_TARGET_UBOOT_FORMAT_BIN is not set
|
||||||
BR2_TARGET_UBOOT_FORMAT_CUSTOM=y
|
BR2_TARGET_UBOOT_FORMAT_CUSTOM=y
|
||||||
BR2_TARGET_UBOOT_FORMAT_CUSTOM_NAME="u-boot.toc1"
|
BR2_TARGET_UBOOT_FORMAT_CUSTOM_NAME="u-boot-sunxi-with-spl.bin"
|
||||||
BR2_PACKAGE_HOST_GENIMAGE=y
|
BR2_PACKAGE_HOST_GENIMAGE=y
|
||||||
|
Loading…
Reference in New Issue
Block a user