Fix the Python build when running Linux 3.*
When compiling Python on a host running Linux 3.0, the sys.platform constant is set at "linux3". A lot of code (inside the interpreter itself, its build system and third party apps and libraries) relies on it to be linux2 on a Linux system. This leads to the build of the target python package to break. This behaviour has been reported on the Python bugtracker but is not fixed yet. http://bugs.python.org/issue12326 Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
e35921b3a0
commit
ad891ac44a
22
package/python/python-2.7-013-fix-linux-3-compilation.patch
Normal file
22
package/python/python-2.7-013-fix-linux-3-compilation.patch
Normal file
@ -0,0 +1,22 @@
|
||||
diff -r 683202530137 configure
|
||||
--- a/configure Fri Aug 12 11:40:39 2011 +0300
|
||||
+++ b/configure Fri Aug 12 14:02:18 2011 +0200
|
||||
@@ -3055,6 +3055,7 @@ then
|
||||
cygwin*) MACHDEP="cygwin";;
|
||||
darwin*) MACHDEP="darwin";;
|
||||
irix646) MACHDEP="irix6";;
|
||||
+ linux*) MACHDEP="linux2";;
|
||||
'') MACHDEP="unknown";;
|
||||
esac
|
||||
fi
|
||||
diff -r 683202530137 configure.in
|
||||
--- a/configure.in Fri Aug 12 11:40:39 2011 +0300
|
||||
+++ b/configure.in Fri Aug 12 14:02:18 2011 +0200
|
||||
@@ -307,6 +307,7 @@ then
|
||||
cygwin*) MACHDEP="cygwin";;
|
||||
darwin*) MACHDEP="darwin";;
|
||||
irix646) MACHDEP="irix6";;
|
||||
+ linux*) MACHDEP="linux2";;
|
||||
'') MACHDEP="unknown";;
|
||||
esac
|
||||
fi
|
Loading…
Reference in New Issue
Block a user