configs/qemu_ppc_mpc8544ds_defconfig: remove kernel patch
The ppc-mpc8544ds is the only qemu configuration that requires a kernel patch: board/qemu/ppc-mpc8544ds/patches/linux/0001-powerpc-Fix-mcpu-options-for-SPE-only-compiler.patch But this patch doesn't apply after a backport between v6.1.20 and v6.1.21 https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=da0beae2449376326086e9f57468fd2b64736d2a So the patch 0001-powerpc-Fix-mcpu-options-for-SPE-only-compiler.patch doesn't seem required anymore. Welcome to Buildroot buildroot login: root # uname -a Linux buildroot 6.1.28 #1 Wed May 24 09:08:27 UTC 2023 ppc GNU/Linux # cat /proc/cpuinfo processor : 0 cpu : e500v2 clock : 400.000000MHz revision : 3.0 (pvr 8021 0030) bogomips : 800.00 timebase : 400000000 platform : MPC8544 DS model : MPC8544DS Memory : 128 MB Fixes: https://gitlab.com/buildroot.org/buildroot/-/jobs/4306895282 https://bugs.busybox.net/show_bug.cgi?id=15581 Signed-off-by: Romain Naour <romain.naour@smile.fr> Cc: Jan-Benedict Glaw <jbglaw@lug-owl.de> Cc: Sebastian Weyer <sebastian.weyer@smile.fr> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
parent
e418a2c06a
commit
ad4775fb2f
@ -74,7 +74,6 @@ board/pine64/rockpro64/post-build.sh Shellcheck
|
||||
board/qemu/aarch64-sbsa/assemble-flash-images Shellcheck
|
||||
board/qemu/microblazebe-mmu/0001-net-xilinx-xemaclite-add-2.00.b-revision.patch Upstream
|
||||
board/qemu/microblazeel-mmu/0001-net-xilinx-xemaclite-add-2.00.b-revision.patch Upstream
|
||||
board/qemu/ppc-mpc8544ds/patches/linux/0001-powerpc-Fix-mcpu-options-for-SPE-only-compiler.patch Upstream
|
||||
board/qemu/x86/post-build.sh Shellcheck
|
||||
board/qemu/x86_64/post-build.sh Shellcheck
|
||||
board/qmtech/zynq/patches/linux/0001-DTS-for-QMTech-Zynq-starter-kit.patch Upstream
|
||||
|
@ -1,53 +0,0 @@
|
||||
From a0919e3177295f4aaa9006915adcddc31788d809 Mon Sep 17 00:00:00 2001
|
||||
From: Ben Hutchings <ben@decadent.org.uk>
|
||||
Date: Wed, 26 Dec 2018 00:00:40 +0000
|
||||
Subject: [PATCH] powerpc: Fix -mcpu= options for SPE-only compiler
|
||||
|
||||
GCC for Debian's "powerpcspe" architecture only supports 32-bit
|
||||
SPE targets, and using -mcpu=powerpc or -mcpu=powerpc64 is a fatal
|
||||
error.
|
||||
|
||||
* Change the test for a biarch compiler to pass both the -m32 and -m64
|
||||
options, so that it doesn't catch 32-bit-only compilers
|
||||
* Add an ifdef CONFIG_PPC64 around the 64-bit CPU option definitions
|
||||
|
||||
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
|
||||
[Romain: Patch from Debian repository:
|
||||
https://salsa.debian.org/kernel-team/linux/-/blob/buster/debian/patches/bugfix/powerpc/powerpc-fix-mcpu-options-for-spe-only-compiler.patch]
|
||||
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
||||
---
|
||||
arch/powerpc/Makefile | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/powerpc/Makefile b/arch/powerpc/Makefile
|
||||
index 5c8c06215dd4..e3dbea6d7ae0 100644
|
||||
--- a/arch/powerpc/Makefile
|
||||
+++ b/arch/powerpc/Makefile
|
||||
@@ -12,7 +12,7 @@
|
||||
# Rewritten by Cort Dougan and Paul Mackerras
|
||||
#
|
||||
|
||||
-HAS_BIARCH := $(call cc-option-yn, -m32)
|
||||
+HAS_BIARCH := $(call cc-option-yn, -m32 -m64)
|
||||
|
||||
# Set default 32 bits cross compilers for vdso and boot wrapper
|
||||
CROSS32_COMPILE ?=
|
||||
@@ -164,6 +164,7 @@ CFLAGS-$(CONFIG_PPC32) += $(call cc-option, $(MULTIPLEWORD))
|
||||
|
||||
CFLAGS-$(CONFIG_PPC32) += $(call cc-option,-mno-readonly-in-sdata)
|
||||
|
||||
+ifdef CONFIG_PPC64
|
||||
ifdef CONFIG_PPC_BOOK3S_64
|
||||
ifdef CONFIG_CPU_LITTLE_ENDIAN
|
||||
CFLAGS-$(CONFIG_GENERIC_CPU) += -mcpu=power8
|
||||
@@ -175,6 +176,7 @@ endif
|
||||
else
|
||||
CFLAGS-$(CONFIG_GENERIC_CPU) += -mcpu=powerpc64
|
||||
endif
|
||||
+endif
|
||||
|
||||
ifdef CONFIG_FUNCTION_TRACER
|
||||
CC_FLAGS_FTRACE := -pg
|
||||
--
|
||||
2.17.1
|
||||
|
@ -3,7 +3,6 @@ BR2_powerpc=y
|
||||
BR2_powerpc_8548=y
|
||||
|
||||
# System
|
||||
BR2_GLOBAL_PATCH_DIR="board/qemu/ppc-mpc8544ds/patches"
|
||||
BR2_SYSTEM_DHCP="eth0"
|
||||
|
||||
# Filesystem
|
||||
|
Loading…
Reference in New Issue
Block a user