package/libstrophe: bump to version 0.11.0
- Use official tarball (and so drop autoreconf and first patch)
- gnutls is an optional dependency since
e490011b68
https://github.com/strophe/libstrophe/releases/tag/0.11.0
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
22abc0cf45
commit
ac49e2b4f6
@ -1,20 +0,0 @@
|
||||
Make the package autoreconfigurable
|
||||
|
||||
Signed-off-by: Denis Bodor <lefinnois@lefinnois.net>
|
||||
[Gustavo: update for 0.8.8]
|
||||
|
||||
diff -Nura libstrophe-0.8.8.orig/m4/.empty libstrophe-0.8.8/m4/.empty
|
||||
--- libstrophe-0.8.8.orig/m4/.empty 1969-12-31 21:00:00.000000000 -0300
|
||||
+++ libstrophe-0.8.8/m4/.empty 2015-09-23 19:29:37.893688227 -0300
|
||||
@@ -0,0 +1,2 @@
|
||||
+
|
||||
+
|
||||
diff -Nura libstrophe-0.8.8.orig/Makefile.am libstrophe-0.8.8/Makefile.am
|
||||
--- libstrophe-0.8.8.orig/Makefile.am 2015-09-23 19:26:10.960492781 -0300
|
||||
+++ libstrophe-0.8.8/Makefile.am 2015-09-23 19:29:17.265970964 -0300
|
||||
@@ -1,4 +1,4 @@
|
||||
-AUTOMAKE_OPTIONS = subdir-objects
|
||||
+AUTOMAKE_OPTIONS = subdir-objects foreign
|
||||
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
AM_CFLAGS = -g -Wall
|
@ -1,7 +1,7 @@
|
||||
config BR2_PACKAGE_LIBSTROPHE
|
||||
bool "libstrophe"
|
||||
depends on BR2_TOOLCHAIN_HAS_THREADS
|
||||
select BR2_PACKAGE_OPENSSL
|
||||
select BR2_PACKAGE_OPENSSL if !BR2_PACKAGE_GNUTLS
|
||||
select BR2_PACKAGE_LIBXML2 if !BR2_PACKAGE_EXPAT
|
||||
help
|
||||
libstrophe is a lightweight XMPP client library written in C.
|
||||
|
@ -1,4 +1,4 @@
|
||||
# Locally calculated
|
||||
sha256 5bf0bbc555cb6059008f1b748370d4d2ee1e1fabd3eeab68475263556405ba39 libstrophe-0.10.1.tar.gz
|
||||
sha256 feafee545403d26a44aa573d4adf327d6d07ad3f3466370634d22bbac5bd49ee libstrophe-0.11.0.tar.xz
|
||||
sha256 82476f36ffd5e895a176013c0812166ba7b7d99f3d536fc7f5ed2e33e9f74a08 MIT-LICENSE.txt
|
||||
sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 GPL-LICENSE.txt
|
||||
|
@ -4,11 +4,10 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LIBSTROPHE_VERSION = 0.10.1
|
||||
LIBSTROPHE_SITE = $(call github,strophe,libstrophe,$(LIBSTROPHE_VERSION))
|
||||
LIBSTROPHE_DEPENDENCIES = openssl host-pkgconf
|
||||
# Doesn't ship configure
|
||||
LIBSTROPHE_AUTORECONF = YES
|
||||
LIBSTROPHE_VERSION = 0.11.0
|
||||
LIBSTROPHE_SOURCE = libstrophe-$(LIBSTROPHE_VERSION).tar.xz
|
||||
LIBSTROPHE_SITE = https://github.com/strophe/libstrophe/releases/download/$(LIBSTROPHE_VERSION)
|
||||
LIBSTROPHE_DEPENDENCIES = host-pkgconf
|
||||
LIBSTROPHE_LICENSE = MIT or GPL-3.0
|
||||
LIBSTROPHE_LICENSE_FILES = MIT-LICENSE.txt GPL-LICENSE.txt
|
||||
LIBSTROPHE_INSTALL_STAGING = YES
|
||||
@ -21,4 +20,12 @@ LIBSTROPHE_CONF_OPTS += --with-libxml2
|
||||
LIBSTROPHE_DEPENDENCIES += libxml2
|
||||
endif
|
||||
|
||||
ifeq ($(BR2_PACKAGE_OPENSSL),y)
|
||||
LIBSTROPHE_CONF_OPTS += --with-tls --without-gnutls
|
||||
LIBSTROPHE_DEPENDENCIES += openssl
|
||||
else
|
||||
LIBSTROPHE_CONF_OPTS += --with-gnutls --without-tls
|
||||
LIBSTROPHE_DEPENDENCIES += gnutls
|
||||
endif
|
||||
|
||||
$(eval $(autotools-package))
|
||||
|
Loading…
Reference in New Issue
Block a user