package/grpc: bump version to 1.42.0

* update patch 0001 to match changed target code
* BSD-3c and MPL-2.0 licenses were added to LICENSE

Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
Michael Nosthoff 2021-11-24 21:59:16 +01:00 committed by Arnout Vandecappelle (Essensium/Mind)
parent 50c4fd9363
commit ac0ddf8bdf
3 changed files with 19 additions and 4 deletions

View File

@ -11,6 +11,14 @@ non-POSIX function in all cases.
Upstream: https://github.com/grpc/grpc/pull/17610
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
[buildroot@heine.tech:
1.42.0 added new logic to handle older glibc without pthread_setname_np()
but is still not sufficient for all cases. So alter the patch to wrap all
this with our cmake based workaround.
See: https://github.com/grpc/grpc/pull/27540
]
Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
---
CMakeLists.txt | 6 ++++++
include/grpc/impl/codegen/port_platform.h | 2 ++
@ -37,15 +45,22 @@ diff --git a/include/grpc/impl/codegen/port_platform.h b/include/grpc/impl/codeg
index 4f213ff..55ecd9d 100644
--- a/include/grpc/impl/codegen/port_platform.h
+++ b/include/grpc/impl/codegen/port_platform.h
@@ -168,7 +168,9 @@
@@ -186,6 +186,7 @@
#endif /* _LP64 */
#ifdef __GLIBC__
#define GPR_POSIX_CRASH_HANDLER 1
+#if defined(HAVE_PTHREAD_SETNAME_NP)
#ifdef __GLIBC_PREREQ
#if __GLIBC_PREREQ(2, 12)
#define GPR_LINUX_PTHREAD_NAME 1
@@ -194,6 +195,7 @@
// musl libc & others
#define GPR_LINUX_PTHREAD_NAME 1
#endif
+#endif /* HAVE_PTHREAD_SETNAME_NP */
#include <linux/version.h>
#else /* musl libc */
#define GPR_MUSL_LIBC_COMPAT 1
--
2.26.63

View File

@ -1,3 +1,3 @@
# Locally computed
sha256 e5fb30aae1fa1cffa4ce00aa0bbfab908c0b899fcf0bbc30e268367d660d8656 grpc-1.41.0.tar.gz
sha256 cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30 LICENSE
sha256 b2f2620c762427bfeeef96a68c1924319f384e877bc0e084487601e4cc6e434c grpc-1.42.0.tar.gz
sha256 277adcc1dcef8359b1efb48e628635f88b40be8fbd64e82fd0169930d135d7a5 LICENSE

View File

@ -4,7 +4,7 @@
#
################################################################################
GRPC_VERSION = 1.41.0
GRPC_VERSION = 1.42.0
GRPC_SITE = $(call github,grpc,grpc,v$(GRPC_VERSION))
GRPC_LICENSE = Apache-2.0, BSD-3-Clause (third_party code), MPL-2.0 (etc/roots.pem)
GRPC_LICENSE_FILES = LICENSE