package/rtl8189fs: bump to latest version to fix build failure with linux >= 6.0.0

Let's also drop local patch in favor of the upstream pending patch we
already use for package rtl8189es to deal with endianness.

Fixes:
http://autobuild.buildroot.net/results/841cf9da4b07ae4bdc14d049f2585b09a95a92f5/

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Giulio Benetti 2022-10-17 22:38:28 +02:00 committed by Thomas Petazzoni
parent 0f50d96114
commit abf2593ead
4 changed files with 48 additions and 33 deletions

View File

@ -0,0 +1,40 @@
From 4a555ffb77a5947814b6c7f330968318e265c496 Mon Sep 17 00:00:00 2001
From: Giulio Benetti <giulio.benetti@benettiengineering.com>
Date: Wed, 28 Sep 2022 21:17:17 +0200
Subject: [PATCH] Makefile: move 'EXTRA_CFLAGS += $(USER_EXTRA_CFLAGS)' at the
end of EXTRA_FLAGS assignment
At the moment USER_EXTRA_CFLAGS can't override local Makfile EXTRA_CFLAGS
since it's assigned at the beginning of the Makefile. For example it's not
possible to undefine the hardcoded CONFIG_LITTLE_ENDIAN and this doesn't
allow to build these modules for big endian architectures. So let's move
the assignment of USER_EXTRA_CFLAGS to EXTRA_CFLAGS after the last
EXTRA_CFLAGS assignment.
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
[Upstream status: https://github.com/jwrdegoede/rtl8189ES_linux/pull/83]
---
Makefile | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 8fcb7bd..e4664e9 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,3 @@
-EXTRA_CFLAGS += $(USER_EXTRA_CFLAGS)
EXTRA_CFLAGS += -O1
#EXTRA_CFLAGS += -O3
#EXTRA_CFLAGS += -Wall
@@ -2239,6 +2238,8 @@ ifneq ($(USER_MODULE_NAME),)
MODULE_NAME := $(USER_MODULE_NAME)
endif
+EXTRA_CFLAGS += $(USER_EXTRA_CFLAGS)
+
ifneq ($(KERNELRELEASE),)
########### this part for *.mk ############################
--
2.34.1

View File

@ -1,30 +0,0 @@
From 480d9da302885d9e8b3d1f9c68def569e3c8a8c0 Mon Sep 17 00:00:00 2001
From: Sergey Matyukevich <geomatsi@gmail.com>
Date: Mon, 9 May 2022 00:17:21 +0300
Subject: [PATCH] Makefile: remove default endianness
There is no way to remove configuration options from EXTRA_CFLAGS
without editing Makefile. So default LE configuration can not be
conveniently replaced by BE. Remove default endianness from the
Makefile to enable its configuration via USER_EXTRA_CFLAGS.
Signed-off-by: Sergey Matyukevich <geomatsi@gmail.com>
---
Makefile | 1 -
1 file changed, 1 deletion(-)
diff --git a/Makefile b/Makefile
index dfca305..fde4e6b 100644
--- a/Makefile
+++ b/Makefile
@@ -22,7 +22,6 @@ endif
EXTRA_CFLAGS += -I$(src)/include
-EXTRA_CFLAGS += -DCONFIG_LITTLE_ENDIAN
EXTRA_CFLAGS += -DCONFIG_IOCTL_CFG80211 -DRTW_USE_CFG80211_STA_EVENT
EXTRA_LDFLAGS += --strip-debug
--
2.35.1

View File

@ -1,2 +1,2 @@
# Locally calculated
sha256 41eee18d8a4289c2eac07af3224c62214a9b694a717bf497cd34a95b955f3d49 rtl8189fs-94a61cbf46ce87b7c9b8aa53123aeb142133a3c9.tar.gz
sha256 7cc80cb85ed6e7f7d5480e6094c377d3dbcd18a57b58cfba43a7e42ea59fc8d3 rtl8189fs-c93cfd712a3acd2ecdeda19a66d269c20f8803f1.tar.gz

View File

@ -4,15 +4,20 @@
#
################################################################################
RTL8189FS_VERSION = 94a61cbf46ce87b7c9b8aa53123aeb142133a3c9
RTL8189FS_VERSION = c93cfd712a3acd2ecdeda19a66d269c20f8803f1
RTL8189FS_SITE = $(call github,jwrdegoede,rtl8189ES_linux,$(RTL8189FS_VERSION))
RTL8189FS_LICENSE = GPL-2.0
# Undefine the hardcoded CONFIG_LITTLE_ENDIAN
RTL8189FS_USER_EXTRA_CLAGS = -UCONFIG_LITTLE_ENDIAN
# Set endianness
RTL8189FS_USER_EXTRA_CLAGS += -DCONFIG_$(call qstrip,$(BR2_ENDIAN))_ENDIAN
RTL8189FS_MODULE_MAKE_OPTS = \
CONFIG_RTL8189FS=m \
KVER=$(LINUX_VERSION_PROBED) \
KSRC=$(LINUX_DIR) \
USER_EXTRA_CFLAGS="-DCONFIG_$(call qstrip,$(BR2_ENDIAN))_ENDIAN"
USER_EXTRA_CFLAGS="$(RTL8189FS_USER_EXTRA_CLAGS)"
define RTL8189FS_LINUX_CONFIG_FIXUPS
$(call KCONFIG_ENABLE_OPT,CONFIG_WIRELESS)