package/openvmtools: introduce SUBDIR variable and update patches
The Open-vm-tools package is now distributed from GitHub and a new subdirectory was introduced, which breaks the Buildroot process. This patch adds the _SUBDIR variable in the Makefile and also updates all distributed patches. Fixes: http://autobuild.buildroot.net/results/bfd10c8d454a2686ebb1c4afdb49c55e39a9dd67/ Signed-off-by: Karoly Kasza <kaszak@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
574629ffe8
commit
ab71dff0dd
@ -6,8 +6,8 @@ this case, and they break compilation.
|
||||
|
||||
Signed-off-by: Karoly Kasza <kaszak@gmail.com>
|
||||
|
||||
--- open-vm-tools-9.4.6-1770165.orig/lib/misc/msgList.c 2014-07-02 00:21:14.000000000 +0200
|
||||
+++ open-vm-tools-9.4.6-1770165/lib/misc/msgList.c 2014-07-29 13:40:40.000000000 +0200
|
||||
--- openvmtools-stable-9.10.0.orig/open-vm-tools/lib/misc/msgList.c 2015-06-17 10:01:00.000000000 +0200
|
||||
+++ openvmtools-stable-9.10.0/open-vm-tools/lib/misc/msgList.c 2015-06-17 10:01:00.000000000 +0200
|
||||
@@ -487,6 +487,7 @@
|
||||
return messages->id;
|
||||
}
|
||||
|
@ -4,14 +4,15 @@ Disable the mandatory flag -Werror in configure.ac.
|
||||
|
||||
Signed-off-by: Karoly Kasza <kaszak@gmail.com>
|
||||
|
||||
--- open-vm-tools-9.4.6-1770165.orig/configure.ac 2014-07-02 00:21:14.000000000 +0200
|
||||
+++ open-vm-tools-9.4.6-1770165/configure.ac 2014-09-15 16:03:47.565900402 +0200
|
||||
@@ -832,7 +832,7 @@
|
||||
--- openvmtools-stable-9.10.0.orig/open-vm-tools/configure.ac 2015-06-17 10:02:00.000000000 +0200
|
||||
+++ openvmtools-stable-9.10.0/open-vm-tools/configure.ac 2015-06-17 10:02:00.000000000 +0200
|
||||
@@ -935,7 +935,7 @@
|
||||
|
||||
### General flags / actions
|
||||
CFLAGS="$CFLAGS -Wall"
|
||||
-CFLAGS="$CFLAGS -Werror"
|
||||
+# CFLAGS="$CFLAGS -Werror"
|
||||
|
||||
# -Wno-unknown-pragmas is due to gcc not understanding '#pragma ident' in Xlib.h on OpenSolaris.
|
||||
for TEST_CFLAG in -Wno-pointer-sign -Wno-unused-value -fno-strict-aliasing \
|
||||
# -Wno-unknown-pragmas is due to gcc not understanding '#pragma ident'
|
||||
# in Xlib.h on OpenSolaris.
|
||||
|
||||
|
@ -4,9 +4,8 @@ This is so horribly broken for cross-compilation. :-(
|
||||
|
||||
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
||||
|
||||
diff -durN openvmtools-9.4.6-1770165.orig/m4/vmtools.m4 openvmtools-9.4.6-1770165/m4/vmtools.m4
|
||||
--- openvmtools-9.4.6-1770165.orig/m4/vmtools.m4 2014-07-02 00:21:14.000000000 +0200
|
||||
+++ openvmtools-9.4.6-1770165/m4/vmtools.m4 2014-09-21 12:39:15.901659888 +0200
|
||||
--- openvmtools-stable-9.10.0.orig/open-vm-tools/m4/vmtools.m4 2015-06-17 10:03:00.000000000 +0200
|
||||
+++ openvmtools-stable-9.10.0/open-vm-tools/m4/vmtools.m4 2015-06-17 10:03:00.000000000 +0200
|
||||
@@ -281,10 +281,10 @@
|
||||
if test "$os" = freebsd; then
|
||||
CUSTOM_$1_CPPFLAGS="-I/usr/local/include"
|
||||
|
@ -5,8 +5,8 @@ Android method.
|
||||
|
||||
Signed-off-by: Karoly Kasza <kaszak@gmail.com>
|
||||
|
||||
--- open-vm-tools-9.10.0-2476743.orig/lib/misc/idLinux.c 2015-03-29 12:19:30.776922510 +0200
|
||||
+++ open-vm-tools-9.10.0-2476743/lib/misc/idLinux.c 2015-03-29 12:30:30.000000000 +0200
|
||||
--- openvmtools-stable-9.10.0.orig/open-vm-tools/lib/misc/idLinux.c 2015-06-17 10:04:00.000000000 +0200
|
||||
+++ openvmtools-stable-9.10.0/open-vm-tools/lib/misc/idLinux.c 2015-06-17 10:04:00.000000000 +0200
|
||||
@@ -997,7 +997,7 @@
|
||||
static Bool
|
||||
IdIsSetUGid(void)
|
||||
|
@ -10,6 +10,7 @@ OPENVMTOOLS_LICENSE = LGPLv2.1
|
||||
OPENVMTOOLS_LICENSE_FILES = COPYING
|
||||
# Autoreconf needed or config/missing will run configure again at buildtime
|
||||
OPENVMTOOLS_AUTORECONF = YES
|
||||
OPENVMTOOLS_SUBDIR = open-vm-tools
|
||||
OPENVMTOOLS_CONF_OPTS = --with-dnet \
|
||||
--without-icu --without-x --without-gtk2 \
|
||||
--without-gtkmm --without-kernel-modules \
|
||||
|
Loading…
Reference in New Issue
Block a user