iprutils: bump to version 2.4.5
Rebase patch 0003 on top of 2.4.5 release. Signed-off-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
02f7dd3493
commit
ab6170ce67
@ -1,4 +1,8 @@
|
||||
iprutils: Fix static build by passing the libraries in the right order
|
||||
From 1f62dd91314b0ce6378aeafb2a03566002036326 Mon Sep 17 00:00:00 2001
|
||||
From: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
||||
Date: Thu, 11 Dec 2014 23:36:55 +0100
|
||||
Subject: [PATCH 3/3] iprutils: Fix static build by passing the libraries in
|
||||
the right order
|
||||
|
||||
This mistake was causing failures like this one:
|
||||
|
||||
@ -7,14 +11,25 @@ m_post.c:(.text+0x60): undefined reference to `wattr_on'
|
||||
http://autobuild.buildroot.net/results/500/5004e7b230635e0605acdd17d2b7d2d01fc5075c/build-end.log
|
||||
|
||||
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
||||
--- iprutils-2.4.2/Makefile.orig 2014-09-17 18:14:52.435367860 +0100
|
||||
+++ iprutils-2.4.2/Makefile 2014-09-17 18:15:09.367652526 +0100
|
||||
@@ -16,7 +16,7 @@ TAR = cd .. && tar -zcpf iprutils-$(UTIL
|
||||
[Romain: rebase on top of 2.4.5]
|
||||
Signed-off-by: Romain Naour <romain.naour@openwide.fr>
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 66c4942..18cea94 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -16,7 +16,7 @@ TAR = cd .. && tar -zcpf iprutils-$(UTILS_VER)-src.tgz --exclude .git --exclude
|
||||
all: iprconfig iprupdate iprdump iprinit iprdbg docs
|
||||
|
||||
iprconfig: iprconfig.c iprlib.o iprconfig.h
|
||||
- $(CC) $(CFLAGS) $(INCLUDEDIR) -o iprconfig iprconfig.c iprlib.o $(LDFLAGS) -lform -lpanel -lncurses -lmenu
|
||||
+ $(CC) $(CFLAGS) $(INCLUDEDIR) -o iprconfig iprconfig.c iprlib.o $(LDFLAGS) -lform -lpanel -lmenu -lncurses
|
||||
- $(CC) $(CFLAGS) $(INCLUDEDIR) -o iprconfig iprconfig.c iprlib.o $(LDFLAGS) -lform -lpanel -lncurses -lmenu -lm
|
||||
+ $(CC) $(CFLAGS) $(INCLUDEDIR) -o iprconfig iprconfig.c iprlib.o $(LDFLAGS) -lform -lpanel -lmenu -lncurses -lm
|
||||
|
||||
iprupdate: iprupdate.c iprlib.o
|
||||
$(CC) $(CFLAGS) $(INCLUDEDIR) -o iprupdate iprlib.o iprupdate.c $(LDFLAGS)
|
||||
--
|
||||
1.9.3
|
||||
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
IPRUTILS_VERSION = 2.4.2
|
||||
IPRUTILS_VERSION = 2.4.5
|
||||
IPRUTILS_SITE = http://downloads.sourceforge.net/project/iprdd/iprutils%20for%202.6%20kernels/$(IPRUTILS_VERSION)
|
||||
IPRUTILS_SOURCE = iprutils-$(IPRUTILS_VERSION)-src.tgz
|
||||
IPRUTILS_DEPENDENCIES = ncurses libsysfs pciutils
|
||||
|
Loading…
Reference in New Issue
Block a user