mesa: fix build for x86

mesa wants to compile and run gen_matypes at build time, so make sure it
gets compiled for the host and not for the target.

Closes #323.

Signed-off-by: Jim Persson <spambox@nurd.se>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Jim Persson 2009-05-19 14:22:48 +02:00 committed by Peter Korsgaard
parent a7ed91a957
commit ab59a44160

View File

@ -0,0 +1,12 @@
diff -ruN Mesa-7.2.orig/src/mesa/x86/Makefile Mesa-7.2/src/mesa/x86/Makefile
--- Mesa-7.2.orig/src/mesa/x86/Makefile 2008-08-25 16:46:47.000000000 +0200
+++ Mesa-7.2/src/mesa/x86/Makefile 2009-05-08 08:46:34.000000000 +0200
@@ -21,7 +21,7 @@
gen_matypes: gen_matypes.c
- $(CC) $(INCLUDE_DIRS) $(CFLAGS) gen_matypes.c -o gen_matypes
+ $(CC_FOR_BUILD) $(INCLUDE_DIRS) $(CFLAGS_FOR_BUILD) gen_matypes.c -o gen_matypes
# need some special rules here, unfortunately
matypes.h: ../main/mtypes.h ../tnl/t_context.h gen_matypes