buildroot: add libart package
This commit is contained in:
parent
8eb01e4a05
commit
ab36f50a82
@ -318,6 +318,7 @@ source "package/directfb/Config.in"
|
||||
source "package/fusion/Config.in"
|
||||
source "package/imagemagick/Config.in"
|
||||
source "package/jpeg/Config.in"
|
||||
source "package/libart/Config.in"
|
||||
source "package/libpng/Config.in"
|
||||
source "package/libungif/Config.in"
|
||||
source "package/sdl/Config.in"
|
||||
|
15
package/libart/Config.in
Normal file
15
package/libart/Config.in
Normal file
@ -0,0 +1,15 @@
|
||||
config BR2_PACKAGE_LIBART
|
||||
bool "libart"
|
||||
default n
|
||||
help
|
||||
Libart is a library for high-performance 2D graphics. It
|
||||
supports a very powerful imaging model, basically the same
|
||||
as SVG and the Java 2D API. It includes all PostScript
|
||||
imaging operations, and adds antialiasing and
|
||||
alpha-transparency. It is also highly tuned for incremental
|
||||
rendering. It contains data structures and algorithms suited
|
||||
to rapid, precise computation of Region of Interest, and a
|
||||
two-phase rendering pipeline optimized for interactive
|
||||
display.
|
||||
|
||||
http://www.levien.com/libart/
|
34
package/libart/libart-art-config-cross.patch
Normal file
34
package/libart/libart-art-config-cross.patch
Normal file
@ -0,0 +1,34 @@
|
||||
diff -urpN libart_lgpl-2.3.20.orig/art_config.h libart_lgpl-2.3.20/art_config.h
|
||||
--- libart_lgpl-2.3.20.orig/art_config.h 2008-04-11 10:50:04.000000000 +0200
|
||||
+++ libart_lgpl-2.3.20/art_config.h 2008-04-11 10:51:32.000000000 +0200
|
||||
@@ -1,9 +1,15 @@
|
||||
/* Automatically generated by gen_art_config.c */
|
||||
|
||||
+#include <limits.h>
|
||||
+
|
||||
#define ART_SIZEOF_CHAR 1
|
||||
#define ART_SIZEOF_SHORT 2
|
||||
#define ART_SIZEOF_INT 4
|
||||
+#if LONG_MAX == 2147483647L
|
||||
#define ART_SIZEOF_LONG 4
|
||||
+#else
|
||||
+#define ART_SIZEOF_LONG 8
|
||||
+#endif
|
||||
|
||||
typedef unsigned char art_u8;
|
||||
typedef unsigned short art_u16;
|
||||
diff -urpN libart_lgpl-2.3.20.orig/Makefile.am libart_lgpl-2.3.20/Makefile.am
|
||||
--- libart_lgpl-2.3.20.orig/Makefile.am 2008-04-11 10:50:04.000000000 +0200
|
||||
+++ libart_lgpl-2.3.20/Makefile.am 2008-04-11 10:50:31.000000000 +0200
|
||||
@@ -3,11 +3,6 @@ noinst_PROGRAMS = testart testuta gen_ar
|
||||
bin_SCRIPTS = \
|
||||
libart2-config
|
||||
|
||||
-BUILT_SOURCES = art_config.h
|
||||
-
|
||||
-art_config.h: gen_art_config$(EXEEXT)
|
||||
- ./gen_art_config > art_config.h
|
||||
-
|
||||
EXTRA_DIST = \
|
||||
libart.def \
|
||||
libart-config.in \
|
20
package/libart/libart.mk
Normal file
20
package/libart/libart.mk
Normal file
@ -0,0 +1,20 @@
|
||||
#############################################################
|
||||
#
|
||||
# libart
|
||||
#
|
||||
#############################################################
|
||||
|
||||
LIBART_VERSION = 2.3.20
|
||||
LIBART_SOURCE = libart_lgpl-$(LIBART_VERSION).tar.gz
|
||||
LIBART_SITE = http://ftp.gnome.org/pub/gnome/sources/libart_lgpl/2.3/
|
||||
LIBART_AUTORECONF = YES
|
||||
LIBART_STAGING = YES
|
||||
LIBART_TARGET = YES
|
||||
|
||||
LIBART_CONF_OPT = --target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) --build=$(GNU_HOST_NAME) \
|
||||
--prefix=/usr --sysconfdir=/etc
|
||||
|
||||
LIBART_DEPENDENCIES = uclibc
|
||||
|
||||
$(eval $(call AUTOTARGETS,package,libart))
|
Loading…
Reference in New Issue
Block a user