package/snmppp: bump to version 3.5.1
Drop non-v3 fix patch as this was upstreamed Signed-off-by: Jesse Van Gavere <jesseevg@gmail.com> Tested-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Reviewed-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
2081781833
commit
aae8ebc9a5
@ -1466,7 +1466,6 @@ package/smcroute/S41smcroute NotExecutable lib_sysv.Indent lib_sysv.Variables
|
|||||||
package/smstools3/0001-fix-Makefile.patch lib_patch.Upstream
|
package/smstools3/0001-fix-Makefile.patch lib_patch.Upstream
|
||||||
package/smstools3/0002-fix-build-with-gcc-10.x.patch lib_patch.Upstream
|
package/smstools3/0002-fix-build-with-gcc-10.x.patch lib_patch.Upstream
|
||||||
package/smstools3/S50smsd Shellcheck lib_sysv.Variables
|
package/smstools3/S50smsd Shellcheck lib_sysv.Variables
|
||||||
package/snmppp/0001-fix-build-without-v3.patch lib_patch.Upstream
|
|
||||||
package/snort/0001-configure.in-Avoid-path-poisoning-with-libpcap.patch lib_patch.Upstream
|
package/snort/0001-configure.in-Avoid-path-poisoning-with-libpcap.patch lib_patch.Upstream
|
||||||
package/snort/0002-configure.in-Allow-to-override-the-INADDR_NONE-check.patch lib_patch.Upstream
|
package/snort/0002-configure.in-Allow-to-override-the-INADDR_NONE-check.patch lib_patch.Upstream
|
||||||
package/snort/0003-configure.in-convert-AC_RUN_IFELSE-to-AC_CHECK_MEMBE.patch lib_patch.Upstream
|
package/snort/0003-configure.in-convert-AC_RUN_IFELSE-to-AC_CHECK_MEMBE.patch lib_patch.Upstream
|
||||||
|
@ -1,43 +0,0 @@
|
|||||||
fix build without v3
|
|
||||||
|
|
||||||
Fix the following build failure without version3 raised since version
|
|
||||||
3.5.0:
|
|
||||||
|
|
||||||
msgqueue.cpp: In member function 'int Snmp_pp::CSNMPMessage::ResendMessage()':
|
|
||||||
msgqueue.cpp:263:34: error: 'version3' was not declared in this scope; did you mean 'version1'?
|
|
||||||
263 | if (m_target->get_version() == version3) {
|
|
||||||
| ^~~~~~~~
|
|
||||||
| version1
|
|
||||||
|
|
||||||
Fixes:
|
|
||||||
- http://autobuild.buildroot.org/results/8ef3e4407a51c53c15e530606227338761dd905b
|
|
||||||
|
|
||||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
||||||
[Upstream status: sent to katz.agentpp.com@magenta.de]
|
|
||||||
|
|
||||||
diff -Nura snmp++-3.5.0.orig/src/msgqueue.cpp snmp++-3.5.0/src/msgqueue.cpp
|
|
||||||
--- snmp++-3.5.0.orig/src/msgqueue.cpp 2023-03-20 10:49:30.629000853 +0100
|
|
||||||
+++ snmp++-3.5.0/src/msgqueue.cpp 2023-03-20 10:51:36.880664304 +0100
|
|
||||||
@@ -260,18 +260,20 @@
|
|
||||||
m_target->set_retry(m_target->get_retry() - 1);
|
|
||||||
SetSendTime();
|
|
||||||
int status;
|
|
||||||
- if (m_target->get_version() == version3) {
|
|
||||||
#ifdef _SNMPv3
|
|
||||||
+ if (m_target->get_version() == version3) {
|
|
||||||
// delete entry in cache
|
|
||||||
if (m_snmp->get_mpv3())
|
|
||||||
m_snmp->get_mpv3()->delete_from_cache(m_pdu.get_request_id());
|
|
||||||
-#endif
|
|
||||||
status = m_snmp->snmp_engine(m_pdu, m_pdu.get_error_status(), m_pdu.get_error_index(),
|
|
||||||
*m_target, m_callBack, m_callData, m_socket, 0, this);
|
|
||||||
}
|
|
||||||
else {
|
|
||||||
+#endif
|
|
||||||
status = send_snmp_request(m_socket, m_rawPdu, m_rawPduLen, *m_address);
|
|
||||||
+#ifdef _SNMPv3
|
|
||||||
}
|
|
||||||
+#endif
|
|
||||||
if (status != 0)
|
|
||||||
return SNMP_CLASS_TL_FAILED;
|
|
||||||
|
|
@ -1,3 +1,3 @@
|
|||||||
# Locally computed:
|
# Locally computed:
|
||||||
sha256 43a433bd5f6fd67add5a26add6521ca664c41aead438405658ed57483664b4bf snmp++-3.5.0.tar.gz
|
sha256 034553f7cb75d7ce1fe70cb3ba06e88587b6bca4fa062d10344ce4555a1395f7 snmp++-3.5.1.tar.gz
|
||||||
sha256 61337e799c8274e596e5783b22607beea8073ee296c6b27fc5c7487296e56851 src/v3.cpp
|
sha256 61337e799c8274e596e5783b22607beea8073ee296c6b27fc5c7487296e56851 src/v3.cpp
|
||||||
|
@ -4,7 +4,7 @@
|
|||||||
#
|
#
|
||||||
################################################################################
|
################################################################################
|
||||||
|
|
||||||
SNMPPP_VERSION = 3.5.0
|
SNMPPP_VERSION = 3.5.1
|
||||||
SNMPPP_SOURCE = snmp++-$(SNMPPP_VERSION).tar.gz
|
SNMPPP_SOURCE = snmp++-$(SNMPPP_VERSION).tar.gz
|
||||||
SNMPPP_SITE = http://www.agentpp.com/download
|
SNMPPP_SITE = http://www.agentpp.com/download
|
||||||
SNMPPP_DEPENDENCIES = host-pkgconf
|
SNMPPP_DEPENDENCIES = host-pkgconf
|
||||||
|
Loading…
Reference in New Issue
Block a user