package/gawk: drop incorrect patch

Commit 8cd06967b9 (gawk: bump version and migrate to autotargets)
added a patch that purportedly reduced the installation size by not
installing the versioned program (gawk-X.Y).

However, the versioned program is a hard-link to the unversioned one,
so, save for a directory entry, it does not take extra space in the
final image.

Drop that patch.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Yann E. MORIN 2022-10-31 08:26:34 +01:00 committed by Thomas Petazzoni
parent b9dd9ee857
commit aaba432e2c

View File

@ -1,16 +0,0 @@
Disabled versioned installation of binaries to save space.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
[Gustavo: update for 4.1.2]
diff -Nura gawk-4.1.2.orig/Makefile.in gawk-4.1.2/Makefile.in
--- gawk-4.1.2.orig/Makefile.in 2015-04-29 16:11:09.367925925 -0300
+++ gawk-4.1.2/Makefile.in 2015-04-29 16:11:25.308466495 -0300
@@ -1173,6 +1173,7 @@
# (This is done universally, which may not always be right, but
# there's no easy way to distinguish GNU from non-GNU systems.)
install-exec-hook:
+foo:
(cd $(DESTDIR)$(bindir); \
$(LN) gawk$(EXEEXT) gawk-$(VERSION)$(EXEEXT) 2>/dev/null ; \
if [ ! -f awk$(EXEEXT) ]; \