setserial: convert to autotargets and fix manpages install

Close #2269

[Peter: fix Makefile patch to not strip wrong file, rename hayes patch]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Thomas Petazzoni 2010-07-25 16:53:51 +02:00 committed by Peter Korsgaard
parent 5ca30174bf
commit aaa2b660a9
4 changed files with 42 additions and 11 deletions

View File

@ -27,10 +27,10 @@
libgpg-error, libidn, liblockfile, libpng, lighttpd, links,
linux-fusion, lmbench, lrzsz, ltrace, make, module-init-tools,
mplayer, mysql_client, nbd, ncurses, neon, netcat, netperf,
ntfsprogs, openssl, php, qt, quagga, sqlite, sdl, sdl_mixer,
sdl_sound, sdl_ttf, squashfs, swfdec, tftpd, thttpd, tn5250,
tremor, usbutils, webif, wireless_tools, xkeyboard-config,
xserver_xorg-server, xvkbd
ntfsprogs, openssl, php, qt, quagga, setserial, sdl, sdl_mixer,
sdl_sound, sdl_ttf, sqlite, squashfs, swfdec, tftpd, thttpd,
tn5250, tremor, usbutils, webif, wireless_tools,
xkeyboard-config, xserver_xorg-server, xvkbd
Removed packages: modutils, portage, rxvt
@ -81,6 +81,7 @@
#2233: Atmel atstk target skeletons have /etc/mtab as a file, not ...
#2245: Netcat does not work due to incorrect assumptions about signed..
#2251: directory output/build after make *_defconfig not found
#2269: setserial causes make error
2010.05, Released May 30th, 2010:

View File

@ -0,0 +1,28 @@
Install the setserial program in /usr/bin instead of /bin, and make
sure that the directories (especially the manpages directory) are
created before installing files to them. This is similar to what
automake does.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
Makefile.in | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
Index: setserial-2.17/Makefile.in
===================================================================
--- setserial-2.17.orig/Makefile.in
+++ setserial-2.17/Makefile.in
@@ -26,9 +26,10 @@ setserial.cat: setserial.8
nroff -man setserial.8 > setserial.cat
install: setserial setserial.8
- $(INSTALL_PROGRAM) setserial $(DESTDIR)/bin
- $(STRIP) $(DESTDIR)/bin/setserial
- $(INSTALL_DATA) setserial.8 $(DESTDIR)/usr/man/man8
+ mkdir -p $(DESTDIR)/usr/bin
+ $(INSTALL_PROGRAM) setserial $(DESTDIR)/usr/bin
+ mkdir -p $(DESTDIR)/usr/share/man/man8
+ $(INSTALL_DATA) setserial.8 $(DESTDIR)/usr/share/man/man8
clean:
$(RM) setserial setserial.o setserial.cat *~

View File

@ -3,16 +3,18 @@
# Setserial
#
#############################################################
SETSERIAL_VERSION:=2.17
SETSERIAL_PATCH_VERSION:=.orig
SETSERIAL_PATCH_FILE:=setserial_2.17-45.diff.gz
SETSERIAL_SOURCE:=setserial_$(SETSERIAL_VERSION)$(SETSERIAL_PATCH_VERSION).tar.gz
SETSERIAL_SITE:=$(BR2_DEBIAN_MIRROR)/debian/pool/main/s/setserial/
SETSERIAL_INSTALL_TARGET_OPT=DESTDIR=$(TARGET_DIR) install
SETSERIAL_VERSION = 2.17
SETSERIAL_PATCH = setserial_2.17-45.2.diff.gz
SETSERIAL_SOURCE = setserial_$(SETSERIAL_VERSION).orig.tar.gz
SETSERIAL_SITE = $(BR2_DEBIAN_MIRROR)/debian/pool/main/s/setserial/
SETSERIAL_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
define SETSERIAL_APPLY_DEBIAN_PATCHES
# Touching gorhack.h is needed for the Debian patch 18 to work
if [ -d $(@D)/debian/patches ]; then \
toolchain/patch-kernel.sh $(@D) $(@D)/debian/patches \*.patch; \
touch $(@D)/gorhack.h; \
rm $(@D)/debian/patches/01_makefile.dpatch; \
toolchain/patch-kernel.sh $(@D) $(@D)/debian/patches *.dpatch; \
fi
endef