package/grpc: bump to version 1.50.0
drop cross-compile patch which is now upstream (again). Signed-off-by: Michael Nosthoff <buildroot@heine.tech> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
6833dd5079
commit
a9f5a9926f
@ -1,43 +0,0 @@
|
||||
From 6798193f062676fddf7fee6d0c928f8ce6d92894 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Nosthoff <buildroot@heine.tech>
|
||||
Date: Thu, 21 Jul 2022 22:14:32 +0200
|
||||
Subject: [PATCH] cmake: fix cross-compilation with
|
||||
gRPC_BUILD_GRPC_CPP_PLUGIN=OFF
|
||||
|
||||
commit 99752b173cfa reintroduced the cross-compilation issue which was fixed by da10b795e177
|
||||
|
||||
upstream PR: https://github.com/grpc/grpc/pull/30378
|
||||
|
||||
Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
|
||||
|
||||
---
|
||||
CMakeLists.txt | 2 +-
|
||||
templates/CMakeLists.txt.template | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 9cad96a12f95..11e7ae2b67df 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -514,7 +514,7 @@ function(protobuf_generate_grpc_cpp_with_import_path_correction FILE_LOCATION IM
|
||||
--plugin=protoc-gen-grpc=${_gRPC_CPP_PLUGIN}
|
||||
${_protobuf_include_path}
|
||||
${REL_FIL}
|
||||
- DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/${FILE_LOCATION} ${ABS_FIL} ${_gRPC_PROTOBUF_PROTOC} grpc_cpp_plugin
|
||||
+ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/${FILE_LOCATION} ${ABS_FIL} ${_gRPC_PROTOBUF_PROTOC} ${_gRPC_CPP_PLUGIN}
|
||||
WORKING_DIRECTORY ${_gRPC_PROTO_SRCS_DIR}
|
||||
COMMENT "Running gRPC C++ protocol buffer compiler for ${IMPORT_PATH}"
|
||||
VERBATIM)
|
||||
diff --git a/templates/CMakeLists.txt.template b/templates/CMakeLists.txt.template
|
||||
index 161cf46798f1..82fe4217913a 100644
|
||||
--- a/templates/CMakeLists.txt.template
|
||||
+++ b/templates/CMakeLists.txt.template
|
||||
@@ -498,7 +498,7 @@
|
||||
--plugin=protoc-gen-grpc=<%text>${_gRPC_CPP_PLUGIN}</%text>
|
||||
<%text>${_protobuf_include_path}</%text>
|
||||
<%text>${REL_FIL}</%text>
|
||||
- DEPENDS <%text>${CMAKE_CURRENT_SOURCE_DIR}/${FILE_LOCATION}</%text> <%text>${ABS_FIL}</%text> <%text>${_gRPC_PROTOBUF_PROTOC}</%text> grpc_cpp_plugin
|
||||
+ DEPENDS <%text>${CMAKE_CURRENT_SOURCE_DIR}/${FILE_LOCATION}</%text> <%text>${ABS_FIL}</%text> <%text>${_gRPC_PROTOBUF_PROTOC}</%text> <%text>${_gRPC_CPP_PLUGIN}</%text>
|
||||
WORKING_DIRECTORY <%text>${_gRPC_PROTO_SRCS_DIR}</%text>
|
||||
COMMENT "Running gRPC C++ protocol buffer compiler for <%text>${IMPORT_PATH}</%text>"
|
||||
VERBATIM)
|
@ -1,3 +1,3 @@
|
||||
# Locally computed
|
||||
sha256 5071b630e2a14707ad060636990f1b25b0984bd168c7ea1ab95e48a3bdc0081f grpc-1.49.1.tar.gz
|
||||
sha256 76900ab068da86378395a8e125b5cc43dfae671e09ff6462ddfef18676e2165a grpc-1.50.0.tar.gz
|
||||
sha256 590198e3f305f2c347fde64d637c65492bbef554db6c8364e149cd375e3797ee LICENSE
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
GRPC_VERSION = 1.49.1
|
||||
GRPC_VERSION = 1.50.0
|
||||
GRPC_SITE = $(call github,grpc,grpc,v$(GRPC_VERSION))
|
||||
GRPC_LICENSE = Apache-2.0, BSD-3-Clause (third_party code), MPL-2.0 (etc/roots.pem)
|
||||
GRPC_LICENSE_FILES = LICENSE
|
||||
|
Loading…
Reference in New Issue
Block a user