diff --git a/package/python-sip/Config.in b/package/python-sip/Config.in
index 45e48ad00e..1f8961d0df 100644
--- a/package/python-sip/Config.in
+++ b/package/python-sip/Config.in
@@ -2,12 +2,17 @@ comment "python-sip needs a toolchain w/ C++, threads"
 	depends on BR2_USE_MMU
 	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
 
+comment "python-sip needs qt or qt5"
+	depends on BR2_USE_MMU
+	depends on BR2_INSTALL_LIBSTDCPP && BR2_TOOLCHAIN_HAS_THREADS
+	depends on !BR2_PACKAGE_QT && !BR2_PACKAGE_QT5
+
 config BR2_PACKAGE_PYTHON_SIP
 	bool "python-sip"
 	depends on BR2_INSTALL_LIBSTDCPP # qt
 	depends on BR2_TOOLCHAIN_HAS_THREADS # qt
 	depends on BR2_USE_MMU # qt
-	select BR2_PACKAGE_QT
+	depends on BR2_PACKAGE_QT || BR2_PACKAGE_QT5
 	help
 	  SIP is a tool that makes it very easy to create Python
 	  bindings for C and C++ libraries. It was originally
diff --git a/package/python-sip/python-sip.mk b/package/python-sip/python-sip.mk
index d13801fb82..0c0a94738d 100644
--- a/package/python-sip/python-sip.mk
+++ b/package/python-sip/python-sip.mk
@@ -10,7 +10,11 @@ PYTHON_SIP_SITE = http://downloads.sourceforge.net/project/pyqt/sip/sip-$(PYTHON
 PYTHON_SIP_LICENSE = SIP license or GPLv2 or GPLv3
 PYTHON_SIP_LICENSE_FILES = LICENSE LICENSE-GPL2 LICENSE-GPL3
 
+ifeq ($(BR2_PACKAGE_QT5),y)
+PYTHON_SIP_DEPENDENCIES = qt5base
+else
 PYTHON_SIP_DEPENDENCIES = qt
+endif
 
 ifeq ($(BR2_PACKAGE_PYTHON),y)
 PYTHON_SIP_DEPENDENCIES += python