statserial: don't link against legacy curses

Link against libncurses instead of the legacy libcurses.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Gustavo Zacarias 2014-07-04 14:03:01 -03:00 committed by Thomas Petazzoni
parent 1b1ed35089
commit a95b9cc124

View File

@ -0,0 +1,16 @@
Link to libncurses instead of the legacy libcurses.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
diff -Nura statserial-1.1.orig/Makefile statserial-1.1/Makefile
--- statserial-1.1.orig/Makefile 2014-07-04 12:47:41.279440415 -0300
+++ statserial-1.1/Makefile 2014-07-04 12:47:47.948665740 -0300
@@ -10,7 +10,7 @@
LDFLAGS = -s -N
statserial: statserial.o
- $(LD) $(LDFLAGS) -o statserial statserial.o -lcurses
+ $(LD) $(LDFLAGS) -o statserial statserial.o -lncurses
statserial.o: statserial.c
$(CC) $(CFLAGS) -c statserial.c