stress: new package

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Arnout Vandecappelle 2012-05-04 11:32:56 +00:00 committed by Peter Korsgaard
parent 4205dbd9f6
commit a90617b627
4 changed files with 44 additions and 0 deletions

View File

@ -37,6 +37,7 @@ source "package/netperf/Config.in"
source "package/oprofile/Config.in"
source "package/rt-tests/Config.in"
source "package/strace/Config.in"
source "package/stress/Config.in"
source "package/whetstone/Config.in"
source "package/valgrind/Config.in"
source "package/pv/Config.in"

8
package/stress/Config.in Normal file
View File

@ -0,0 +1,8 @@
config BR2_PACKAGE_STRESS
bool "stress"
help
A deliberately simple workload generator for POSIX systems.
It imposes a configurable amount of CPU, memory, I/O, and
disk stress on the system.
http://weather.ou.edu/~apw/projects/stress/

View File

@ -0,0 +1,22 @@
Remove largefile
Otherwise it doesn't compile in uClibc without largefile.
If the toolchain does support largefile, it will still work on large files
anyway.
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
Upstream status: mail sent to apw@rossby.metr.ou.edu
---
diff -rup stress-1.0.4.orig/src/Makefile.am stress-1.0.4/src/Makefile.am
--- stress-1.0.4.orig/src/Makefile.am 2009-12-03 02:04:05.000000000 +0100
+++ stress-1.0.4/src/Makefile.am 2012-05-04 23:09:48.229842463 +0200
@@ -1,7 +1,5 @@
MAINTAINERCLEANFILES = Makefile.in
-AM_CFLAGS = -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
-
bin_PROGRAMS = stress
stress_SOURCES = stress.c
stress_MANS = stress.1

13
package/stress/stress.mk Normal file
View File

@ -0,0 +1,13 @@
#############################################################
#
# stress - a workload generator
#
# http://weather.ou.edu/~apw/projects/stress/
#
#############################################################
STRESS_VERSION = 1.0.4
STRESS_SITE = http://weather.ou.edu/~apw/projects/stress
STRESS_AUTORECONF = YES
$(eval $(call AUTOTARGETS))